Crystal Rep printing Group headers

For those of you who have used Crystal reports, I have recently switched to using version 6 and I am upgrading to version 7 soon....

I have a problem with my group header where it will print on the bottom of the page even if there isnt enough room to print the other headers that come below it....  I dont want to use the "keep together" functionality because it leaves way too much white space on a sheet with split 'groups'.

The group header is reprinting fine on the top of the next page but it looks really tacky having this one down at the bottom of the page before(this page).

I have thought to use the "suppress" functionality but the formulas dont really seem to provide any viable options for figuring out where the current position is or anything like that.

Does anyone have any idea how to fix this problem?


P.S. Please dont 'answer' this question unless you know for sure or I tell you your comment is sufficient, thanks...
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.


You have to set the "keep together" option in Format sections.

This option will try to keep a Group together on a page if there is enough space, otherwise it will print it on the next page... i think you have to check this same option for the detail band of the group also.
This option can get messy if your group and detail of the group spans more than a page because it will leave a whole page blank in those scenarios.

btw: on your previous Q about a reporting tool, i don't have a prob if you want to split the points between the guys/gals that contributed.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
didn't see you already allocated the points in your prev Q.

disregard my previous comment on the issue, and thanks:)

ok, remembered i spent some time with CR tech support on this one.
There is a second Keep Together option, the one that you are looking for is under: Report / Change Group Expert / Options.

Check the Keep Together option here and uncheck Keep Together in the Format sections area of your group. This will prevent your group from breaking accross pages. My comment above still applies if the group spans more than one page.
GabeinOZAuthor Commented:

alright! works great!  I really should have figured this one myself because I had already come up against problems with the two different "keep together" settings for each group but you were right and it solved my problem so now I can move on to doing the rest of my reports confidently...

I appreciate you help greatly....

Thanks mate :)

Gabe, your'e very welcome:)
seems like your are already well up to speed with CR, good luck...:)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.