[Webinar] Streamline your web hosting managementRegister Today

x
?
Solved

FTP dosen't work at all !!!!

Posted on 1999-11-23
7
Medium Priority
?
282 Views
Last Modified: 2010-03-18
I just re-installed Red Hat 6.0, with LAN networking
and I cannot ftp to it.  I can ping from my Win98 PC, and
I can ping the Win98 PC from linux.  I can telnet from the Win98
PC though.  I notice the linux box trying to spawn the ftp daemon,
as my "ps -aef | grep ftp" command returns "in.ftpd -l -a".
I don't even get to a username
prompt, it just Says "Connection
closed by remote host" a few seconds
after typing "ftp linux1"

Help!!!!!!!!!!!!!
0
Comment
Question by:cwilliso
7 Comments
 
LVL 5

Expert Comment

by:n0thing
ID: 2229056
Could you add your Windows hostname/IP address
in the /etc/hosts and try again ??
Also check if your /etc/hosts.allow /etc/hosts.deny if the IP adresses are present and if you've activated your wrapper.
Check in the /var/log/messages for any errors.
0
 

Author Comment

by:cwilliso
ID: 2229965
what is a wrapper?
0
 

Author Comment

by:cwilliso
ID: 2231946
More clues:

1.) ftp from the linux box to its-self
yields the message: "421 - Service not
available", yet ftp is in /etc/inetd.conf and /etc/services (unchanged from initial install)

2.) ipchains was installed but _not_ configured yet.  (this shouldn't affect LAN operations right?) Telnet works fine!!!

3.) The Network card is a DEC Tulip.  This shouldn't even matter if ping is working correctly, but I mentioned it because I'm out of ideas!

4.) I did not install Anonymous-Ftp.  Would this help me out at all?

5.) Ping and telnet both work perfectly.

6.) I really need to transfer files to this unix machine.  Is there any other way to do it.  (Samba didn't work either.)
0
[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

 
LVL 5

Expert Comment

by:n0thing
ID: 2232113
If you didn't install anonymous ftp. Then you don't
have a ftp deamon. You'll need to install it.
Simply check in /usr/sbin to see if in.ftpd is there,
if it's not then you don't have any ftp deamon at
all. You could either download the source or the package or install it from your CD.  Should work fine after.
0
 

Expert Comment

by:tgreaser
ID: 2236834
have you tried to reinstall your ftp software

for instance if you installed wu-ftp

#rpm --force -ivh wu-ftpd-2.5.0-9.i386.rpm
then
kill -1 1 (<-- this has your box reread your inetd.conf file)

if you are wanting to realy share files NFS is what you realy want ..
http://www.linuxdoc.org/HOWTO/NFS-HOWTO.html

but you should get your ftp to work... this way you can share files with just about an OS..

if you want some help with the NFS just make another trouble ticket and I will be glad to give what help I can..
0
 

Author Comment

by:cwilliso
ID: 2237176
anon ftp worked -- thanks.
0
 

Accepted Solution

by:
dobriain earned 300 total points
ID: 2283973
FTP Server is disabled on most LINUX distrs by default. To enable do the following.

1. Edit /etc/inetd.conf

   Un-# the line

   ftp stream tcp nowait root /usr/sbin/tcpd in.ftpd

2. ps x|grep inetd (Find the process ID of the inetd Daemon)

    <Process ID> ? s 0:00 /usr/sbin/inetd

3. kill -HUP <process ID>
   (inetd daemon is forced it to reread inetd.conf)

   FTP Server will now be running.
0

Featured Post

Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
The video provides a quick and easy steps to migrate MBOX file to well known Outlook PST and Office 365. Besides this, it also supports and migrates more than 20 email clients of MBOX which include AppleMail, Opera, Thunderbird and SeaMonkey effortl…
Suggested Courses
Course of the Month9 days, 21 hours left to enroll

591 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question