XTerm won't open

Hi, I just installed RHL v6.1, and I
chose the enlightment WM.
Now, when I'm in the XWindows environment, and try to open a new XTerminal, it just opens this black window, with NOTHING in it. It then gets stuck, I cannot even close it.
Trying to anhiliate it resulted in 'Program won't respond to...', when I remove it, it gets removed.
I also tried the Color XTerm, didn't help.
Any suggestions?
lgadiAsked:
Who is Participating?
 
EatEmAndSmileConnect With a Mentor Commented:
I don't believe our friend's problem has anything to do with colors, since he can't even kill the window.

 I believe it doesn't have to do with Enlightenment, also.

 Igadi, what does your ~/.bash_profile look like? Please post it here. I believe your ~/.bash_profile is calling something that is messing up with your terminal.

 By the way, do you get into X automatically after logging in?

 Later.
--------------_4D4800905E98BFFFEDE4
Content-Disposition: form-data; name="notify"

on
--------------_4D4800905E98BFFFEDE4
Content-Disposition: form-data; name="Submit"

Submit
--------------_4D4800905E98BFFFEDE4--
0
 
jetxCommented:
Did you configure the XWindows properly?
you can do this via, XF86Setup

Also, make sure that XTerm will run on the default XWindows. If it runs, then it must be a problem with E.

If this all fails try to install the RPM version of E then try it again.

Please let me know what happens.
0
 
gunny051499Commented:
here you are jetx, once again telling stories!?

XF86Setup won't change your xterminals behaviour in any way. it may be a problem with Enlightenment and it's configuration of course. did you already try Eterm and xkvt?

if it's just an general problem with Enlightenment setup, you should be able to run "xterm -display localhost:0.0" on a different virtual console (pay attention to log in as the same user, or you won't be able to start it!).

any other x-applications bringing problems of some kind, likewise with fonts?
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
gunny051499Commented:
sorry, i meant kvt not xkvt.
0
 
crouchetCommented:
I imagine Xconfigurator is what you would want to use if you are planning to tinker with the Xwindows setup in RedHat, but if Enlightenment is coming up at all then you don't need to mess with that.

Have you messed with the color setting in Enlightenment at all? I once saw a similar problem that turned out to be black text displayed on a black background.

J Crouchet
0
 
crouchetCommented:
Oh, hey, also try logging on with KDE or some other windows manager and try an xterm there. That should tell you if it is an xterm problem or an Enlightenment problem.

J Crouchet
0
 
patowicCommented:
Have you tried any other window managers besides enlightenment?

Can you start X without a window manager?
0
 
EatEmAndSmileCommented:
Yeah, try Window Maker, it's a great window manager...
0
 
patowicCommented:
I'd say go with blackbox--smaller, faster, and more stable than anything else out there...  you can find it through www.freshmeat.net
0
 
lgadiAuthor Commented:
Hi,
  Well, the problem really was a
  not-so-good configuration file,
  The enlightment itself had nothing
  to do with it, Thanks
   Gadi
0
All Courses

From novice to tech pro — start learning today.