Setting the display resolution

my voodoo video card is not listed, so I tried a custom configuration. Now when I boot linux all I get is a black screen and can do nothing except a ctrl+alt+del to shutdown. Also as the system boots, it cruises straight thru the first login screen to X.
Help Meeeeeeee! please.
P.S. This is my first time with linux.
Chris112299Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chris112299Author Commented:
Edited text of question.
0
EatEmAndSmileCommented:
Let's try some stuff first. Can you get off of the X screen by pressing one of the following key sequences?

 CTRL+ALT+F1

 or

 CTRL+ALT+BACKSPACE

 If you do, you should get to the console mode, where you'd be able to log in as root and run Xconfigurator again.

 Which Voodoo model do you have? I've heard you need the SVGA server for Voodoo's, but tell me the model of your board so I could give you a more precise answer.

 Good luck!
--------------_4D48008D86DCBFFFEDE4
Content-Disposition: form-data; name="notify"

on
--------------_4D48008D86DCBFFFEDE4
Content-Disposition: form-data; name="Submit"

Submit
--------------_4D48008D86DCBFFFEDE4--
0
Chris112299Author Commented:
 My apologies. The video card is a 3dfx voodoo3 2000 pci with 16MB sdram, core clock:143mhz, ramdac:300mhz,vertical refresh rate of 60hz-160hz, api support:Direct X, Glide, Open GL
The model number is 210-0366-00x.
  The mother board is a PII @ 66mhz. W/ intel lx chipset.
the model number is P6LX-ATX. The proccesor is a300mhz Celeron A. And 96 megs SDRAM
  I am running a dual boot system with bootmagic. This is working fine with win98 on the master hdd and linux on the slave hdd.

  Now then. I had already tried to ctrl+alt+bksp to no avail.
One thing I was wondering is whether there is a way to get the boot up to stop at the first login point rather than zipping in to X.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

EatEmAndSmileCommented:
That's what I was afraid. You installed RedHat with that option to get straight into X instead of the console. This is not good. Well, you could try booting with a floppy, this would get you into console mode. You could log-in as root and try running Xconfigurator. This time, choose it not to start straight into X mode.

 I hope this solve your problem, but Ill also recommend you to change from RedHat to Slackware. On issues like easy of configuration, customization, performance and coolness Slack kicks ass. Just a recommendation, though.

 Good luck!
--------------_4D4800AB8AD8BFFFEDE4
Content-Disposition: form-data; name="notify"

on
--------------_4D4800AB8AD8BFFFEDE4
Content-Disposition: form-data; name="Submit"

Submit
--------------_4D4800AB8AD8BFFFEDE4--
0
bughead1Commented:
I agree with the previous comment: Slackware is easier in these matters...but to the problem at hand:

I have never messed with BootMagic, but if it presents a choice, try typing "Linux 3" or "Linux 1" at the boot prompt. (this works with Lilo).  

Linux 3 should cause your box to boot to multi-user character cell mode -- or Linux 1 to get to single user (root) and character cell mode. You could then try Xconfigurator again -- or even more reliable (if a bit less flashy) xf86config.

If you use Xconfigurator, just make sure you don't select the option to boot to X.  If it all works OK you can edit /etc/inittab to cause it to boot to runlevel 5 later.
0
EatEmAndSmileCommented:
That's right... In that part when Xconfigurator asks if you're seeing the screen, it then asks if you want to boot to X all the time. Answer no.
--------------_4D4800C99E10BFFFEDE4
Content-Disposition: form-data; name="notify"

on
--------------_4D4800C99E10BFFFEDE4
Content-Disposition: form-data; name="Submit"

Submit
--------------_4D4800C99E10BFFFEDE4--
0
bdukCommented:
In the absence of a suitable boot/root set with the tools you'd need to be able to fix the system from there (meaning, if you're stuck with just the boot floppy and CDROM), you can boot off the CDROM and select "rescue" mode.  When you get to the prompt, type type following:

cd tmp
mkdir t
mount (root partition) t
cd t/X11
ls -l X
(write down the exact path the link refers to)
rm X
cd /tmp
umount t <-important
CTRL-ALT-DEL (reboot)

This will make it so that when your system starts up and tries to start X-windows, it wont be able to find the link to the X server, and you'll be dumped back to a text mode login without giving X a chance to kill the system.  From there, you gotta figure out the rest of the fix to make the card work.  Running Xconfigurator again will replace the X link, or you can recreate it yourself with

ln -s /usr/X11R6/bin/XF86_SVGA (or whatever) /etc/X11/X

Be SURE to umount the root directory.  For some reason, when I tried this a hundred times without umounting the partition, it didn't save the changes I'd made.  When I tried to reboot, X was still there.

Hope this helps.  I had a nearly identical problem, almost decided to just scrap UNIX altogether and get into stamp collecting (something Windows could handle) before I figured out how to stop X from starting.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bdukCommented:
above, that was supposed to be

mount (root partition) t
cd t/etc/X11
ls -l X

sorry.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.