mouse, no keyboard

I'm trying to install RedHat 6.0 on an older p200 machine. When I boot to gnome my mouse works but the keyboard does not work! Why? The mouse is a M$ Serial 2.1a. mouseconfig is set to generic two button w/o three button emulation. I've added this script to the startup files in /rc.d/rc3.d
mouseconfig --kickstart --device cua0 I found that on Redhat's site. Please help I'm very new to this but love the power of this OS!
marxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

s_turner99Commented:
Similar thing happened to me with Microsoft Serial 2.1a mouse, I accidentally set it up as 2-button without 3-button emulation.  I my case the mouse stopped working soon after the login screen came up (but for some reason it worked for 2 or 3 seconds before that while X was initializing).

The solution?  Completely reinstall RedHat 6.0 and enable 3-button emulation.  (There was probably an easier way, but I'm new to Linux and couldn't find it.)
0
DVBCommented:
Try removing the script from rc3.d.

s_turner99, you can run Xconfigurator or xf86config to change mouse settings for Xwindows. Or you could edit the XF86Config file by hand. Its pretty well documented in the man pages.
0
marxAuthor Commented:
It's fixed! Here are the different things I tried: 1.removed the script from the startup file-no help
2.tried every mouseconfig I could think of; generic 2button w/o emulation and w/emulation,with and without the script; M$ 2.1 w/and w/o emulation, w/and w/o the script-all had the same result (mouse worked and keyboard did not work).
3.No that's not true. With some of those combinations the keyboard would work but the mouse would not.
4.Last resort, reinstall. The only thing I did differently on this install was after x tested the video settings it asks if you want x to start on bootup. I selected no rather than yes. Now the machine boots to a login prompt(text), I login and do a startx. X starts up just fine, everything works. The mouse is set to M$2.1, emulate three buttons, and no script was added. Now to the serious business of learning! A modem install later this weekend. Thanks to all! marx  
0
DVBCommented:
You could just have logged in as root in runlevel 1. (Linux 1 or Linux single at the lilo prompt) and then edited your /etc/inittab file. Change default runlevel to 3 from 5, and you would have been in text mode. init 3 will take you there directly.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
marxAuthor Commented:
Correction: when I checked my notes I saw that I did but the script in (mouseconfig --kickstart --device cua0). Thanks DVB! That probably would have worked, because I see now that's basically what I did. But I'm not sure that I know how to to edit a file like that yet. Heck, I'm still learning how to navigate the file system from the command line! But I did get sound working last night, had to disable ISA PnP in the BIOS, then used sndconfig to turn on the soundblaster16 card. That was too easy!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.