Server-status forbidden on Apache

I have mod_status compiled into my Apache 1.3.9 server but when I go to /docroot/server-status , I get a Forbidden message. I have this in my httpd.conf:

<Location>
SetHandler mod_status
<Limit GET>
Order deny,allow
Deny all
Allow 192.168.0
</Limit>
</Location>

Do I need the actual server-status folder in my document root?
sxnAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bcwhiteCommented:
Here's what I have in my conf...

httpd.conf:
LoadModule status_module /usr/lib/apache/1.3/mod_status.so
ExtendedStatus on

# Allow server status reports, with the URL of http://servername/status
# Change the ".nowhere.com" to match your domain to enable.

<Location /status>
SetHandler server-status

order deny,allow
deny from all
allow from 192.168.1.1
</Location>

Hope that helps!

-- Brian
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gunny051499Commented:
bcwhite's comment realy should be the answer ;)

sxn, if you have a look at the httpd.conf.default your apache installation created, you will find the above lines commented out...
0
TYoungCommented:
From bcwhite's comment, you can take off the some of the last digits in the ip address: 192.168.1.1 to be something like this: 192.168.1.   and have everyone with an IP beginning with that be allowed to access it.
0
Wouter WolkersCommented:
Might be my mistake, but if you stated
order deny,allow
in your config file, than you should IMHO put the allow lines before the deny lines, otherwise everything will be denied.


Order deny,allow
allow from 192.168
deny from all
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.