V.90 and non V.90 Who to connect them?

Hi guys, these are all my remaining points .

I have an NT server with an external "Motorola ModemSurf 33.6" modem that works with some old modems. It really works fine, it let me browse the whole lan and Internet when dialing in to that modem.

I have some portables with V.90 modems. They cannot connect with the server modem. The dialup connection does not go further the "Connecting..." message.

I think I cannot upgrade the 336 to V.90 (and I almost think there is nothing to do about it).

But I think I could "downgrade" or use some AT commands and say the V.90 modem to act as a 336 old one. Is this possible? I've read many pages of AT commands and I cannot complettely understand them, and all my tries just give different modem "music" with no connection.

Can somebody help me with the correct AT codes to initialize my V.90 modem (this a LTWinmodem DataFaxModem 5.15 integrated on an portable Acer Extensa368D).
LVL 2
nfernandAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rayt333Commented:
The V90 modem should drop back to the slower speeds and other standards if it cannot connect at the higher speeds or with another V90 modem.
0
nfernandAuthor Commented:
Yes... the modem's manual says that.
But it does not work.
And it's this way for 5 portable PCs.

Thanks
0
OttaCommented:
It is *NEVER* possible for two V.90 modems to connect to each other at V.90 speeds.

You always need to connect your V.90 modem to an (expensive!) V.90 modem-server, in order to get "fast" downloads *TO* your V.90 modem.

Either way, *SENDING* data from a V.90 modem is *NEVER* faster than 33600.
0
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

femson7Commented:
What modem brands are connected on those portables? You see, you might have configured those portables to CANCEL THE CALL IF NOT CONNECTED WITHIN x seconds. Also, try to locate the modem's logfile under the x:\windows directory.

0
nfernandAuthor Commented:
Thansk for answer.
I think I wasn't very clear.

My portables has V.90 modems from 3 different brands. Some are PCMCIA and another are motherboard-integrated.

The serve (and only the server) has the non V.90 Modem (Motorola ModemSURF 336)

Thanks for your help.
0
rayt333Commented:
If the modems don't drop back to the slower speed then just what does happen?
They don't connect at all?
0
nfernandAuthor Commented:
Yes, they don't connect: The answer is "You were disconnected from the remote computer"

This is the log file:
11-24-1999 13:32:26.06 - LT Win Modem in use.
11-24-1999 13:32:26.13 - Modem type: LT Win Modem
11-24-1999 13:32:26.13 - Modem inf path: LTADF.INF
11-24-1999 13:32:26.13 - Modem inf section: Modem_PNP_DSVD
11-24-1999 13:32:27.19 - 19200,N,8,1
11-24-1999 13:32:27.20 - 38400,N,8,1
11-24-1999 13:32:27.26 - Initializing modem.
11-24-1999 13:32:27.26 - Send: AT<cr>
11-24-1999 13:32:27.26 - Recv: AT<cr>
11-24-1999 13:32:27.26 - Recv: <cr><lf>OK<cr><lf>
11-24-1999 13:32:27.26 - Interpreted response: Ok
11-24-1999 13:32:27.26 - Send: AT &F E0 &C1 &D2 V1 S0=0\V1<cr>
11-24-1999 13:32:27.39 - Recv: AT &F E0 &C1 &D2 V1 S0=0\V1<cr>
11-24-1999 13:32:27.39 - Recv: <cr><lf>OK<cr><lf>
11-24-1999 13:32:27.39 - Interpreted response: Ok
11-24-1999 13:32:27.39 - Send: ATS7=60S30=0L3M1\N4%C1&K3B0B15B2N1\J1X4<cr>
11-24-1999 13:32:27.40 - Recv: <cr><lf>OK<cr><lf>
11-24-1999 13:32:27.40 - Interpreted response: Ok
11-24-1999 13:32:27.40 - Dialing.
11-24-1999 13:32:27.40 - Send: ATDT;<cr>
11-24-1999 13:32:30.18 - Recv: <cr><lf>OK<cr><lf>
11-24-1999 13:32:30.18 - Interpreted response: Ok
11-24-1999 13:32:30.18 - Dialing.
11-24-1999 13:32:30.18 - Send: ATDT#w#######<cr>
11-24-1999 13:33:40.49 - Recv: <no response>
11-24-1999 13:33:40.49 - WARNING: Unrecognized response.  Retrying...
11-24-1999 13:33:42.42 - Hanging up the modem.
11-24-1999 13:33:43.67 - Session Statistics:
11-24-1999 13:33:43.67 -                Reads : 55 bytes
11-24-1999 13:33:43.67 -                Writes: 91 bytes
11-24-1999 13:33:43.67 - LT Win Modem closed.
0
rayt333Commented:
For lack of a reason here may I make a suggestion? Can you switch the modem on your server to a V90 modem and see if that helps.
Maybe it is just the newer modems don't like the Motorola on the server now.
0
femson7Commented:
Ok, first make the DTE to read 115200... it seems that they werent able to connect because of some line problems...

DTE should read 115200 on both the modem and com ports. and be sure that the ports and modem's start and stop bits match... the 8,n,1 thing.

They haven't even reached the TCP/IP configuration block of the process, so it is the modem not being able to negotiate a link.

Goto control panel/modems/properties/advanced

uncheck error correction if it's checked;
uncheck compress data if it's checked;

do the otherwise of the above two, if they are unchecked, check them.

Try to connect again.

v90 modems handshake carrier is different from 33.6... and if the answering modem is 33.6 the originating v90 modem would use v34+ protocol. and vice versa.

So it's not really an issue of ITU-T standards, unless of course, your motorola v90s are configured to FORCE v90 connection ONLY and/or has been configured to disable v34+ or v34 or all of the lower protocols.

Your logfile implies that your dte doesn't match. Although it follows whichever is higher, but it is safe to always use 115200. And this gives you maximum throughput between your modems and your computer.
0
OttaCommented:
11-24-1999 13:32:30.18 - Send: ATDT#w#######<cr>
11-24-1999 13:33:40.49 - Recv: <no response>

What do you hear during this 70.3 seconds?

It seems that one modem "hangs-up" about 60 seconds after the last digit is "dialed".
0
nfernandAuthor Commented:
Otta: During this time sounds like one modem keeps "talking" normal, the other keeps doing a very long "beeeeeeeeeeeee"

Femson7: I'll try what you told me soon. PLease wait.

Thanks guys
0
femson7Commented:
Ok, will wait. And while you're at it, judging by the way you describe it in this last comment, and the message you were disconnected... it seems that one factor is the carrier loss detect timer is set too short....

Coz during the phase of actual connection, you can transfer some data etc... but when the modems needs to retrain, it sends some signals to the other modem, and then pauses momentarily. Total silence I mean, so that it can initiate the retrain sequence or channel equalizations routine. and if one modem's carrier loss detect time is too short, it will disconnect itself, and return that the remote modem hanged up.

Check your modem's S-Registers and other AT commands for instructions on how to set this.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nfernandAuthor Commented:
Thank you man... now let me tell you what I did:

I tried (ats28=1). The manual says its for enabling V.34 modulation but I got nothing new. Doing (ats28=0) it let the modems connect (I really don't understand why).

Now I have another (this time little) problem: they only connect at 14400. Other non V90 modems can connect at 28800. But I can live with this for a while.

Thank all of you.
0
femson7Commented:
Upgrade your INFs:

ftp://ftp.driverguide.com/archive4/127/Ms56kinf.exe --> Win95 Inf File

ftp://ftp.driverguide.com/archive4/128/Rasinf.exe  --> Windows NT 3.51 Inf File

---

Also, Motorola implemented during the beta testing phase of 56K, the K56Flex platform. Is your modem flash upgradable? If it is, have u used K56Flex before? If it's flash upgradable, you can download the bios.

Please check out this URLs http://www.56k.com/buyer/v90upfaq.shtml
http://v90.motorola.com/download.html
http://www.mot.com/MIMS/ISG/Products/modems/update.html

*** WARNING:  BUT BEFORE YOU DO, CALL MOTOROLA IF IT'S POSSIBLE TO FLASH YOUR MODEM TO K56Flex. FLASHING YOUR MODEM MAY RENDER IT USELESS IF THE PROGRAM IS NOT INTENDED FOR YOUR MODEM. ***

Coz I think you can flash it to 56KFlex then flash it to v90.

On which modem did you disable this? The Motorola ModemSurf or the V90s?

Disabling v34/v34+ (the ITU-T standard for 28.8/33.6 connections) means going down to 14.4 level. And one thing that affects the non successful negotiation of v34/v34+ modems is line noise, and it is followed by incompatibility problems between different manufacturer's implementations. Although they are supposed to adhere strictly to ITU-T specs, some manufacturers can't fully comply or fields drivers to update their modems, which users like us, can use to update our modems. But I think the line noise is the culprit here.

This is my suggestion for the v90 modems:

You have disabled your V34 capabilities. Also on your S-Registers there's an option to disable v90 and enable v34 (at s28=1). Use error-control, and compression.

For the Motorola Modem:

I've read somewhere, that you can upgrade the Motorola ModemSurfer 33.6 to 56K

Upgrade your modem's INF driver file for windows NT. It may be outdated. Enable error-control and compression too. If possible, upgrade the modem's firmware too. It can be downloaded from Motorola's website.

---

After you have enabled error control and compression on the Motorola modem and the V90s on your portable, and you have disabled v90 (it's an S register entry in your v90 modems), try to connect. And you should see at least a connect speed higher than 14.4...

If still unsuccessful, then check your telephone wirings (this you should do after you have checked for driver updates etc.) for any scratches or loose wirings.

Just write here as to your progress regarding about pushing the speed up.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.