[Webinar] Streamline your web hosting managementRegister Today

x
?
Solved

login problem

Posted on 1999-11-26
5
Medium Priority
?
251 Views
Last Modified: 2010-04-20
I have just installed madake 6.1 off of this mounths pc answers magazine. Once it has installed and rebooted it wont let me log in . The login screen(text) is there but it wont even go pas entering my loggin name. Once i hit enter it just goes back to the login name script. Help?
0
Comment
Question by:Marktalbot
  • 3
5 Comments
 
LVL 3

Expert Comment

by:DVB
ID: 2236122
Boot into single user mode with linux single or linux 1. This bypasses the login script. Check the file /etc/passwd to ensure that the user name is there.
If that is there, fiddle about with the settings in /etc/pam.d/login. Use # to comment out a few lines and then try logging in.
If the user is not there, add a line for the user as given by the other lines. Keep the second field blank. If the file /etc/shadow exists, do the same thing in this file. save and exit. init 3.
This should work. Best of luck.
0
 

Expert Comment

by:steven112699
ID: 2236943
Have you logged in as ROOT initially.  The first boot after installation requires this action.  Your login is ROOT and your passwd is the one you were prompted for during the installation routine.

After the initial login you can change the user permissions so you do not have to log in as ROOT.
0
 
LVL 3

Accepted Solution

by:
TYoung earned 100 total points
ID: 2239250
When you go into single user mode, check that /etc/nologin does not exist. If it does, then that would also be a problem. The command to change a password is: passwd

Such as:

passwd
New UNIX password:
Retype new UNIX password:
passwd: all authentication tokens updated successfully


You may also specify a user after the passwd command to change a different user's password. Such as: passwd bob

To get rid of any password in /etc/passwd, you may remove the delete the encrypted part of the entry, for example:

root:Vi4gom4fAifu65IM:0:0:root:/root:/bin/bash

and change it to:

root::0:0:root:/root:/bin/bash

When you login, don't enter a password, and on some systems, it won't even prompt you for a password. Make sure you have one after you figure out what is wrong, because not having one is a security hazzard.
0
 
LVL 3

Expert Comment

by:DVB
ID: 2240650
Thats assumes that you have not enabled shadow files.
If you have enabled shadow passwords, do the same thing in /etc/shadow.
If you haven't done that, enable shadow passwords.
0
 
LVL 3

Expert Comment

by:DVB
ID: 2240654
Umm that last comment applies after you have solved this problem.
0

Featured Post

[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Fine Tune your automatic Updates for Ubuntu / Debian
This article will show you step-by-step instructions to build your own NTP CentOS server.  The network diagram shows the best practice to setup the NTP server farm for redundancy. ┬áThis article also serves as your NTP server documentation.
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses
Course of the Month7 days, 15 hours left to enroll

607 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question