• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 327
  • Last Modified:

Panasonic DVD driver problem?

I have fitted a Panasonic SR-8583 DVD-ROM drive into a Pentium II-350 machine. It si configured as Secondary controller, master device and is the only device on that controller. I have been unable to play DVDs using PowerDVD trial or the Zoran player supplied with my Matrox Marvel. PowerDVD does a blue screen error, and the Zoran player says the player is not ready or their is no disk loaded (when there is),

If I put in an ordinary CD, I can do a dircectory listing ok, but a dir /s causes it to crash and kill the dos window when it tries to print the totals. It also doesn't appear to detect disk changes.

No disks or drivers were supplied with the dvd, and searching the panasonic web site revealed only drivers for 8581 and 8582, not the 8583B.

Questions: do I need a driver? If I do, can anyone tell me where to find it? If not, does anyone have any suggestions to make it work before I return it?

Anyone who can point me at the driver will get the points, whether or not it fixes the problem - I will open a new question if that doesn't cure it.

0
argo
Asked:
argo
  • 2
1 Solution
 
Patricia Siu-Lai HoCommented:
argo, You need not to have a specific driver as Windows98 supports it.
However, you may need to add a line in config.sys and autoexec.bat as following: -
In autoexec.bat file

LH C:\WINDOWS\COMMAND\MSCDEX.EXE /D:MSCD000
 
In config.sys file

DEVICEHIGH=C:\WINDOWS\COMMAND\EBD\OAKCDROM.SYS /D:MSCD000

Save the files and exit. Restart the computer.

For the Oakcdrom.sys, you can use the one as stated above or you can copy from the startup floppy the realmode oakcdrom.sys into your hard disk C drive. Then make the path of the oakcdrom in the config.sys to be the right one.

Secondly, go to the device manager of control panel, expand the DVDrom device, click the properties, in settings, enable DMA by checked the box
[x] DMA

You have to make certain your display card is supporting Directdraw and upgrade the DirectX from WindowUpdate site with the most updated version.

Try to test again.
Let me know your test result if you have any queries.  pslh
0
 
larrypaloozaCommented:
You may have an incompatible IDE driver that comes with Win98.  Check the Motherboard manufacturer for a secondary IDE driver update.  I have read about a conflict with the very device you have. Try setting it up as a slave on your primary IDE or as master for that matter.  Set up your hard drive on the secondary.  Do you have the same problem?  My problem was only on the seondary until I got the Driver update.  FYI, My motherboard was an ALCORP w/ an ALI chipset.  I got the upgrade driver from www.ali.com.tw. Good luck.
0
 
argoAuthor Commented:
larrypalooza, you were very close - the problem was caused by my Win98 using the old Win95 driver - I upgraded.

I did control panel/system/devices/ide driver update driver from the win98 directory on the Win98 cd, and it all started working.

You were right about the incompatible IDE driver, and I found the solution while looking for an updated IDE driver on the Intel site, so if you post an answer, I will accept it - thanks.

0
 
larrypaloozaCommented:
Yabba Dabba DOOO.  Hey Sport, good for you.
0

Featured Post

Take Control of Web Hosting For Your Clients

As a web developer or IT admin, successfully managing multiple client accounts can be challenging. In this webinar we will look at the tools provided by Media Temple and Plesk to make managing your clients’ hosting easier.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now