SCSI Controller problem

I have an adaptec 2940U2W scsi controller, installed in a PC
which is used periodically.
When installed, it worked fine (and the devices hanging off it also).
The last time I booted (and since) it failed to see any devices
on the bus.  I've checked the actual devices on another PC, and
they work fine.  I've also moved the controller to another PC
and the problem is the same.
The devices in question are a hard disk, and a dat drive, both external.
The devices get moved periodically (say monthly) to other
computers.  But they work fine on the other computers.

Any ideas ?
manuelbsbAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
swestonConnect With a Mentor Commented:
Have you used the 2940's bios software that allows you to poll the SCSI devices as a check to see if they are attached.

First take one device and hook it up, preferably with a known good cable.  Make sure it is adequately terminated.  Do not rely on auto-termination, but use a terminator.  If you can not get the card to see either device under these controlled conditions, and Windows has no problem finding the card in Device Manager, then the card is probably bad.
0
 
RudolfFraDKCommented:
1. Does "no effect" mean that it doesnt work on ther other computer?
2. Are you often moving the devices around between your computers?
3. What kind of devices are we talking about?
4. Have you tried it with different cables?
0
 
manuelbsbAuthor Commented:
Edited text of question.
0
Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

 
RudolfFraDKCommented:
1. Have you checked all your different cables ?
2. Are the controllers the same in all the machines ?
3. Have you terminated the scsibus in both ends?
0
 
RudolfFraDKCommented:
As you say: "I've also moved the controller to another PC and the problem is the same" - When you move the controller to another computer and the problem still is the same, then you have moved the problem to the computer, so the problem must be the controller or something else that you move with it fx. Cables.  
0
 
wonderkatCommented:
Let me atke a stab at this.
First off have you tried just one device at a time on the SCSI chain? If not give it a try. Check the termination of the harddrive, makesure the devices are not double terminated i.e. the termination resistors are not on the harddrive itself as well as the external termination. Also slow down the data transfer rate, try switching to 8 bit scsi if you have not already done so. And lastly CHECK THE CABLE!!!
I've seen bad cables that actully heat up when in us, and check those pins make sure none are bent.
good luck
0
 
manuelbsbAuthor Commented:
I've tried all the combinations (cables/configuration) at my disposal,
and I've come to the conclusion that the card is dead.  
Thanks for all the input from everyone.
0
 
swestonCommented:
Next step is to decide whether any comment was worthy of an answer, or delete the question.
0
All Courses

From novice to tech pro — start learning today.