Setting Up Sound

I have A Compaq Presario 5184.  And the sound card is inbedded in the mother board.  It is a Ess PCI sound card.  How would I set this up to work with Linux.

Linux-Mandrake 6.0
Compaq Presario 5184
380mhz AMD - K6 2
undertainmentAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mwnCommented:
Have you compiled you kernel for soundcard support ?

Or, are you using the sound module ?

mwn
0
carlosvsCommented:
Use this commands...

# pnpdump > /etc/isapnp.conf

edit the file isapnp.conf
in the last part of the file you will find # (ACT Y) or something like this.. uncomment it !! (delete the #) and then

use
#sndconfig

You will probably have an error for MIDI in sndconfig ... ingnore it .. you will be set!!

You will now have your sndcard enabled ... you also need to config ... your Gnome sounds .. if you are using Gnome...!!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
undertainmentAuthor Commented:
How do I setup Gnome Sound?
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

carlosvsCommented:
That will be and extra-question!!

:)
0
undertainmentAuthor Commented:
When I go to sndconfig it says that the kernel is not setup for this.  What do I do to fix this problem?
0
mwnCommented:
As I wrote earlier ... you have to configure your kernel for sound support. Do this (should work on most Linux box's):

# cd /usr/src/linux
# make  xconfig

Configure the soundcard settings along with the other options. I cannot in this message describe the hole process, but if you look at this site www.linux.org ... you may find the information you need to do the work.

After "make xconfig" do

# make dep
# make bzImage
# make modules
# make modules_install

Know setup the sound card with

# sndconfig

  mwn :-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.