?
Solved

IDE/ATAPI and SCSI emulation for cdrw

Posted on 1999-12-01
19
Medium Priority
?
587 Views
Last Modified: 2013-12-15
  Hey guru's,
 I have compiled my kernel with scsi emulation and generic scsi support so that I can burn cd's. I run cdrecord -scanbus and both the cdrom and cdrw drives are listed with a warning that : controller returns wrong size for CD capabilities page. I can't mount either drive. I have added the append "hdd=ide-scsi" to lilo.conf. And both appear in the fstab.
  How can I config my sys to burn cd's? I am sure I am missing something simple, I have read everything I can find on the subject and tried every option........still no joy.
Its a tough subject, so I am offering many points....starting at 300.........will probably give more for a fix.
           Thanks
       jester911
0
Comment
Question by:jester911
  • 10
  • 4
  • 3
  • +1
19 Comments
 

Expert Comment

by:aa0na
ID: 2248116
1.  good job on the append="hdd=ide-scsi" in lilo.conf

2.  add these lines to your /etc/conf.modules

      alias scd0 sr_mod      #use ide-scsi as scsi cdrw
      alias hostadapter ide-scsi  #hostadapter
      options ide-scsi ignore=hdd

3.  reboot
4.  execute "cdrecord -scanbus", this will scan your scsi bus and you should see your cdrw.  note the three numbers (0,0,0) or whatever for your device.

5.  as a user, if you are not able to run cdrecord -scanbus, you need your account to be able to read and write to /dev/sg* devices.

6.  Follow the cd-writing how-to for burning cd's and copying audio cd's.  I have no trouble once, I added those lines.

cheers,
chuck
0
 

Author Comment

by:jester911
ID: 2248372
  Thanks for the effort,..........Still no joy.
hers the output from cdrecord -scanbus

[root@jesternet /root]# cdrecord -scanbusCdrecord release 1.8a21 Copyright (C) 1995-1999 Jörg Schilling
scsibus0:cdrecord: Warning: controller returns wrong size for CD capabilities page.                 
 0) 'BCD 48SB' ' CD-ROM         ' 'C2.4' Removable CD-ROM    1) 'ATAPI   ' 'CD-R/RW CRW6206A' '1.4A' Removable CD-ROM    2) *
 3) *                 
 4) *                 
 5) *                 
 6) *                 
 7) *
0
 

Author Comment

by:jester911
ID: 2248375
Please keep in mind that I am unable to even get the cdrom to mount at this point. I am really stumped.........:-/

        jester911
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 

Expert Comment

by:aa0na
ID: 2248500
do you have a cdrom and a cdrw?

what device are you trying to mount? (/dev/cdrom?  /dev/scd0?  /dev/hdd? etc.)
0
 

Author Comment

by:jester911
ID: 2248509
/dev/cdrom won't mount. And shouldn't the cdrw mount as well?  The How-To is pretty scetchy. The cdrom should mount normally shouldn't it. I am pretty new to Linux....4 months
Be specific...how should the fstab read now that the IDE drives are being scsi emulated? I am in windows at the moment so I can't get outputs to give you what I have so far. Thanks for your help on this. I think your original answer was a piece of the puzzle, but not the whole hat trick.

           jester911
0
 

Expert Comment

by:aa0na
ID: 2248565
1.  conf.modules

alias scd0 sr_mod
alias scd1 sr_mod
alias hostadapter ide-scsi  
options ide-scsi ignore=hdc
options ide-scsi ignore=hdd

2.  i'm assuming hdc and hdd are cdrom/cdrw.

3.  /dev/cdrom is a link to /dev/hdc or /dev/hdd which ever you installed linux from (i'm guessing but cdrom is just a link to the real device name)

4.  try above and give print out of cdrecord
5.  try mounting scd0 and scd1 as they are both scsi devices.

6.  maybe cdrom cannot be a scsi device but cdrw should and you should be able to mount that as in fstab
/dev/scd0      /mnt/cdrom      iso9660       user,exec,dev,suid,ro,noauto,owner 0 0

7.  that's my best shot, sorry if it don't work
0
 

Author Comment

by:jester911
ID: 2250429
Sorry..........still no go. Thanks for all of your help though. At the very least, Linux provides us with an opportunity to learn. :-)

            jester911
0
 
LVL 1

Expert Comment

by:crouchet
ID: 2251313
Ok, I notice that at least one of your drives is an ATAPI drive. Here is my stupid question: are both drives actually SCSI drives?

Second, if you have scsi, why do you need scsi emulation? My IDE ATAPI CD drive seems to work fine without it.

I realize these are  peripheral issues (sorry) but I find knocking off the corners sometimes makes the problem easier to solve.
0
 

Author Comment

by:jester911
ID: 2251415
 Thanks for asking. This should help.........

IDE-Primary master -8gig Seagate hdd (Windows98)
IDE Primary slave - 48x creative cdrom (ATAPI)
IDE Secondary Master - 20 Gig Maxtor Hdd (OpenLinux2.3)
IDE Secondary Slave Acer CDRW 6206A (ATAPI)

   Nothing is scsi.......I need the scsi emulation to be able to burn using the cdrw.  

        Hope this helps you help me. :-)

                   jester911
0
 
LVL 1

Expert Comment

by:crouchet
ID: 2253034
I recommend getting rid of the SCSI stuff. You are not really running SCSI and cdrecord does NOT require it. Below is the descriptive text from the cdrecord home page. Notice that it specifically supports IDE & ATAPI.

If you have somehow made your system believe your drives are SCSI, that could be the source of your problem.

DESCRIPTION:
Cdrecord creates home-burned CDs with a CD-R/CD-RW recorder. It works as a burn engine for several applications. Cdrecord supports CD recorders from Acer, AOpen, BTC, Compro, Dysan, DynaTec, Grundig, Hi-Val, HP, Imation, JVC, Kodak, Matsuhita, Memorex, Microboards, MicroNet, Mitsumi, Nomai, Olympus, OTI, Panasonic, Philips, Pinnacle, Pioneer, Plasmon, Plextor, Procom, Ricoh, Smart & Friendly, Sony, Taiyo, TEAC, That's Write, Traxdata, Turtle Beach, Waitek, Wearnes and Yamaha; all SCSI-3/mmc and ATAPI/mmc compliant drives should also work. Supported features include: IDE/ATAPI, parallel-port, and SCSI drives; audio CDs, data CDs, and mixed CDs; full multi-session support, CD-RWs (rewritable), TAO, DAO and human-readable error messages.

J Crouchet
0
 

Author Comment

by:jester911
ID: 2253485
 Ok, here we go..........you should have read more of the how-to..........Here is a section cut straight from the cdrecord howto. I have a question........Do you use an IDE/ATAPI cdburner on your system? If not, you probably don't understand the question.
   Here is the cut:

If you are using Linux Kernel version prior to 2.1.73 or prior to 2.0.35, please upgrade before you try to compile and use cdrecord.

In any case, you need to configure a kernel with ATAPI/SCSI hostadapter emulation. Read carefully the following instructions:

In any case, you need to disable generic IDE/ATAPI CDROM support in order to make ATAPI SCSI emulation working.

Many people ask why I use ATAPI-SCSI emulation.

   The use of the naming convention "ATAPI-SCSI emulation" is a litle bit misleading. It should rather be called: "SCSI host adapter emulation"

   The ATAPI standard describes method of sending SCSI commands over IDE with some small limitations to the "real" SCSI standard.For this reason ATAPI-SCSI emulation is the native method of supporting ATAPI devices.

   Now all of that being said, The reason I put scsi support in the kernel..was because the How-to told me too. It is necessary for the software/hardware to communicate and function. My problem is, although I have read understand and implemented the directions, I still can't get the thing to work. If you can give me some help with this I will be very thankful.

            Sig Sauer
0
 
LVL 1

Accepted Solution

by:
tq3407 earned 1600 total points
ID: 2254318
Hi there,  I noticed on your origional posting of the question that you enabled the SCSI emmulation fot the ATAPI drives.  This step is correct.  Did you turn off the IDE- ATAPI support in the kernel?  I'm sure that you did do this but it is worth a check.  I compiled my kernel like this.
IDE-ATAPI CD ROM support n
SCSI Emmulation y
SCSI CD-ROM support y
Generic SCSI Support y
SCSI support  y
Make these a part of the kernel and not modules.
After you compile these options in and re-setup lilo with the new kernel.  Reboot
In the startup messages it should show you that the drives are still on the /dev mount but further down when the SCSI support is loaded, you should see some info about your CD drives being detected as SCSI.  Once you get logged in, you will probably notice that the mount points for the /dev for your rom drives will no longer work.  I had to mount my drives on the /dev/scd mounts.  For example my cd-rom drive in my system sits at /dev/scd0.  My HP7200i sits on /dev/scd9.  The way that I found out where the cdroms were was to put in good cd into both drives and mount them.
Here is what I did I issued this command to see which rom will spin the CD and mount.  mount /dev/scd0 /mnt/cdrom
It turned out that it was my CD-ROM on /dev/scd0. After I foung out what device sat on which /scd mountpoint ( theer are 10 of them starting at 0 going thru 9) then adjust the fstab with the changes.  It seems like your kernel is compiled correctly But I think that your anwser lies in the /dev/scd section.  I also got errrors when the scanbus was used in my system.  Try looking for your CD-writer at /dev/scd9 and work twards 0.  Remember to try to mount the writer as a CD-rom and have a known good CD loaded.

Give this a shot and let us know
Later
Marshall

By the way, ATAPI emmulates SCSI.  This is why CD writer software in Wndows works. It sends SCSI commands to the drive.
0
 

Author Comment

by:jester911
ID: 2254577
Girlies and guru's, we have a WINNER!!!!!!!!!!
I went back and checked the config. Sure enough I had left IDE cdrom support there as a module. The How-to said you could do this on the later kernels specifying that both IDE and scsi devices can co-exist on IDE chains.......or something to that effect. I guess its still a (per-system) ordeal. ...........Lasers at max.........FIRE!!!

                 You da man

            jester911
0
 
LVL 1

Expert Comment

by:tq3407
ID: 2255458
Glad I got this to go for you, Were you able to mount the drives?

Let me know

Marshall
0
 
LVL 1

Expert Comment

by:crouchet
ID: 2259239
Cool. I learned something here too, which will be useful when I set up my cdw. Looks like I was in the ballpark, but I had the solution backwards.

Glad you got it to work.

J Crouchet
0
 

Author Comment

by:jester911
ID: 2260585
  Thanks Marshall,
yep I can  mount the drives just fine. But still have a couple of bugs to work out. I can't paly audio cd's in either drive now. And when I try to write a disc, the program dis-appears and nothing.
   But at least they are now recognized as scsi drives....thats a start. Any more hints?

   jester911   Brad

 thanks to you too J Crouchet.
0
 
LVL 1

Expert Comment

by:crouchet
ID: 2263688
I don't think you can play audio CDs when the drive is mounted.

You need to verify that the sound pathway is working.

First, is your sound system working? Can you play sounds and audio files to your sound card? (/dev/audio)

Second,  is your CD drive physically cabled to your sound card? It should be attached with a small round (not ribbon) cable that carries the audio channels.

Third, if you put in an audio CD, does your machine recognize it? You will ant to start a CD player program to verify this.

If the CD is recognized, try playing it. If there is no sound from your speakers, try plugging them or a pair of headphones into the audio plug on the front of the cd drive.

Once you go through these steps you should have a better idea of what is wrong and we should be able to give you better advice.

J Crouchet
0
 

Author Comment

by:jester911
ID: 2264979
  Hey guru's
  I really appreciate all of the assistance. Here it goes...
Yes my sound system is working. Yes the sound cables are connected to the soundcard.
    No the machine won't recognize an audio disc. I have tried a few just making sure it wasn't the disc. I tried playing it both while mounted and unmounted.
  Another stumper.....

                jester911 (Brad)
0
 

Author Comment

by:jester911
ID: 2265066
OH I got it to work.............I had to tell the cdplayer program where the device was..........it was still set on /dev/cdrom............No Brainer
 
   Sometimes its the easy ones that stump us......

            jester911
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
This article explains how to use the rsync command to create backups and sync data across hosts. Rsync is a very useful command that is often used to copy data, make backups, migrate hosts, and bridge the gap between site staging and production envi…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Suggested Courses

601 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question