Missing DLL/Notron Utilities

My copy of Norton Utilities says that I have 8 similar problems of an "Invalid ActiveX/COM registry entry"  where e.g the key --
"CLSID\{an alphanumeric string}\InprocServer32" refers to a missing file "LIPREF32.DLL"

And the suggested "cure" is to "Fix invalid registry entry with file "C:\Program Files\Netscape\Communicator\Program\
lipref32.dll"
7 similar dll's are treated likewise.

What is the problem and does the suggested fix fix it ?

(Windows 98SE PC)
danMAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Asta CuTechnical consultant & graphic designCommented:
Have you been having problems?  It would help to know a little more about what's transpired.  Am reluctant to post a series of possibilities without knowing a little more.  I hasten to add that a friend recently upgraded, used disk utilities (dont recall which), and they modified registry and/or recommended fixes that totally messed up her registry.  Have you tried all the standard Windows-based routines?  Example, WindowsUpdate to ensure currency and fixes installed; SFC to test your system files and check DLLs, MSINFO32 - Tools - directX diagnostics, etc.?

Based on your input, Netscape may require an update; have you checked that?
0
Asta CuTechnical consultant & graphic designCommented:
http://search.support.microsoft.com/kb/search.asp?D=win98x+or+custserv&A=F&T=B&SG=&S=F&SD=SO&T1=&FR=0&DU=C&Sz=%28win98se%29+and+norton&O=norton

This link provides a path to the Microsoft KNowledge Base relative to some hits from my search criteria of Windows 98 SE and Norton.  
0
dew_associatesCommented:
Dan, if your system is functioning without errors, then let Norton remove the registry key.

If, on the other hand you're getting errors of some sort, it would be better to locate those files and restore them to your system.

I suspect you uninstalled something though and the uninstaller failed to remove the registry entries. With that, as I mentioned, if there are no system or program error, just delete the keys.
Dennis
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

rayt333Commented:
This is from experience
"DO NOT LET NORTON FIX ANYTHING THAT YOU DO NOT KNOW WHAT IT IS DOING AND MAKE A BACKUP"
Too many people thinks Nortons is a solve all tool and I have found it causes more problems then it solves in the hands of the inexperienced. It is a great program in the hands of someone thats understands what it is doing and know what to let it do and what not let it change.
0
danMAuthor Commented:
As far as I know I currently have no problems.  I just upgraded Netscape from 4.61 to v 4.7 by uninstalling 4.61 first. (I tried to install 4.7 on top of 4.61 but then had problems running 4.7) The query was more an attempt to find out the meaning of these messages in case I had a "time bomb" liable to "go off" at a later date when I tried to use some obscure facility!

Any recomendations for a "good" system checker/fixer ?  I am reasonable PC literate, having built this Win98SE PC.

Also I use DriveImage2 to frequently do full backups of my main HDD to a separate HDD, which can hold 3 complete HDD images on the grandfather/father/son principle.   Dan
0
rayt333Commented:
Norton is good as long as you know what it is doing, if it wants to change something you are not sure about then either don't let it or make sure you have a backup.
I agree with Dennis (dew_associates) that you can let Norton remove the registry key as long as you are having no problems
0
TatsniceCommented:
With the combination of suggestions and your reference to tryed to upgrade from
4.61-4.7

I suggest reinstalling 4.61 and then uninstalling again.  
Also remove all reference to netscape in your program files. Run Sysedit and check if there are also any references there after the uninstall.
Then do a fresh install of 4.7

It seems you have residuals from your last attempt to upgrade.
0
Asta CuTechnical consultant & graphic designCommented:
Bottom line, you've found your solution and are please.

Good.

Asta
0
danMAuthor Commented:
In the end I just restored a previous backup of a day or so ago.  This is the real advantage of having complete backups of the entire HDD -- you can reverse out of any horrors  - before installing or making any significant change I do a complete image of my main disk.  

Thanks to all who responded.

And also McAfee's "Nuts & Bolts" gave me even more headaches.

Dan.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.