Epson Stylus 1520 ink flow quit

I have an Epson Stylus 1520 that uses the same cartridges as the 800. The printheads are built into the printer. Only brand new cartridges have been used in this printer. Each color, black last, has in turn, sputtered and died. It acts as though contaminants have clogged the printheads, but I can't believe that all four sets of print nozzles have clogged at about the same time. Do I have clogged printheads that need to be replaced, or is there another mechanism that has failed? How to fix?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Do you have individual Ink tanks or is it the cartridge where you have one all black and one that has 3 colors ?
jmichaelsonAuthor Commented:
2 cartridges: one black, one color
I have never heard of a 2 cartridge system that actually has the printhead built in the printer. If the cartridge you have  have like a chipboard flexbile strip on them then they have the printhead built into them most likely on the bottom of the cartridge at the front of it. Have you tried running it through cleaning cycles or priming cycles as of yet ?
Also have you tried wiping the end of the cartridge with a damp cloth to see if you get ink ?

Try the above if priming results in no ink flow and wiping does not provide any ink flow then I would ahve to say to try some new ink tanks the ones you have may either be empty or defective

\There should  be a hose inside the printer that comes off of the docking station (this si where the cartridges sit when they are not in use) this hose could be clogged if it is clean it out either with water or you could try replacing it by using some fish tank hose like they use for aquariums..

Also there may or may not be a foam like pad over at the docking station make sure that is not coated with dried ink otherwise air will not be able pump into the cartridges. you could use a little rubbin alcohol on this piecve but dilute it down a little bit.

finally it could be a pump problem if there is a foam pad over at the docking station which I am assuming there is put a few drops of water on it try priming the machine if the water does not get sucked down into the pad and down into the tube then you know the pump is no good and the unit will need to be serviced

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
This question was awarded, but never cleared due to the JSP-500 errors of that time.  It was "stuck" against userID -1 versus the intended expert whom you awarded.  This corrects the problem and the expert will now receive these points; points verified.

Please click on your Member Profile and select "View Question History" to navigate through any open or locked questions you may have to update and finalize them.  If you are an EE Pro user, you can also choose Power Search to find all your open questions.

This is the Community Support link, if help is needed, along with the link to All Topics which reflects many TAs recently added.
Thank you,
Moderator @ Experts Exchange
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.