Recovering Lilo (after W98 installation)

Problem -

  Linux (RH6) won't boot via Lilo after
  W95-->W98 upgrade.  System boots to
  W98 without Lilo Prompt.

Observations -

  Partition Magic still recognizes the
  Linux partitions.  

  Normal rescue procedure is to boot w/
  standard boot diskette and enter
 
  linux single root=/dev/hda2 initrd=
 
  as per RH SysAdmin user guide.

Problem to be solved

  "/dev/hdaXX" file system not being
  recognized (have tried hda1 /2/3/4)

  I have made a "rescue diskette" but
  can't reboot with it.

Question -

   Am I hosed????? (thanks MicroSoft!!)


Dr. Hed Krash
Silver Spring, Maryland
krash092097Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

courageCommented:
Try setting the linux partition to active (boot)
with partition magic.  With any luck your LILO
prompt will be back, to boot off either label.
0
adam923Commented:
If you created a rescue disk in red hat setup you should be able to boot linux from it unless your windows upgrade (or you) changed your partition scheme.  What messages do you get when you try to boot your linux rescue disk?
0
krash092097Author Commented:
Followup - Lilo/MBR recovery

  1. Have a rescue disk, but not
     a bootable floppy (other than
     install diskette).

  2. When I type rescue, I get a
     RAMDISK load of vmlinux, but
     no recognizable mount points.

  3. I would like to boot with floppy,
     mount /dev/hda2 as / and then
     re-run lilo.

0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

adam923Commented:
do you have a rescue disk or an install boot disk? they are different. if you actually have a rescue disk it will boot!
if you need to make one i think it can be done from dos/windows with the redhat cd, i'll get back to you on it.
0
adam923Commented:
ok, here's what i found out: the installation disk can be used as a boot disk (as you were trying before) type this at the boot prompt.
You see
boot:
You type
vmlinuz root=/dev/hdXY
where X is you hd letter and Y is your partition #
looks like XY=a2 for you based on above comments
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
krash092097Author Commented:
Here's a response that solved the
problem -

What you should do would depend partly on which version of RH6.X you have.

In either case, if you made a boot floppy, you should still be able to boot Linux from it and then run lilo.  You shouldn't need to pass any parameters to it.    If you can't do that, then to use a rescue system.  If you have the
boot floppy as above, boot from it and enter rescue at the boot prompt as instructed.  Then insert the rescue disk when prompted.  (The 6.0 rescue disk also works for 6.1.)  

If that doesn't work, for 6.0 boot from the installation media, and when you've gone far enough for Alt-F2 to bring
up a bash prompt, you now are in rescue mode.

For 6.1, you boot from the installation media and enter linux rescue at the boot prompt and you are ultimately put at the (rescue mode) bash prompt.

Once you are in rescue mode (in a ramdisk), run fdisk -l /dev/hda
to check your partition information.   Mount what you think your root partition is on some stub directory.   There is
a /mnt directory, but you probably shouldn't use that since it won't be empty, so create your own with mkdir /a, for  example.   Once it is mounted, you can rerun lilo by lilo -r /a
(or use whatever you mounted the root partition on).

There is one further twist with RH6.1.  The devices for the disks won't exist when you start.  So you have to
create them with mknod.   So for example even to run fdisk -l, you would have to first do something like mknod /dev/hda b 3 0 And to be able to mount the second partition, you would need
mknod /dev/hda2 b 3 2
Then you should be able to mount it.

If when you get in rescue mode, fdisk -l /dev/hda does not
show your linux partitions, then the upgrade to Windows 98 wiped out the partition table.  It is not supposed to do that, and we have installed Windows 98 on a machine with Linux without that happening.  But I've seen such reports.
In that case, there is a program called gpart which may be able to find the partition markers, and you may be able
to use fdisk in rescue mode to remake the partitions.
--

Leonard Evens      len@math.nwu.edu      847-491-5537
Dept. of Mathematics, Northwestern Univ., Evanston, IL 60208
0
crobert120999Commented:
there's a program called "loadlin" that comes in
with almost all RH cd-roms. read the txt's. restart
in ms-dos mode, and run loadlin. after you get
linux working you can run lilo to replace m$'s mbr.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.