Linux/Win98/Boot

I got a problem. I just upgraded to win98 (formatted and then upgraded) and now when I start my comp it always says invaild system disk? I have been told that linux is not being reconized or something? How do I fix this? When I press space bar it just loads normal? Any ideas? Also someone told me in mIRC to get a boot disk and re install lil boot? First of all I dont have a boot disk, I need one. Secondly I dont know how ot re install lil boot. I have redhat6.1. Hope you can help me!
kinger2000Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

marcelvhCommented:
you can find a boot disk in any distibution - it is the disk that you use to boot when installed linux.
I use the boot disk from slackware ( net.i ).
boot on this disk and follow the message that you can read when you are invited to continue (enter root=/dev/hda2 if your linux is on the second partition of your first IDE disk - or what convient at your installation). When you are in linux edit the /etc/lilo.conf to enter the different OS that you will start. execute lilo to upgrade the MBR. and thats all.
You can also execute liloconfig to upgrade your lilo.conf with menu facilities
marcel
0
kinger2000Author Commented:
Sorry man, that confused me totaly. I am not experianced in Linux all that much, basically i know how to get into it thats it.. I need like Linux for dumies instructions. :( sorry.. Can you make it simplerer?
0
PufferCommented:
hehe, in simple terms in win98 msdos prompt do a fdisk /mbr to restore the master boot record to get rid of the first message - of course now lilo is gone, but that's ok, it wasn't working in the first place.  Next, install a boot manager that will allow you to boot more than one OS, i suggest a new one called 'xosl' (extended operating system loader), it's freeware and graphical, unlike all the others and easy to set up.  It's at www.xosl.org  That way you don't have to touch scary lilo :)
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

kinger2000Author Commented:
That fdisk /mbr did not get rid of that invalid system disk error, and also that webiste all the files werent there, fourorfour errors.
0
sirwnstnCommented:
I was wondering.  What is saying that you have an invalid sytem disk?  Is LILO saying it or is DOS saying it?  I can't tell from your question, but are you saying that you can't load linux or you can't load win98?  And about the spacebar thing- what loads after you press it, win 98 or linux?

(one more side question that will help me formulate an answer for your question- when installing redhat 6.1, did you boot off the CD-ROM or did you make a floppy to boot and install?)
0
kinger2000Author Commented:
I think dos is saying the invalid thingie. I cant load linux. And when I press any key it loads win98. I am 89% sure I booted from A drive, wait now I think I am 95% sure.
0
sirwnstnCommented:
I'm answering as a comment so that other more experienced experts can (if they want to) see if I've made any mistakes.  Messing with the LILO is not a walk in the park.  I've installed linux dozens of times and each time I do it, I let the installer do the installation and configuration of LILO.

A word of warning: BACK UP ALL IMPORTANT  DATA BEFORE DOING ANYTHING.
A good friend of mine installed linux wrong and he lost access to his dos partition.  He ended up reformatting his hard drive.

Now that you've backed up your data:

Get two blank floppies ready.

I should have ask if you knew how to boot off the redhat6.1 CD.  If you know how to set the BIOS to boot from the CD, boot from the redhat CD and skip to the "Next Section."

If you can't boot from the CD and you've lost your install floppy, it's time to make a new one.   Boot into windows and pop your redhat CD in.  Go into the dosutils folder of the redhat CD and look for rawrite.exe.  When you fire it up you'll get a dos prompt asking you to type in the image location.
  Type: "\d:\images\boot.img" (or whatever drive letter the CD-ROM is)
This is the installation boot image.
Next it will ask you to type in the location to write the image.  Pop a blank floppy into the drive and type: "a:".  After it does its work you now have an install floppy.

Next Section:
You've booted from the floppy or CD.  Now instead of doing an installation, we'll do an upgrade.  (If it can't find the current installation of linux, stop reading this 'cuz it's time to reinstall linux)
It will ask if you want to customize the package installation.  Select "yes" and when it drops you into the selection window, deselect all the packages.  We don't want to install anything yet (unless you see something you like and want to- by all means go for it).  
After that it will install nothing (or something if you selected anything to install) and ask if you want to make a boot floppy.  Make one.  

Next, it will ask where you want to install LILO.  Here's where things get uncertain for me.  (good thing you back up your dos stuff)  You can install it on the master boot record, a floppy or on the linux partition.  Since you are booting two OS's, to my knowledge, you can only use the first and second options I've listed.  If you install it on a floppy, you'll have to stick in a floppy every time you want boot anything.  If you install LILO on the master boot record, you can boot without the floppy.  Here's the catch.  I don't know if installing on the master record will kill access to your dos partion.  Everytime I've done it, nothing happened to my dos partition.  My good friend did the same but lost access to his dos partition.  (that's why I asked you to back up your data! :) )  I'm 90% sure that you can install LILO onto the master boot record with no problems, but the 10% bugs me enough to give you fair warning.  
On the other hand, if you get to this section of the installation process and the installer can see both dos and linux partitions and asks which one you want set as the boot default, you can be 99.9% sure that installing LILO on the master record will be OK.  If you are fortunate and the installer sees both boot partitions, select the one you want by pressing F1 (or whatever the instructions say at the bottom of the screen).  Now you are done.  Remove the boot media from the floppy and/or CD-ROM drives, reboot and see what happens.  
If you were not fortunate, just install LILO onto another floppy.  You'll boot linux from this floppy until I or another expert can clear up that 10% uncertainty.  Good Luck!
0
raks04Commented:
hey i may not be very experienced in linux but i have this kind of stuff dozens of times so hope it works for u too.
just follow these verrry carefully.
1.First boot in DOS using a DOS boot disk (floppy)
if u do not have one get one from someone who has...
imp:copy the sys.com , format.com onto the floppy
these will be found on your friends c:\windows\command directory.ofcourse u will also need fdisk.exe!!

to create the boot disk use the command(dos)
format a: /s
     or
format a:
sys a:

create 2 diskettes to be on the safer side.

2.Now boot into dos.
at the command prompt u have 2 options:
u can type
  a)fdisk /mbr
  b)sys c:
 run both these commands from a: drive
Now the first part of the prob is history!!!

3.Now load your cd driver(if necessary) and load (or install) win95/98.

4.Skip 3 if u want and use your linux cd rom and boot into the cdrom .
choose upgrade type of installation.
if your linux install is intact it not only upgrades the necessary software but also reloads the LILO

5.if 4 is sucessful then u can install win95/98.
but this rewrites the MBR so remember to repeat step 4 after the win98 installation.
The above proceedures will not only get both win98 and linux working but also install LILO properly.
Now take care and stop fiddling around too much with the system.

6.if any of the above methods are unsuccessful(especially
 4 & 5) take a deep breath ... u are in a lot of trouble!!

7.u will have to first of all remove all the partitions!
trust me fdisk will never remove the linux ext2 type partition(i have tried this hundreds of times)do a low level format on the HDD or
use disk manager . it is a handy tool that comes with your hard disk (in case u didnt get one contact your hardware vendor they always have this)boot into dos and if u run this all partitions will be removed  and ofcourse all the data and it will be like a new hard disk.
now format and partition it according to your requirements
and install linux in the partition that u want to install it on and repeat the above proceedures (i assume that u know how to use fdisk and install linux on a particular partition)
[ using disk manager create 2 partitions --->1 primary and 1 extended.in the extended create just one partition whose size = total size - size u want to give for linux.
then on installation linux installs onto the space u have given for linux.incase u want to give the whole of the extended partition for linux then dont repartition the extended partition nor format it ----linux will take care of this later.just format the primary partition and exit.reboot into dos. and run step 2 onwards.
best of luck.
This is a fail proof method and alwats works especially the disk manager part.
But remember --- formatting the HDD too many times WILL corrupt it.so once win and lin are installed never fiddle around with them again!!!
0
vvijaykCommented:
The above methods are OK but I dont think u shd be even thinking of removing all the partitions in ur disk. U can always rectify situations like this without wiping out ur HDD. At worst, u would need to wipe out ur Linux ext2 partition(s).
0
kinger2000Author Commented:
I know for a fact you DO NOT need to format to do this. I am not going to format c,d,e,f. I dont care about formatting the linux drives, if i CAN save them great, if I cant then that is ok too.
0
Kyle SchroederEndpoint EngineerCommented:
I'm sure this isn't the case...but you're not booting up with a non-bootable floppy in the drive are you, or have your BIOS set to boot from CD-ROM, with a CD that has no boot information on it?  Is the exact text of what it says:

Invalid system disk or disk error.
Insert another disk and press any key.

?  It sounds like your Win9x is still booting...

Another silly question...have you tried formatting the Linux partitions and reinstalling from a linux boot floppy (or booting off the CD...its bootable too you know if your BIOS supports it, which most modern ones do).

dogztar
0
patowicCommented:
Scrounge a single-floppy linux, like toms rescue disk.  Available from  http://www.toms.net/rb/

Make yourself the boot floppy.  Boot from that floppy.

Mount your linux partition.

vi /etc/lilo.conf

make sure your dos partition (or win98) definition is correct.

exit vi

type:  /<mountpath>/sbin/lilo -f /<mountpath>/etc/lilo.conf

That should restore lilo to it's former glory
0
kinger2000Author Commented:
Ok I got my lilo back I can get into linux etc now. I have a new prob. I cant connect to the internet. It used to dial and makes the right noises but then just disconnects for no reason? Then a friend told to do this as root. echo noauto>>/etc/ppp/options and thats just made it so that no dialing at all happned now. help!
0
Kyle SchroederEndpoint EngineerCommented:
kinger, I think its time to start a new question and close this one :)

dogztar

or check the PAQ...there are lots of dialup questions there.
0
grudCommented:
It would be nice if kinger was to let all the people who contributed know exactly what fixed the problem.
You could then award the points accordingly.

Also kinger I think you should realise that nobody will help you if you post a second and different question within a question thread as it smacks of being a bit mean with the old points.
0
kinger2000Author Commented:
Oh ya sorry guys. But really none of your answers helped me :( it was a linux boot disk i typed in something like linux root=/dev/hda1 i think and i had to re install and everything was fine. I guess i did wrong here sorry. :( Whoever thinks they should get the points answer it I will give it to you.
0
Kyle SchroederEndpoint EngineerCommented:
I would say patowik's was the closest, fixing the lilo.conf file via the bootdisk.  Or give me the points :)

d0gztar
0
kinger2000Author Commented:
Wohever first one to answer gets it. :)
0
Kyle SchroederEndpoint EngineerCommented:
Well, in my comment I did recommend booting from the boot disk/CD and reinstalling......
0
biardCommented:
Hell, I didn't do anything, but I'll take em since noone else is claiming them!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.