Cannot use Windows Update, divide error in module wuvis.dll

When attempting to use the Windows Update site, after clicking on "Product Updates" I get the following error:

"This program has performed an illegal operation and will be shut down.  If the problems persist, contact the program vendor." [CLOSE] [DEBUG] [DETAILS]

Clicking the [DETAILS] button provides this:
"IEXPLORE caused a divide error in module WUV3IS.dll at 015f:05930bcf."

Then a dialog box comes up:
"There was an internal error and one of the windows you were using will be closed.  It is recommended that you save your work, close all programs, and then restart your computer." [OK]

Clicking [OK] closes that window, and the "Checking available updates" box is still there.  X-ing that window closes it.

The computer operates normally after that, but I am unable to use the Windows Update site.  Other browsers will not work with the Windows Update site.  I am using IE5.00.2314.1003/WIN98 4.10.1998/winupdmgr.exe 5, 3, 220, 1000. Any ideas what might be causing the error, and what I can do to fix it?  TIA.
speedy1200Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

waynebCommented:
I do not know why you would get this error, but at least you could download the windows98 updates from the following site., it is not a fix but at least a work around for your problem.

http://www.microsoft.com/windows98/downloads/corporate.asp
0
speedy1200Author Commented:
I guess using that site plus my wuhistv3.log file I could apply updates that are not already done.  The nice thing about Windows Update is it keeps track of it all for you.

Just found this article too:
http://support.microsoft.com/support/kb/articles/Q241/1/22.ASP

Started to apply that solution, but I'm getting an "access denied" error when I try to delete the file in step 3c.

Logging off...
0
speedy1200Author Commented:
I'm back after rebooting.  Applied the solution noted above in article Q241122.  Did not fix the error I am receiving.  More info:  the last successful visit to Windows Update was 10/31/1999.  12 of the 14 files that get downloaded into the C:\Program Files\WindowsUpdate folder are all dated 11/16/1999, and the other 2 are dated 11/15/1999.  That's about when I started having this problem.  Thanks again.
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

waynebCommented:
Try this, delete or rename the following files that are located in the c:\windows or c:\windows\system, then the first time you run windows update it will redownload them to your harddrive, this may work. If you do not want to delete them then make sure you move these files

Now in the windows\downloaded program files folder you will see an active x control called cv3 class, right click on this file and then click remove, this also will be downloaded when you try windows update site.
So there are 4 files you are going to remove if they are present.
wupdmgr.exe
actsetup.inf
wuv3is.dll

Let me know if this works for you
Good luck.

The worst that can happen is that Windows update does not work anymore, and it does not work now.
so you have nothing to lose.


0
iwinCommented:
In your last update, did you update IE 5.01 or are you using 5.01?  MS admit 5.01 has problem with its windows update page.  I read this in an article probably from zdnet last week!
0
speedy1200Author Commented:
1.  iwin:  I did not update to IE 5.01.

2.  wayneb:  your suggestion did not work.  I did not have an actsetup.inf file, but I did have an actsetup.exe, which I moved.  I also found that I did not have a cv3 class, and I had two classes that were listed as damaged (which I removed):
WuRedirInfoB class
WuSysInfo class

The other thing that seems strangely coincidental is the cv3 class was created on 11/13/1999, and the wuv3is.dll was also created on 11/13/1999 at the same time (5:24 PM).  I'm guessing at this point it's a Microsoft problem (duh), but I'm still open to suggestions.

I've upped the ante to 200 points...
0
dew_associatesCommented:
Speedy, see if this helps.

Dennis
===========================
Use as many of the following steps as is necessary. If one step does not work, go to the next step until the behavior is resolved.
 
1. Verify that your copy of Windows 98 is registered. To do so, follow these
   steps:
 
   a. Click Start, point to Programs, point to Accessories, point to System
      Tools, and then click Welcome To Windows.
 
   b. Click Register Now, and then follow the instructions on your screen. If
      Register Now is not listed, your copy of Windows 98 is already registered.
 
2. Try to log on to your Internet service provider (ISP) before you attempt to
   access the Windows Update site. Some ISPs require you to log on before
   opening a browser session. When you log on to an ISP, Transmission Control
   Protocol/Internet Protocol (TCP/IP) is loaded and provides connectivity to
   the Internet. Connecting to the Windows Update site requires an existing
   TCP/IP session.
 
   For additional information about connecting to the Internet, please see the
   following article in the Microsoft Knowledge Base:
 
   Q138789 How to Connect to the Internet in Windows 95/98
 
3. Use the System File Checker tool to extract a new copy of the Vbscript.dll
   file from your original Windows 98 CD-ROM or disks to the Windows\System
   folder.
 
   NOTE: Be sure to make a back up copy of the Vbscript.dll file when you are
   prompted to do so.
 
   For information about how to extract files using the System File Checker tool,
   please see the following article in the Microsoft Knowledge Base:
 
   Q129605 How to Extract Original Compressed Windows Files
 
4. Register the dynamic-link library (DLL) files that are associated with the
   Windows Update Web site and clear the cache and history:
 
   a. Click Start, and then click Run.
 
   b. Type "regsvr32 c:\windows\system\vbscript.dll" (without the quotation
      marks), and press ENTER.
 
   c. Type "regsvr32 c:\windows\system\mshtml.dll" (without the quotation
      marks), and press ENTER.
 
5. Remove any damaged or poorly written files downloaded from the Internet. To
   do so, follow these steps:
 
   a. Click Start, click Shut Down, click "Restart in MS-DOS mode," and then
      click OK.
 
   b. At the command prompt, type the following commands, pressing ENTER after
      each command, and pressing Y if you are prompted to confirm folder
      deletion.
 
      NOTE: If you have a cookie that stores a password for a particular Web
      site, copy the contents of the Cookies folder to a new folder instead of
      deleting the Cookies folder. To do so, type the following commands at the
      command prompt, pressing ENTER after each command
 
   smartdrv.exe
   md <new folder>
   copy c:\windows\cookies\*.* c:\windows\<new folder>
 
      where <new folder> is the folder to which you want to copy the
      contents of the Cookies folder.
 
      NOTE: Smartdrv.exe is not required to delete these files. It is used only
      to speed the file deletion process.
 
      Type the following commands.
 
      NOTE: If you do not intend to reinstall the Microsoft Java Virtual Machine
      (VM), do not delete the "Win32 Classes" file in the Downloaded Program
      Files (Downlo~1) folder. Instead, delete every file but the "Win32
      Classes" file.
 
   cd\windows
   deltree cookies
   deltree history
   deltree tempor~1
   exit
 
   c. Click Start, point to Find, and then click Files Or Folders. In the Named
      box, type "downloaded program files" (without the quotation marks), and
      then click Find Now. Double-click the Downloaded Program Files folder,
      right-click a file in this folder, and then click Remove. Continue to
      remove files from this folder in this manner until all files are removed,
      and then restart your computer.
 
      WARNING: Do not delete or use the Deltree command on, the Downloaded
      Program Files folder.
 
6. Use the System Configuration Utility to determine if a file or program that
   is loaded into memory is preventing you from loading the Windows Update site.
   For additional information about clean-boot troubleshooting using the System
   Configuration Utility, please see the following article in the Microsoft
   Knowledge Base:
 
   Q192926 How to Perform Clean-Boot Troubleshooting for Windows 98
 
7. Use System File Checker to replace any changed or damaged system files.
 
   For information about how to replace altered files using System File Checker,
   please see the following article in the Microsoft Knowledge Base:
 
   Q129605 How to Extract Original Compressed Windows Files
 
8. Delete the Internet Explorer 4.0 Setup files if they are on your hard disk.
   To do so, follow these steps:
 
   a. Click Start, point to Settings, and then click Control Panel.
 
   b. Double-click Add/Remove Programs.
 
   c. In the list of installed programs, click Microsoft Internet Explorer 4.0
      Setup Files. If Microsoft Internet Explorer 4.0 Setup Files is not listed,
      skip to step 5.
 
   d. Click Add/Remove, click Yes when you are prompted to remove the files, and
      then click OK.
 
   NOTE: If you install Microsoft Internet Explorer 4.0 in Microsoft Windows 95,
   save the uninstall information, and then upgrade to Windows 98, the Internet
   Explorer 4.0 Setup files remain on your hard disk and you have the ability to
   remove them using the Add/Remove Programs tool. If you are receiving the
   "Error Installing Dependency" error message, deleting the Internet Explorer
   4.0 Setup files may resolve the error message. For additional information,
   please see the following article in the Microsoft Knowledge Base:
 
   Q179650 Error Message: Error Installing Dependency
 
9. Obtain the latest version of the Microsoft Java VM from the following
   Microsoft Web site:
 
   http://www.microsoft.com/java/
 
   NOTE: Because the Microsoft Web site is constantly updated, the site address
   may change without notice. If this occurs, link to the Microsoft home page at
   the following address:
 
   http://www.microsoft.com/
 
10. Remove and then reinstall the Active Setup and Windows Update files. To do
   so, follow these steps:
 
   a. Click Start, point to Settings, and then click Control Panel.
 
   b. Double-click Internet.
 
   c. On the General tab click Settings, click View Objects.
 
   d. Locate the following files (if they exist). Right-click one of the files,
      and then click Update.
 
       - Wusysinfo
 
       - Wuredirinforb
 
       - InstallEngineCTL Object
 
   e. When you are prompted to install Active Setup, click Yes.
 
   f. Close the Downloaded Program Files window.
 
   g. Click OK, and then click OK again.
 
   h. Find and then delete the following files:
 
       - Asctrls.ocx
 
       - Inseng.dll
 
       - Wudetect.dll
 
       - Wupdatto.dll
 
       - Wuredirb.dll
 
      To find a file, click Start, point to Find, click "Files or Folders," type
      the name of the file you want to find in the Named box, and then click
      Find Now. To delete a file, right-click it, and then click Delete.
 
   i. Restart your computer, and then connect to the Windows Update site to see
      if the problem is resolved.
 
      NOTE: If you are using Internet Explorer 5, connect to the
      http://windowsupdate.microsoft.com Web site to download the ActiveX
      components, and then click Windows Update on the Tools menu.
 
If the problem persists, download the Microsoft Scripting Engine 5.0 for Internet
Explorer from the following Microsoft Web site:
 
   http://microsoft.com/windows98/downloads/corporate.asp
 
NOTE: This is the same JScript update that is available on the Windows Update
site.
 
For more information about Microsoft Scripting Engines 3.1b, please see the
following article in the Microsoft Knowledge Base:
 
   Q191200 Update Available for Window.External JScript Security
 
If the problem persists, you may want to reinstall Windows 98. To do so, use the
following steps:
 
1. Start your computer with your Windows 98 Startup Disk. If you do not have one
   you may be able to create one on any computer that has a CD-ROM drive. For
   information about how to do so, please see the following article in the
   Microsoft Knowledge Base:
 
   Q187632 How to Create a Windows 98 Startup Disk that Supports FAT32
 
2. Choose "Start computer with CD-ROM support", and then press ENTER.
 
3. At the command prompt, type the following commands, pressing ENTER after each
   command:
 
   c:
   cd progra~1
   ren intern~1 interold
   <CD-ROM drive letter>:
   setup
 
   where <CD-ROM drive letter> is the drive letter assigned to your CD-ROM
   drive.
 
   NOTE: When you start your computer with a Windows 98 Startup Disk and enable
   CD-ROM support, your CD-ROM drive letter is changed to one letter after the
   normal letter. For example, if your CD-ROM drive letter is normally D, it is
   now E.
0
speedy1200Author Commented:
to: dew_associates
Thanks for the detailed response.  

1.  My copy of Windows is registered.  The option to "register now" is still there, but once you click it, a dialog comes up saying you're already registered.

2.  I'm always dialed in and logged on before attempting to connect to Windows Update (or any site for that matter.)

3.  I extracted a copy of vbscript.dll from c:\windows\options\cabs.  I later found this to be a problem.  Apparently Visual Studio 6.0 SP3 installs version 5 of the Microsoft Scripting Engine.  The version I had extracted was 3.1.0.2124; SP3 installs version 5.0.0.3715.  See Q191200.  The other 3 files mentioned are all version 5.0.0.3715.  I reinstalled VS6 SP3 and now have the correct version 5 scripting engine.

4.  Registered the two dll's mentioned.

5.  Deleted the contents of the three folders mentioned while in DOS mode.  Deleted everything in the Downloaded Program Files folder, including Win32 Classes.

6.  ** Have not ** used system configuration utility yet.  Tried just doing a restart in safe mode, but had no modem access.  I'll save this for last.

7.  SFC found no problem files.  I run sfc.exe pretty consistently.

8.  There were no IE4 setup files to delete.

9.  Downloaded Java BM build 3188.  Previously had build 3176.  I did not see the Win32 class back in the Downloaded Program Files folder after attempting the Windows Update site again.  Is that a problem?

10.  The items mentioned were previously deleted in step 5c.  No way to "update them."  They're no longer there.

10 continued.  As mentioned in 3 above, I re-installed VS6 SP3 and now has version 5.0.0.3715 of the Microsoft Scripting Engine.  This SP has been previously applied 7/13/1999, and I had been using Windows Update for 4 months without incident after that.

I really do not want to reinstall Windows 98.  I have Win98 SE and may just install that.  Any other ideas?

BTW, I am receiving the same exact error as before.  Windows Update is not working.  I have not other known problems with IE5.  Are there other sites I can go to that make extensive use of VBscript and Java, where the problem might also show up?
0
speedy1200Author Commented:
An answer is now worth 300 points.
0
speedy1200Author Commented:
More info:  wupdmrg.exe shows
Microsoft(r) Windows (r)
2000 Operating System

When you bring up the properties and Product Name.  I'm used to seeing Windows NT for the operating system, but this is the 1st time I've seen Windows 2000 here.

Would it be helpful to click on [DEBUG] when I get the error box?  I can't make heads or tails of C++, but maybe there would be some useful information?
0
dew_associatesCommented:
Speedy,

9: I don't believe this will be a problem.

As for the Java sites, I've never really had to test this, but I'll see what I can find.

Go ahead and run debug, it can't hurt.
0
dew_associatesCommented:
I've also asked a few other techs to join us.
0
Patricia Siu-Lai HoCommented:
Speedy, You may give this a trial.
(1) Use Windows Explorer to locate following files and delete them.
      C:\WINDOWS\wupdmgr.exe
      C:\WINDOWS\SYSTEM\wuv3is.dll

(2) Open an IE browser, File-open, paste following line in the open box and OK.

http://windowsupdate.microsoft.com/V31Controls/x86/w98/en/actsetup.cab

It will ask you to download a cabinet file. Save it to a temporary directory. Use windows explorer to open it. You will see three files.
Right click the files of followings and extract it to the path.
wupdmgr.exe             C:\WINDOWS\  
wuv3is.dll                  C:\WINDOWS\SYSTEM\

(3) Use Windows Explorer, go to the Downloaded Program Files.
     If you find the "CV3 Class", right click to popup the context menu. Select the "Update".
     It will recreate the ActiveX components.

(4) Restart the computer for two times. On the third start, connect the internet.
      Use windows explorer, go to the C:\WINDOWS\wupdmgr.exe.
      Double click the file and go to the WindowUpdate Site.

See if there is any improvement.          Pslh
0
Patricia Siu-Lai HoCommented:
Speedy, forgot to mention (2)and 3) of my previous comment should be online for downloading and updating.     Pslh
0
speedy1200Author Commented:
1.  dew_associates:  thanks for getting others involved.  I'd *really* like to resolve this, without doing a win98 install.

2.  pslh:  deleted the two files as suggested, and went to the url mentioned.  I downloaded the cab file, but could not open it in explorer.  WinZip tried, but didn't work.  So I used sfc.exe to extract the 2 files from the cab.  I didn't see the third file you mentioned.  Is it also important?

3.  pslh:  I still do not have a Win32 class in the Downloaded Program Files folder.

4.  pslh: restarted the system twice, then a third time, and dialed up my ISP.  Tried wupdmgr.exe, made it to the windows update site, clicked product updates, but eventually got the same error.  I noted the URL it was accessing this time, if it matters:
http://windowsupdate.microsoft.com/v31site/x86/w98/en/Ie5/catalog.htm  (not sure on the capitalization.)

So, I still have the same error.  Any other ideas?

Thanks to all who've tried to help...
0
speedy1200Author Commented:
BTW, speedy1200 is the name the system assigned when I forgot my password from 18 months ago.  My name is Chris (but if you prefer, you can continue to call me speedy :-)
0
Patricia Siu-Lai HoCommented:
Chris/speedy, Sorry that I've jumped over a few steps

Step (2)
http://windowsupdate.microsoft.com/V31Controls/x86/w98/en/actsetup.cab 

After downloaded the actsetup.cab e.g. in C:\TEMP\ directory.
Use Windows Explorer to go to the C:\TEMP\actsetup.cab.
Select the "actsetup.cab" and double-click it. Another window will be open and it contains 3 files.
actsetup.inf
WUpdMgr.exe    
WuV3Is.dll

Select "WUpdMgr.exe". Right click to pop up the context menu. There is only one option "Extract". Select extract and it will ask you to put to which directory. Set it to place in folder of C:\windows where the mouse states at the folder "windows", click OK. It will add the most update version of "WUpdMgr.exe" to the C:\windows directory.

Repeat same procedure for WuV3Is.dll, but set it to place in folder of C:\windows\system directory.

Where "actsetup.inf" is very important. However it is a cache file of installation of ActiveX components.
It is working when you proceed the steps of following.

Repeat again the above mentioned steps.

Meanwhile, please tell me what files that you have found in the Downloaded Program Files.
0
speedy1200Author Commented:
pslh, my system responds differentlt than your apparently.  When I double click actsetup.cab, WinZip Wizard opens up and gives me an error saying this is not a valid archive.  I did note that the window title said "WinZip Classic Required."  I right clicked on the cab, and chose "extract to..." and got the three files.  I put wupdmgr.exe and wuv3is.dll where they were before (same as where you mentioned.)  The files I downloaded were the exact same date & number of bytes.

Also, the context menu for the wupdmgr.exe and wuv3is.dll do not list an extract option.  I just copied them to the correct folders.

I see where the location of actsetup.inf is important, but I missed where it's supposed to be.  I have the extracted copy, but a "find files or folders" does not turn up another copy  on my system.  Where do I put the file?

And, previously in the t-shooting, I deleted all the files in my Downloaded Program Files folder.  Right now there's only SurveyCtll35 class dated 10/28/99.

Thanks.
Chris

p.s.  anybody want 400 points?  BTW, reinstalling Win98 or Win98 SE is not a valid answer to this problem (for me.)  It's not really a big problem, but it's annoying enough for me to up the ante.
0
Patricia Siu-Lai HoCommented:
Chris,will revert a day later.   Pslh
0
Patricia Siu-Lai HoCommented:
Chris,
Try to check the Start-settings-folder options- file type.
Search for file type "cabinet".
Click into the Edit button. Inspect if it is now associated with Winzip. Try to remove the file-type association of cabinet file opened with Winzip.

In default the cabinet file is linked by an ActiveX component.        

Take a trial to eliminate the influence by Winzip.        Pslh
0
speedy1200Author Commented:
pslh:  I had no "cabinet" file type.  If I went down to "WinZip file", I found the cab extension associated with it (winzip.)  So I deleted that type altogether, and forced WinZip to create it's associations again.  Now cab is not listed in the file types that open with WinZip, but there is no entry for a cab file.  If I double click a cab file, I get the "which program do you want to use to open this file?" dialog.  Cancelled the operation at that point, since I don't know what program should open a cab file.  Can you tell me what your system has associated with the cab file type?  Maybe I could create my own entry.

BTW, in the registry key HKCR, there is an entry ".CAB" but it has no subfolders, and it has a default Name and "WinZIP" in the Data.  I changed that to null.
0
Patricia Siu-Lai HoCommented:
Chris, Try the followings: -

(I)  In the File type association, there should be a file type named "Cabinet".
      Name of file type:  Cabinet
      Extension: CAB
      Opens with:  EXPLORER
      Click into the [EDIT] button. In the window it shows only one "View" item.
                [   View                ]
      Click [Edit] button. It pops up a window saying in the box [  ] as: -
      Application used to perform action:
                [explorer /root,{0CD7A5C0-9F37-11CE-AE65-08002B2E1262},%1         ]

(II) Go to check with the registry as following Data (1) and Data (2).

Registry data (1)
      My Computer\HKEY_CLASSES_ROOT\.cab
      HKEY_CLASSES_ROOT
     |--- Folder      .cab        
           Name                        Data
           (Default)                   "CLSID\{0CD7A5C0-9F37-11CE-AE65-08002B2E1262}"

Registry data (2)
HKEY_CLASSES_ROOT
|
CLSID
|
Folder     {0CD7A5C0-9F37-11CE-AE65-08002B2E1262}
|                Name: [ab] (Default)    Data    "Cabinet"
|
|----Folder   DefaultIcon
|                   Name: [ab] (Default)    Data     "C:\\WINDOWS\\SYSTEM\\ShellExt\\cabview.dll"
|
|----Folder   InProcServer32
|                   Name: [ab] (Default)    Data     "C:\\WINDOWS\\SYSTEM\\ShellExt\\cabview.dll"
|                   Name: [ab] ThreadingModel     Data     "Apartment"
|
|----Folder   shell
          |         Name: [ab] (Default)    Data      (value not set)
          |
          |-------Folder   open
                        |         Name: [ab] (Default)    Data      "View"
                        |
                        |----- Folder    command
                                  Name: [ab] (Default)    
                                  Data    "explorer /root,{0CD7A5C0-9F37-11CE-AE65-08002B2E1262},%1"


You can find exactly the same as the above data (1) and data (2) under the key of HKEY_LOCAL_MACHINE.
Try to check and rebuild exactly if it is not in the file type and in the registry as above stated.

If in the registry the extension ".cab" is now having a link with the Shell or Shellex to open with by application of winzip, try to remove it by deleting the key (folder) of Shellex containing the winzip.

The registry amendment should be carried for both HKEY_CLASSES_ROOT and  HKEY_LOCAL_MACHINE. The content of path/key/name/data should be the same.

After registry editing, go to the menu bar View, click Refresh.
Restart the computer.
Go to double-click the downloaded file of "actsetup.cab" and in the opened window as you find three files, right click to see if a context menu popup with word "extract".

Let me know your proceedings. If you have any queries, please feel free to ask.      Pslh
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
speedy1200Author Commented:
Woo Hoo!  We have a breakthrough!  Following the last bit of advice from pslh, I checked for a .cab file type association; there was none.  With the registry info provided, I recreated the .CAB folder in HKCR, with the data provided.  I scrolled down to the HKCR\CLSID and found those entries already there.  Same with the HKLM entries.  The registry was set with a quick [F5].

Restarted the PC.  Checked the file associations just for kicks, and everything there was set for .cab.  Double clicked the actsetup.cab, and a new window opened, something I had never seen before.

Each of the three items had only one item in the context menu, "extract."  Wupdmgr.exe was extracted to the C:\Windows folder and wuv3is.dll was extracted to the C:\Windows\System folder.

I didn't know where the .inf file went, but I guessed C:\Windows (correctly I guess?)  Went online, tried Windows Update, it took a lot longer, and the site URL looked a little different (yesterday it got locked up on http://windowsupdate.microsoft.com/v31site/x86/w98/en/Ie5/catalog.htm , where today it made it through, but with a /R307 in the URL right before the /V31site - http://windowsupdate.microsoft.com/R307/V31Site/x86/w98/en/Ie5/catalog.htm

Did Microsoft change something, or did associating the cab file type properly and extracting the .inf file do the trick?

Going to try and actually download some stuff now to see if it really works.

Thanks!
Chris
0
Patricia Siu-Lai HoCommented:
Chris,
<<I didn't know where the .inf file went, but I guessed C:\Windows (correctly I guess?)>>
actsetup.inf is a cache file of the ActiveX component for installation of the Downloaded Program. Microsoft’s server uses this to inspect and link the setup with your computer. This is a temporary file, which you do not need to install nor extract it into your computer. That’s why I didn’t tell you where to put this file.

<<Went online, tried Windows Update, it took a lot longer >> 
Since you’ve removed some temporary files, it needs to re-download all the gif and pages into your computer. It took a little bit long at the first time. Next time, it will get faster as all the cookies are in your computer.

<< yesterday it got locked up on http://windowsupdate.microsoft.com/v31site/x86/w98/en/Ie5/catalog.htm , where today it made it through, but with a /R307 in the URL right before the /V31site - http://windowsupdate.microsoft.com/R307/V31Site/x86/w98/en/Ie5/catalog.htm >>

It is only server is changing. They’re mirroring the same downloading page.
Microsoft has many servers in various locations. The sites what you noted is the result of ActiveX function. ActiveX can automatically changing in the background between domains/servers/computers/directories without the notice to the user.

One of the practice of diagnostic to see what happens behind the switching of pages during the WindowUpdate process that I’m using and very effective is to click on the history “Today” while going to the WindowUpdate Site.

You will see these pages has already been visited in between the process.

Blank.htm     http://windowsupdate.microsoft.com/blank.htm

Catalog.htm  http://windowsupdate.microsoft.com/R307/V31Site/x86/w98/en/Ie5/catalog.htm

Catalog.htm  http://windowsupdate.microsoft.com/R307/V31Site/x86/w98/en/Ie5/catalogTop.htm

Checking Available Update  http://windowsupdate.microsoft.com/R307/V31Site/x86/w98/en/Ie5/animDialog.htm

Engine.htm   http://windowsupdate.microsoft.com/R307/V31Site/x86/w98/en/Ie5/engine.htm

Hnav.htm?S000   http://windowsupdate.microsoft.com/R307/V31Site/x86/w98/en/Ie5/HNav.htm?S000

Hnav.htm?S001U000  http://windowsupdate.microsoft.com/R307/V31Site/x86/w98/en/Ie5/HNav.htm?S001U000

Home.htm    http://windowsupdate.microsoft.com/R307/V31Site/x86/w98/en/Ie5/Home.htm

Microsoft Windows Update.        http://windowsupdate.microsoft.com

Microsoft Windows Update.      http://windowsupdate.microsoft.com/default.htm?Page=productupdates

Navigator.htm      http://windowsupdate.microsoft.com/R307/V31Site/x86/w98/en/Ie5/Navigator.htm

Navigator.htm?Page=ProductUpdates    http://windowsupdate.microsoft.com/R307/V31Site/x86/w98/en/Ie5/Navigator.htm?Page=ProductUpdates

Pumain.htm     http://windowsupdate.microsoft.com/R307/V31Site/x86/w98/en/Ie5/pumain.htm

Toolbar.htm     http://windowsupdate.microsoft.com/R307/V31Site/x86/w98/en/Ie5/Toolbar.htm


The destination page is this one: -

Catalog.htm  http://windowsupdate.microsoft.com/R307/V31Site/x86/w98/en/Ie5/catalog.htm

<<Did Microsoft change something.>>
It has shifted the server.

<<did associating the cab file type properly and extracting the .inf file do the trick>>.
Yes, proper file type (in Microsoft international language) association to extract the cab (cabinet) file is the key point to solve the problem.

During the negotiation of your computer to Microsoft server, a lot of files (including executables and images) are stored in cabinets that your computer has to extract the cabinets “in Microsoft understandable language, path and files, of course” so as to download and install into your computer automatically.

Previously, you have associated the Winzip to open the .cab file which Microsoft download engine cannot recognise and cannot extract the cabinets. Therefore, you’ve got the error in the mid-way.

Removal association of winzip and restore the Extract root by “Extract32.exe” of win98 to the root of directory of your C drive. During downloading, Microsoft will search and create (if none is there) the C:\windows\Downloaded Program Files for caching the cabinets files.

Remark: You can remove the actsetup.inf which you’ve stored in C:\windows\.

Please tell me if you have any queries.      Pslh
0
dew_associatesCommented:
Well done so far Pslh (Pat)!
0
speedy1200Author Commented:
Yes, the key was correcting the file association for .cab.  Thanks to all who helped!  I feel much better now.

Chris
0
Patricia Siu-Lai HoCommented:
Thank you Chris! (and you too Den!)    Pslh
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.