Printing problem: no device found.

I am trying to get my Epson 740 to work with Ghostscrip using Red Hat 6.1. I have downloaded and installed a driver for the 740. Printtool gives me this error message: "could not write file "/dev/lp0": no such device." The same thing happens when I enter printer device as /dev/lp1 and /dev/lp2.

When I run the command ls > /dev/lpx (where x=0,1 & 2), I also get the "no such device" error message.

My Bios is set to No PNP OS, parallel port is set to 0378 with irq7. Printer and cable are OK as far as I can tell. Any suggestions?
tarenxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tq3407Commented:
There might be a irq conflict.  Why did you disable the PnP OS setting in BIOS?  Is the printer on the lpt port thats on the computer or is it on an expansion card?
0
tarenxAuthor Commented:
The PNP OS setting in the BIOS is disabled by default, although you have given me the idea to try booting Linux with PNP enabled. The parallel port in question is on the computer (not on an expansion card.) What could you recommend for troubleshooting and resolving a irq conflict? Thanks in advance.
0
ihardingCommented:
Add the folowing line to /etc/conf.modules

alias parport_lowlevel parport_pc
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

tarenxAuthor Commented:
Sorry, your suggestion did not work. I eventually did get Linux to recognize my parallel port as dev/lp0. Here is how I did it.

Current versions of the Linux kernel have adopted the parport device which enables the OS to drive external devices such as Zip drives, etc. through the parallel port. Parport also assigns parallel ports to device numbers dynamically. Even if you have only one parallel port the following procedure should work.

1)  From xterm(as root), issue  # insmod parport.o
2)  If you are using Red Hat 6.x, bring up the GUI Kernel Configurator, and add a type plip module w/ this argument:  io=0x3bc,0x378,0x278_irq=none,7,auto (if you are using another distribution, try  #insmod parport_pc.o io=0x3bc,0x378,0x278 irq=none,7,auto) Then, restart the kerneld.
3)  Issue  # insmod -o plip lp parport=0,2
 
Sources:       -  The Linux Printing HOWTO by Grant Taylor
            -  www.cyberelk.demon.co.uk/parport.html
            -  www.cyberelk.demon.co.uk/parport/parport.txt
            
0
tarenxAuthor Commented:
Since this form will not allow me to withdraw my question, I will offer 100 points to the first person who posts something I consider useful on the general topic of printing from Linux.
0
ResonanceCommented:
Incidentally, you can ask EE to withdraw the question.  Mark the question number and make a request in the EE support forum.

I would note, however, that if you are planning to be doing much printing, a more elegant solution might have been to recompile your kernal so that it supported exactly what you needed.  What you have described is a fairly roundabout method for getting printing to work, even if you are using that port for multiple purposes (i.e. have it on a splitter between a zip drive and a printer, or something else equally strange).

For reference, I have "Parallel printer support" compiled as a module in the kernel (you'll find it under "Character Devices"), which compiles out to the object lp.o.  I don't have to insmod this at all, as I also have kernel daemon support enabled, and it gets loaded automatically as it is needed.  A quick check of cat /proc/modules shows that the lp module is currently loaded, but parport_pc is not, suggesting that it's not needed at all on a properly configured system.

For reference, I'm using Linux 2.2.13 as the kernel, and Debian GNU/Linux-unstable as the distribution.  I'm using modutils 2.3.7.

I'm curious to see if you would be able to print if you simply do "modprobe lp" before printing (modprobe, incidentally, is probably a better way to handle module loading than insmod as it will automaticaly load modules upon which the target module depends).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.