Default Shares

How do I disable them in WIN2000 RC2? Or at least how do I restrict access to the C$ and ADMIN$ shares.

Thanks

Steve
LVL 2
MacrosAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CAFCommented:
you can restrict access to these shares you can even remove the share at system boot but they will return on reboot dont think theres a regedit setting enabled share by default
0
MacrosAuthor Commented:
There was in NT4 a registry setting to stop this share but I can't find the doc to do explain which one. It's probably the same one in W2K (at least i'm willing to kill my system trying *g*)

0
carmineCommented:
For server try:

System\CurrentControlSet\Services\LanManServer\Parameters\
  AutoShareServer = 0

For workstation:
  AutoShareWks = 0


Mark
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

carmineCommented:
The type is REG_DWORD in both cases.

Mark
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MacrosAuthor Commented:
There is a solution
0
MacrosAuthor Commented:
Thanks carmine - I had put that entry in but it hadn't worked. I didn't have it as a REG_DWORD.

So for all you out there - this works just as well in Windows 2000. Tried and tested.

Thanks again.
0
whitetiger13Commented:
I found the registry key "System\CurrentControlSet\Services\LanManServer\Parameters\ ", but there is no setting for "AutoShareWks".  I am on a Windows 2000 workstation machine, did I miss something?
0
whitetiger13Commented:
I found the registry key "System\CurrentControlSet\Services\LanManServer\Parameters\ ", but there is no setting for "AutoShareWks".  I am on a Windows 2000 workstation machine, did I miss something?
0
MacrosAuthor Commented:
Create a new REG_DWORD entry in there called AutoShareWks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.