NFS Server: Can't start rpc.nfsd

When starting './rpc.nfsd' I get the reply: 'nfssvc: Address already in use'

'rpcinfo -p' gives:
    program vers proto   port
    100000    2   tcp    111  rpcbind
    100000    2   udp    111  rpcbind
    100005    1   udp    726  mountd
    100005    1   tcp    728  mountd
    100005    2   udp    731  mountd
    100005    2   tcp    733  mountd
    100005    3   udp    736  mountd
    100005    3   tcp    738  mountd

'ps aux |grep nfsd' gives:
root      7096  0.0  0.0     0    0 ?        SW   Dec03   0:00 [nfsd]

and not (what I expect/require):
root       298  0.0  0.2  1068   312  ?  S   Dec  2   0:00 rpc.nfsd

Any help will be greatly appreciated

Many thanks,
GJ1
gj1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

chintuCommented:
Because nfsd is already running.

why do you need to restart nfsd?

if you have modified your dfstab/export file table
you might want to use
shareall or export ( will all ) option.

0
gj1Author Commented:
I am trying to mount a directory, however when I use the mount command:
mount -o rsize,wsize server:/mnt /mnt/local

response:
failed, reason given by server: Permission denied

I have checked the exports file and it's set-up fine, and I have run exportfs.(& chmod +x)

Any help please
GJ1
0
djtech012498Commented:
If your just trying to mount a directory, then all you need is rpcbind (aka portmapper/portmap).  The permission denied is a definite problem with your /etc/exports file.  Do you also run the server your trying to mount a directory from?  If so make sure you verify that /mnt (unusal mount point to share) is authorized for the client your connecting from.  Depending on the unix your connecting to you should be able to read /var/log/messages and see the error on the server saying unauthorized client connect from hostname, verify this hostname is in your exports file on the server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gj1Author Commented:
The only way in which I can get a directory mounted was to use the same directory name on both server & client.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.