How do I use Version control in Interdev?

We are using Visual Interdev 6.0 for developing our ASP applications, and I would like to use Visual Source Safe as version control system for our development.

Interdev has a menu item (Project | Source Control | Add to source control) that should do something like that. However, when I try it I get the following error message:

"Cannot establish source control for the Web application. The server does not have a source control system installed on it, or the user name is not recognized."

Now, I have installed Visual Source Safe
6.0 on both the development machine and on the web server, and configured it to open our common VSS database by default.

So, what is wrong here? Do I need to install something else on the web server or the developer machine? Or is the problem connected to the '...the user name is not recognized.' part of the error message? I should perhaps mention that we use the network login name as default login name in sourcesafe. Also, I have added IUSR_RHEA (RHEA is the name of our web server) to the VSS user list, and this did not seem to help.

Thanks in advance for any input.

AndersWP
LVL 1
AndersWPAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

FlubbadubCommented:
Step 1.

Install VSS and Interdev on the Server Machine

Step 2.
Create The web Project in Interdev ON THE SERVER MACHINE IN MASTER MODE

Step 3.
Select the Project (Not the solution) i.e the second node in the project explorer window of interdev.

Step 4.

Select Project|Source Control|Add to Source Control from the menus

choose selected files only when prompted

NOTE: make Sure the Interactive user on the sever has access to VSS (Ie logon to the server as a valid VSS User OR add the interactive user of the server to the VSS User List)

Step 5.
After Source control has been applied, goto
Project|Web Project|Web Permissions and set the project to use its own web permissions.  Add any Developers to the user list also ensure that they are valid VSS Users.

Step 6.
On the DEVELOPMENT machine start interdev, create a new web project in local mode connected to the Server.
Choose connect to an existing application and choose the app...HEY Presto We are done


Well, this is how I do it anyway (took our firm 3 months+ to figure this all out!)

The Most importat tip is make sure that the user logged in on the server has the appropriate access rights to VSS
0
AndersWPAuthor Commented:
Thanks for the input, Flubbadub. Unfortunately, installing Interdev on the server is rules out-of-bounds by our network/server manager, so although your idea may well work from a technical point of view, we can not use it.

Regards,
AndersWP
0
AndersWPAuthor Commented:
Something I forgot to mention, and which may be important:

Our VSS database is not located on our web server, but on another machine in our network.

At my current level of lack of understanding, I suspect that the problem is related to the web servers access rights to the VSS database server.

Does that ring a bell with anyone?

Microsoft has a set of guidelines that is supposed to make this setup work, and I have tried following them, without success.

AndersWP
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

brittkCommented:
You do not need VSS or Visual Interdev on the Web Server.
If Frontpage extensions are installed on the Web Server and the Web has been configured to use the extensions and Visual Interdev works ok from the Client then VSS is the problem.

With VSS 5.0 you must do a custom  install and 'enable sourcesafe integration'. With VSS 6.0,this is automatic.

Get rid of any existing VSS stuff from the Client and the Web Server as this just gets in the way. Redo a Client install using NETSETUP from the proper VSS Server. A Map to server drive is needed so NT permissions are important.
The Client Srcsafe.ini is the key to which VSS db is used. NETSETUP automatically configures this for you.  

Then the logon NAME on the client needs to be a VSS user with read/write permissions. The Client Logon credentials need the correct NT permissions on VSS server.

Add to SourceSafe should work now assuming NT level permissions are set up ok.

You will be asked for a VSS project. You can specify an existing one or use the default, Web name, which is then created for you and populated.

The VSS integration is nothing to do with Web Server to VSS server communication. The Visual Interdev Client is the one that does the communicating between the web server via the FP extensions and the VSS server via the Interdev/VSS integration.

The Web Home Directory becomes the VSS working directory and is also the Visual Intedev Master directory. That is the only link.

Get back to me if there are still problems.

It may be better to configure Visual Interdev to access your web project and separately configure the VSS client to access the correct VSS server  database ensureing permissons are ok, then configure Visual Interdev to access Sourcesafe. This will isolate NT Permissions and VSS user name problems.                                                                                        




                                                                                                                                         
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AndersWPAuthor Commented:
Thanks for your input, brittk!

I believe that my VSS configuration is correct: I do not have any problems accessing the VSS DB from my client machine using VSS Explorer. Never the less, I am unable to do the "Add to source control" as described in my question. Do you have any thoughts on that? Do you agree that being able to access the VSS DB through the VSS explorer is sufficient to establish that VSS is setup correctly on my machine?

Also, I must admit that I am a bit sceptical of your claim that no VSS code need be installed on the web server. According to Microsoft, the VSS Automation Server *must* be installed on the web server (see e.g. http://support.microsoft.com/support/kb/articles/q171/1/16.asp).

Regards,
AndersWP
0
brittkCommented:
Your right about VSS on the Web Server, I forgot I was working on the on the server. However the FP extensions only needs the srcsafe.ini file to work. This will point to the right VSS database. So a client install will be enough. Beware having more than one srcsafe.ini file on the server as FP extensions may get hold of the wrong one and point to the wrong database.

If you VSS client works ok and your Interdev client access of the Web works ok then the problem definately lies with the FP extensions and is certainly permissions related. I assume you are using VSS 6.0 (if not enure you have done a custom install and 'enable Sourcesafe integration')

I have IIS 4.0, FP 2000 extensions, FP2000, Interdev 6 and VSS client 6 working on one server and accessing a remote VSS server. The account I logon is specified in the VSS admin.

When I set up a remote workstation with Interdev 6 and accessed the web on the Web server it detected that there was Sourcesafe integration and would show that something was checked out, but when I tried checking out from the workstation I got your error.

I finally managed to get around this by specifying Basic Authentication in the IIS security settings.(no ananonymous or NT Challenge/response)

When I open the web in Interdev, I specify my logon id when challenged. Bt the waythis id has Admin rights on the Web Server.

I haven't had time to pinpoint exact permission requirements or why I had problems on the workstation when I used the same domain logon id as I did on the web server, so this is a bit vague, sorry. You might not be allowed to try things out either!

I think the problem lies with accessing the FP extensions rather than with VSS or the Web. When the FP 2000 extensions are installed on the web, you are asked for NT Account details for administering the FP extensions, the default is Administrator. I'm not sure about FP 98 extensions.

But loook in this area to overcome the problem.    



   








   
0
AndersWPAuthor Commented:
Brittk, thanks again for your input.

I'am afraid that I am in a deadline coma right now. I´ll get back to you next week.

Sorry,
AndersWP
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP

From novice to tech pro — start learning today.