[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 970
  • Last Modified:

FreeBSD kernel rebuild

After I did the following to rebuild the kernel of FreeBSD 3.3, my FreeBSD box cannot use network anymore and I get a error, "sendto : permission denied", when I run "ping" !!

1) add "options IPFIREWALL" and "options IPDIVERT" into "/usr/src/sys/i386/conf/GENERIC"
2) run "config GENERIC"
3) run "make depend all install" under "/usr/src/sys/compile/GENERIC/"
4) add "firewall_enable="YES"", "firewall_type="simple"" and "firewall_quiet="YES"" into "/etc/rc.conf"
5) run "sync;sync;sync;reboot"
6) system restart

What seems to be the problem ?

Andrew
0
andrewyu
Asked:
andrewyu
1 Solution
 
mj031297Commented:
You should also configure the firewall! Or it firewalls everything, which is good if that is what you're after.

Either edit /etc/rc.firewall to suit your needs

or

let the firewall to let everything through (as if it wasn't there in the 1st place) by typing:

root# ipfw add 65000 pass all from any to any
(no need to reboot)

or

set firewall_type to "open" in rc.conf
(and reboot)

If you don't have any plans fiddling with firewall setup then you just as well could remove the kernel options.  

/M
0
 
andrewyuAuthor Commented:
But, I mean that I cannot use PING in the server(FIREWALL) !

Andrew
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now