[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 284
  • Last Modified:

Redhat 6.0 Login Problem

I am using RedHat 6.0.  I have experienced a problem that has occured days after I have successfully configured the OS.  The problems is that I tried to add a user accout (via linuxconf) and the OS got fowled up with the following side effects:
1)Uable to rlogin as some users, but others users still work.
2)FTP does not remotely work.
3)Can not 'su'to root after logging as a regualur users (cannot su to root group - permission denied).
4)Problems logging as as root or user from the Linux loggin prompt.

Has anyone experienced such problems or know of any fixes/patches/workarounds?

0
dustind
Asked:
dustind
1 Solution
 
framebCommented:
I have noticed some general "flakeyness" with linuxconf.  Although it is supposed to be a great tool and very powerful (I guess it is in the sense that it combines lots of configuration options into one graphical interface), I still use the manual "adduser username" command.  By editing configuration files and doing things "manually", you get gain a better understanding of how the graphical programs work anyway.  So my advice would be to stick with the traditional command, adduser, chgrp, etc....

O'Reilly's "Linux in a Nutshell" is a great reference for that sort of thing.
Good Luck-
Ben
0
 
openguinCommented:
Running Linux, 2nd Edition, O'Reilly
is another exceptional ref.  Actually, the entire "critter series" are comprehensive and useful ...

Jaa Mata
0
 
tanmay_kumarCommented:
Perhaps trying the passwd command on the affected usernames might help. If not, then maybe you'll be better off by deleting those users from passwd file itself(manually) and then creating them again. Anyway, I'll always recommend sticking to the console for power jobs like these.
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
patowicCommented:
Be sure to always use vipw when accessing your password file--normal vi will not update the shadow files, if you're using them.

Do you have any accounts with a login shell of /etc/nologin or /etc/false, or some such?

Can you login as root on the console?  direct root login over telnet is sometimes denied on unix system.s
0
 
roberto122399Commented:
By default root is denied direct telnet access. As with su being denied some installaion demand that users be in the "wheel" group to su up.

It sounds like linuxconf changed some of your setings to default values. I never use linuxconf myself but I have heard that it attempts to always use defaults. ie I remove uucp group and user entries since I do use uucp I ran linuxconf and it kept complaining that uucp did not exist...who cares! 8) So that soured me on it.

Anyways, if you can login as root on the console check your /etc/group and securetty files (securetty denies direct root telnet)
As for ftp.. ensure that the daemon is running if so, ensure your group file entries aren't messed up. And also make sure that linuxconf didn't decide to barf all over you ftp config.

Hope this helps
0
 
roberto122399Commented:
in comment for uucp i menat I DO NOT use it 8)
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now