Weird Dsiplay Under XWindows

I have Cirrus Logic 1Mb 5446 Graphics card and standard SVGA monitor. I cannot configure the display correctly. Its difficult to describe, but XWindows will work at correct resolution, but display is "blotchy" with areas missing, or weird blocks of colour here or there. When pointer is moved, it will get worse, or when another window is opened it will get worse and the text is unreadable. If an opened window is closed, the area where the window was will remain. Refresh Display helps a little. Is it monitor or graphics card problem? How do I fix it? I have been through Xconfigurator and xconfig86 a number of times and have tried many combinations of setup.
lauriecopeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

biardCommented:
I have been doing hardware repairs on PCs for many years, and the symptoms you describe sound suspiciously like a video ram problem.  Either ther is not enough (not likely), or it is bad.  First, I would try to check the bios to be sure that the shadowing is on if that option is available.  If this fails, put a cheap $20 video card in there.  You could test the monitor on another system, but it sounds to me like a video card issue.
0
raks04Commented:
hey laurie when u reject biard's answer get back to me and i will tell u how to solve the problem easily
0
lauriecopeAuthor Commented:
Thanks, but also tried Windows95 on machine and graphics are perfect so assume it cant be card. Or can it?
(Shadowing also on).
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

cadavisCommented:
Hi Laurie.  Have you also tried XF86Setup.  There is a feature in there that will allow you to change the settings of your screen.
0
Barn_OwlCommented:
Laurie >> False assumtion. linux drives hard ware a heck of a lot harder than windows ever thought a bout, paticuliarly when running X. A second point is that the Cirrus cards are not the best supported unnder the X system. There may not be enough memory on the card to drive the resolution and color depth you are using espescially under the KDE or Gnome Desktops.
0
biardCommented:
Barn Owl:  Thank you for your support....
0
raks04Commented:
hi again
the prob is definitely with the video card.i have a SiS card and when i first installed linux i had the same prob.
But ever since i moved from redhat6.0 to 6.1 this prob is history
so u can upgrade to either rh 6.1 or read on
this method can be used with every distribution:

1.Run your X86Freesetup or xconf or whatever u use to configure the system keyboard vdo card etc ( not linuxconf or
COAS).

2.now choose the right kind of monitor or better still (as i did)
specify the scan lines (ex> horizontal scan 30.5 - 54
vertical scan 50 - 90).This is verrry important.refer to your moinitor user manual for this else u can just choose a standard monitor.

3.Now if prompted whether u want to look at the video card database asnwer yes and choose it correctly.
choose the right amount of VRAM.if your vdo vard does not have any clockchip (most dont and yours may not have too) or RAMDAC (same here) do not choose any.

4.Choose the the resolutions u want
rest is straightforward

5.verrrrrrrrrrry imp------------>note down the name and path of the file into which these settings are written into and then use your favorite editor and open it for editing

6.search for the line that descibes your video card :

you will see a line like this
#videoram 4096  
where 4096 or 1024 is your video ram and # represents a comment so remove the #
this becomes
videoram 1024
ofcourse leave the caps and lettering as it is as linux is exxxtremely case sensitive.

now add the following lines exactly

Option "nolinear"
Option "hwcursor"
Option "no_accel"

plz note the lettering and quotes.


7.now save the file and type startx or whatever and enjoy!!
if u want higher resolutions then remove the line

Option "nolinear"

and add

Option "nobit_blt"

then u can start higher resolutions by typing
startx -- -bpp 16

so  enjoy linux coz its happening!!!


























0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lauriecopeAuthor Commented:
Excellent! Appologies to biard, but I really needed confirmation before I start spending money! So thanks to biard and Barn Owl. Thanks also to raks04 who helped fix a follow on problem with the new video card (very slow graphics, setting was on 256k instead of 4096k).
Can I give the three of you A's?
0
Barn_OwlCommented:
Give it Rakso4 or baird.
0
raks04Commented:
hey sure laurie i need an A coz when my video card had the same prob i didnt even know this site existed and had to slog for many sleepless nights
0
biardCommented:
I'd love one too.  But unfortunately, you need to distro the points to one person...  But, btw, did you replace the card, or what cuz the notes above are a bit fuzzy in areas.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.