RedHat installation problem....

Here are my system specs:
P150 on Supermicro P5STE Motherboard (upgraded) AMI v.2.2
64MB 70ns RAM
Maxtor 1.6GB IDE HD
IDE 45X ATAPI CDROM
SB16
Linksys LAN16 Ethernet Adapter
Conner 2MB Tape Drive Accelerator Card @(IO-360/IRQ-6/DMA-2)
Standard SuperVGA Video Card(Recognized by Linux) [can't remember name, sorry]

Anyway, my problem started ever since I tried installing the boxed CD version of Red Hat Linux. First, I tried installing a Server Class installation (Since I plan on using this box first, as a gateway/proxy to the internet via cable modem, then as a firewall/email/web/file server later on in pieces. So, I figured that the Server Class install was the way to go.

I install and had numerous problems with freezing during the copy process. I figured it must be memory related and play with my BIOS settings. I find an errata on Red Hat's Site describing how my MB (SuperMicro P5STE) has had problems with lockups and to try to d/l the latest firmware updates seems to fix those lockup problems. I do that and upgrade my firmware.

I get the Server Class installed, only to realize that ever though during the install process, the XFree86 stuff had been copied, I could not "startx". So, I decide to scrap the Server Class install and, instead, try the Gnome Workstation class install.

Now, this went fine (a few lockups), but I got it installed. I go to reboot from the hard drive and it locks up in the middle with the message, "Kernal panic: VFS: Unable to mount root fs on 03:06". I have no clue what this means. I think it means it couldn't mount my root file system, I think. Anyway, the boot process freezes there and I cannot do anything else.

So that my problem. My main goal in this whole process is to loadup my box so that I can have a gateway/proxy/firewall to begin with. But I would also like to use SAMBA later and create a file/print/DNS/LOGIN server for my WIN9X/WIN2K machines in the future. I wouldn't be running this box to do anything else.

Can someone help me out or point me in the right direction to install/resolve this?

-Thanks

Overlord
overlordAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

raks04Commented:
hey i got  a kernel panic a couple of times.this i think usually happens if u delete the essential binaries or if the second install didnt go properly . since both the types of install were completely different.i just formatted my HDD and reinstalled fresh.
Hang ups during installs rarely occur and even if they do its mainly due to degrading hardware.
Hope somebody comes up with a better solution!!
0
overlordAuthor Commented:
well supposedly, and I think it does, the installer, when you choose different install options like Workstation, Server, etc, repartition and reformat the hard drive. I think the GNOME Workstation install reformats ALL Linux partitions (at least that is what the manual states) and the Server Class installl REMOVES ALL Linux partitions and reestablishes the Partitions and reformats them. So, basically, I did a clean reinstall.
0
swwelshCommented:
I've got a feeling that tape drive accelerator card is not supported, so that could be part of the problem. I would try taking it out. I would do a reinstall and make sure the partitions are reformatted, etc. To get X set up, you can run Xconfigurator or (better) xf86config once you get to the console.
0
sk5tCommented:
- Your problem the second time around is with LILO... RH's 6.x installer is seriously flawed in this regard.  It sees, "Yup, LILO is already there," and doesn't continue any further.  First wipe out the master boot record on your drive (whip out the ol' DOS boot disk and 'fdisk /mbr') and then do a clean RH installation.  (Or, if you are more experienced and think the rest of the installation is okay, use a linux 'rescue' disk, mount the partition, check /etc/lilo.conf on the mounted fs, and run /sbin/lilo with the appropriate flags for a non-standard path to lilo.conf: because /dev/hda1 is mounted other than /, and so on.)

- I've found most "freeze during install copy" troubles to be related generally to bad behavior on the part of the CDROM/IO hardware.  If it gets a bad sense code, death awaits.

- In any event, be sure you're using the latest install-floppy image from RH.  There were early python script problems that ate many installs.

- These problems are definitely NOT related to your tape hardware.

- IMO, Redhat got in over their heads for this release.  Have patience (or try another distribution).  Linux is worth it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.