RoadRunner DHCP

I'm using the dhcpcd thing that came with my RedHat5.1 with kernel 2.0.35. I just upgraded to 2.2.13 (big jump) and now I can't get an IP from the server.

Using DHCP for eth0... failed.

My other card (eth1) works fine (it has a intranet static IP). Both cards are probed and found okay, I just can't get the IP address anymore. HELP

P.S. I noticed that when the kernel is loading, after it probes the cards.. it says something like:

Network information incomplete (or something like it)
LVL 3
TYoungAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

j2Commented:
networking changed MAJORLY between 2.0 and 2.2 you most likely have to update a ton of other things aswell.
0
ttaoCommented:
could you paste the result of these
commands?

cat /proc/modules
netstat -rn
ifconfig eth0
0
TYoungAuthor Commented:
cat /proc/modules:


netstat -rn:

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth1
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth1
24.95.150.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
24.0.0.0        0.0.0.0         255.0.0.0       U         0 0          0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U         0 0          0 lo
0.0.0.0         24.95.150.1     0.0.0.0         UG        0 0          0 eth0



ifconfig eth0:

eth0      Link encap:Ethernet  HWaddr FE:FF:FF:7F:FF:FF
          inet addr:24.95.150.72  Bcast:24.255.255.255  Mask:255.0.0.0
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:140 errors:0 dropped:0 overruns:0
          TX packets:92 errors:29128 dropped:401 overruns:0
          Interrupt:11 Base address:0x300


BTW.. thanx for your help.. but It STILL isn't working.
0
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

ttaoCommented:
the result of these commands
indicate that the eth0 have not been
drivered properly, the cause are:

1.perhaps there is not proper modules
for you eth0 or in kernel.

2.the I/O or IRQ of eth0 is not proper.

0
TYoungAuthor Commented:
The I/O and IRQ are fine... they are the same as the 2.0.35 kernel and work fine there.

I just can't resolv IP addresses.
0
biardCommented:
Doesn't time warner issue static ip addresses for raodrunner?
0
TYoungAuthor Commented:
Not that I know of (static ips)

By the way, I got a lot of things working, I just can't resolve ip addresses.


Here is my /proc/modules:

ip_masq_ftp       1         0
ip_masq_raudio  1         0
ip_masq_ftp       1         0
ip_alias              1         11 (autoclean)
ne                    2          2 (autoclean)
8390                 2         2  (autoclean)
appletalk           4         0 (autoclean)
ipx                    3         0 (autoclean)


I can even access 209.162.55.34, but I can't resolve it to www.experts-exchange.com (well actually the other way around).


PLEASE HELP!
0
biardCommented:
Sounds like your DNS setup is not correct.  Check your resolv.conf file.  in /etc for the following:

you shoulld have two lines (at least) of dns server addresses (obtain them from you isp) as follows

nameserver xxx.xxx.xxx.xxx
nameserver yyy.yyy.yyy.yyy

That should do the trick.
0
TYoungAuthor Commented:
Sorry, I do have many of those in there from rrdhcpcd.. 5 of them to be exact.

I can ping them...
0
biardCommented:
Then at a shell prompt, type nslookup
and then enter a www address that exists.  See if it can resolve it this way.  If so it is a netscape problem.  If not, then a DNS problem exists for sure and we will go from there.
0
TYoungAuthor Commented:
Nope... I can't even resolve throush nslookup. Nothing will resolve on the linux machine, nor any of the "masqed" machines on my network.
0
biardCommented:
If it does not resolve the ip, post the contents of the following files:

 /etc/named.conf
 /etc/nsswitch.conf
 /etc/host.conf
 /etc/resolv.conf
 

By the way, is named running already?  Try the following command before you bother to post this stuff:

/usr/sbin/ndc start

Then run nslookup again and try to resolve a name.  named has to be running all the time, so you should have it run at startup.
0
biardCommented:
Ok, well try the stuff I put on the last comment.  If the stuff at the end fails, post those files.  Also, after you run ndc start post the output of

 tail -f /var/log/messages



0
biardCommented:
Any luck?
0
TYoungAuthor Commented:
named.conf doesn not exist.

nsswitch.conf:
passwd:     files nisplus nis
shadow:     files nisplus nis
group:      files nisplus nis

hosts:      files nisplus nis dns

services:   nisplus [NOTFOUND=return] files
networks:   nisplus [NOTFOUND=return] files
protocols:  nisplus [NOTFOUND=return] files
rpc:        nisplus [NOTFOUND=return] files
ethers:     nisplus [NOTFOUND=return] files
netmasks:   nisplus [NOTFOUND=return] files    
bootparams: nisplus [NOTFOUND=return] files

netgroup:   nisplus

publickey:  nisplus


automount:  files nisplus
aliases:    files nisplus






host.conf:
order binf, hosts, nis
multi on




resolv.conf:
domain stny.rr.com
nameserver 24.92.226.171
nameserver 24.92.226.172
nameserver 24.92.226.173
nameserver 24.92.226.14



ndc start -> pid(###) already running.

Nothing is in the log about ncd.



Sorry it took so long to reply.
0
biardCommented:
Ok.  You need to create some files. named.conf needs to be placed in /etc and should read as follows:

options {
        directory "/var/named";
};
zone "." {
        type hint;
        file "root.hints";
};
zone "0.0.127.in-addr.arpa" {
        type master;
        file "named.local";
};



########################

Now, you need to make sure the file root.hints exists in /var/named

If not, check for a file called named.ca
and let me know what you have.  If you have a named.ca and no root.hints in /var/named then changethe relevant line in the file above to match.

Likewise you will now need to create the named.local file as follows and place it into /var/named


@   IN   SOA   localhost.   root.localhost.(
               1     ; Serial
               8H    ; Refresh
               2H    ; Retry
               1W    ; Expire
              1D)   ; Minimum TTL
         NS    localhost.
1        PTR   localhost.



#################################

If you have no root.hints or named.ca in /var/named let me know, but also include a list of the files that are in that directory.  Especially look for one whose contents are very long containing several lines with X.ROOT-SERVERS.NET where the X is a letter of the alphabet.  There will be other stuff in these files too, so look carefully.

Also, in your response above, look at the contents of host.conf and compare it to you actual file.  The line that starts with "order" should say

   order bind, hosts, nis

It is nitpicky, but I want to make sure it doesn't say "binf" on accident.
0
TYoungAuthor Commented:
I haved named.ca and named.local with a /etc/named.conf

That starts named.

Yeah, it says bind.... not binf: :-0
0
TYoungAuthor Commented:
Err... I have a named.boot, not a named.conf

They are the same thing.
0
biardCommented:
That, I imagine is part of the problem.  I think named.boot is for bind 4.  You should have bind 8 now because of the kernel upgrade.  You need to have the named.conf file created manually and saved in /etc  and then in the named.conf where I have root.hints change that to named.ca (I am assuming that named.ca has all of the ROOT-SERVERS.NET lines in it.  The named.local and the named.ca need to be in the /var/named folder together.  Then you need to restart named with the command
      ndc restart
at the shell prompt.

That should do it, I believe.  While you try that out, I'll check to make sure that there is nothing extra needed for a cable modem.
0
TYoungAuthor Commented:
Okay, I'll try that... and yes named.ca has a bunch of ROOT-SERVERS.NET things in...


Off to get another version of bind...!
0
TYoungAuthor Commented:
I don't think bind has anything to do with it. On my working 2.0.35 kernel, if I stop bind (ndc?) I can still resolve. If I am wrong, please let me know and tell me where I can get a RPM (not SRPM) of it. (I am having trouble compiling).
0
TYoungAuthor Commented:
HELP!
0
biardCommented:
Sorry.  I was out of town for a week.  I'll be back at work in the morning and I can try to pick up where we left off then.
0
TYoungAuthor Commented:
Okay
0
biardCommented:
I think you are correct.  You don't need bind.  That is for NIS services I believe.  Oh, and just for kicks, rename your named.boot to named.conf and restart ndc.  Then try to resolve.
0
Bo0gi3manCommented:
Wow....


eth0      Link encap:Ethernet  HWaddr FE:FF:FF:7F:FF:FF
          inet addr:24.95.150.72  Bcast:24.255.255.255  Mask:255.0.0.0
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:140 errors:0 dropped:0 overruns:0
          TX packets:92 errors:29128 dropped:401 overruns:0
          Interrupt:11 Base address:0x300


Thats alot of errors....29128 sounds like the wrong module to me :)
0
j2Commented:
the MAC also looks bogus to me.
0
Bo0gi3manCommented:
Wow....


eth0      Link encap:Ethernet  HWaddr FE:FF:FF:7F:FF:FF
          inet addr:24.95.150.72  Bcast:24.255.255.255  Mask:255.0.0.0
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:140 errors:0 dropped:0 overruns:0
          TX packets:92 errors:29128 dropped:401 overruns:0
          Interrupt:11 Base address:0x300


Thats alot of errors....29128 sounds like the wrong module to me :)
0
TYoungAuthor Commented:
Would the module from 2.0.35 work if copied into the 2.2.13 directory?
0
j2Commented:
No. Most likely not. and the mac is

1111 1110 1111 1111 1011 1111 1111 1111 1111

Thats a bogus MAC alright.
0
TYoungAuthor Commented:
What do you mean by MAC?

I DO know that HWaddr FE:FF:FF:7F:FF:FF is fine. The card works fine. I just can't resolve
0
TYoungAuthor Commented:
Can anyone help me? I have tried everything. I will add more points when I get some... but I really need this fixed. Thanx
0
mixerfix122699Commented:
your ifconfig/dhcpcd are NOT COMPILED for the correct
kernel. Networking/NIC structures were changed significantly between 2.0 and 2.2 kernels. Please boot into the 2.0 series kernel, update all network related packages (ifconfig and dhcpcd especially) and retry.

The major error count on the interface is the result of the kernel-internal data-structures shifting.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Bo0gi3manCommented:
When j2 was talking about MAC addresses I believe he is right.
FE:FF:FF:7F:FF:FF hexdecimel translates to 1111 1110 1111 1111 1011 1111 1111 1111 1111 in binary.  This is impossible.  I aggree with mixerfix that you should recompile the kernel.  Maybe just use an 6.1 install disc and update everything.  Look on your card.  Unless its a newer PCI card it should have a MAC hwaddr chip located somewhere on the card.  usually there will be something that says Ethernet address then printed ie.  00AA00 then an arrow pointing to an ic that has printed on it the last of the hwaddr.  Thats what your Hwaddr in netconf should be set to, not FE:FF:FF:7F:FF:FF.  If it's a pci card then maybe (very unlikely) this almost all 1 addr would work?  Who knows, the shadow knows ahhahah.


Bo0gi3man
0
TYoungAuthor Commented:
Well, on my 2.0.35 kernel (the one that works fine), here is:

[root@bgm-43-250 linux]# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr FE:FF:FF:7F:FF:FF
          inet addr:24.94.43.250  Bcast:255.255.255.255  Mask:255.255.255.0
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:58377 errors:0 dropped:0 overruns:0
          TX packets:35585 errors:0 dropped:0 overruns:0
          Interrupt:11 Base address:0x300

[root@bgm-43-250 linux]#  

Notice 0 errors, and the HWaddr is the same. This works fine, so it must not have relevance.
0
j2Commented:
Nope, checked with a database, an ethernet card can n-e-v-e-r have 1111 has the first quad of the mac, it just isnt in the specs.

Infact, as far as i know the first quad of a MAC is ALWAYS 0000
0
TYoungAuthor Commented:
Then why does it work on 2.0.35?
0
j2Commented:
Good question, but 2.2.x kernels have a "stricter" networking code.
0
j2Commented:
what kind of NIC is this by the way? or is it mentioned, and i just missed it?
0
TYoungAuthor Commented:
eth0 is a kingston NE2000 card.
0
j2Commented:
http://standards.ieee.org/regauth/oui/oui.txt

There is the list.

or http://standards.ieee.org/regauth/oui/index.html 

for a search facility. You cards MAC adress does not exist.
0
Bo0gi3manCommented:
I would recommend picking up a copy of RedHat 6.1 (you are using the RedHat distrib?).  Use the upgrade feature and upgrade EVERYTHING, including config scripts, dns servers, network daemons.  I think that you don't have the NE module compiled into the new kernel.  It just can't be *copied* into a directory.

For some reason, i keep seeing people having trouble with the NE2000 cards and clones.  Go here -->http://www.web-docs.net/howto3.html#ss3.4.  Might be able to answer some of your questions.

Maybe the best solution is to get a diff card???  Your not having much luck right now :)

Bo0gi3man
0
Bo0gi3manCommented:
This might work for you.  Only if ISA card though, you never said ISA or PCI.

Probem: ISA Plug and Play NE2000 (such as RealTek 8019) is not detected.

Reason: The original NE2000 specification (and hence the linux NE2000 driver) does not have support for Plug and Play.

Solution: Use the DOS configuration disk that came with the card to disable PnP, and to set the card to a specified I/O address and IRQ. Add a line to /etc/conf.modules like options ne io=0xNNN where 0xNNN is the hex I/O address you set the card to. (This assumes you are using a modular driver; if not then use an ether=0,0xNNN,eth0 argument at boot). You may also have to enter the BIOS/CMOS setup and mark the IRQ as Legacy-ISA instead of PnP. Alternatively, if you need to leave PnP enabled for compatibility with some other operating system, then look into the isapnptools package. Try man isapnp to see if it is already installed on your system. If not, then have a look at the following URL:

http://www.roestock.demon.co.uk/isapnptools/

0
Bo0gi3manCommented:
Oh, just so you know.  Your prom (MAC addr) isn't being detected correctly.

Checking the ethercard at 0x300.
  Register 0x0d (0x30d) is ff
  Failed initial NE2000 probe, value ff.
8390 registers: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
SA PROM        0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
SA PROM 0x10: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff

 Invalid signature found, wordlength 2.

This is what comes up when you don't have a NE2000 card in.  HMMM, looks familar FF:FF:FF:FF:FF:FF???
0
Bo0gi3manCommented:
I think biard had good intentions, but it isn't the DNS server thats the problem.  You can't resolve because your card don't work.  

Try these commands and post the output here.  

ping 24.95.150.72 -i eth1
----------

i think it'll be timed out.
0
TYoungAuthor Commented:
Yeah ping 24.95.150.72 -i eth1 times out... because I have the internet running eth0. Im gonna install RedHat 6.1. I let you know how it goes. BTW, i wuz running redhat 5.1
0
Bo0gi3manCommented:
cool...i think thats your only solution.  other than hard configuration files :)

bo0gi3man
0
Wouter WolkersCommented:
ok, just start with folowing the necesary upgrades for the 2.2.x kernel range.
first of all, you ifconfig should be updated, because it is showing the information in an incorrect way.
please check Documentation/Changes for the MINIMAL software required to run a 2.2.x kernel, because obviously you don't have all of it.

Current Minimal Requirements
****************************

   Upgrade to at *least* these software revisions before thinking you've
encountered a bug!  If you're unsure what version you're currently
running, the suggested command should tell you.

- Kernel modutils        2.1.121                 ; insmod -V
- Gnu C                  2.7.2.3                 ; gcc --version
- Binutils               2.8.1.0.23              ; ld -v
- Linux libc5 C Library  5.4.46                  ; ls -l /lib/libc*
- Linux libc6 C Library  2.0.7pre6               ; ls -l /lib/libc*
- Dynamic Linker (ld.so) 1.9.9                   ; ldd --version or ldd -v
- Linux C++ Library      2.7.2.8                 ; ls -l /usr/lib/libg++.so.*
- Procps                 1.2.9                   ; ps --version
- Procinfo               16                      ; procinfo -v
- Psmisc                 17                      ; pstree -V
- Net-tools              1.52                    ; hostname -V
- Loadlin                1.6a
- Sh-utils               1.16                    ; basename --v
- Autofs                 3.1.1                   ; automount --version
- NFS                    2.2beta40               ; showmount --version
- Bash                   1.14.7                  ; bash -version
- Ncpfs                  2.2.0                   ; ncpmount -v
- Pcmcia-cs              3.0.13                  ; cardmgr -V
- PPP                    2.3.8                   ; pppd --version
- Util-linux             2.9t                    ; chsh -v

good luck.
0
patowicCommented:
I wouldn't upgrade to rh6.1...I'd just get dhcpcd source and recompile that.  And make sure you've recompiled all the modules and whatnot...
0
Bo0gi3manCommented:
why the hell not just do the whole thing?
0
Bo0gi3manCommented:
it's not just dhcp thats screwed up right now, it's his whole damn kernel with that particular network card...patowic, did you even read the previous comments i made?
0
patowicCommented:
If it's his NIC's module that isn't compiled right, upgrading the whole damn distro is just opening a can of worms.  that's like telling someone "oh, your kitchen faucet is leaking?  You should replace the plumbing in the house."  

and do you have some sort of vested interest in his upgrading to rh6.1 (which has glibc2.1, which is NOT ready for primetime)?  You seem distinctly angry that I suggest a different approach.
0
patowicCommented:
Oh, and by the way, I've got a rh5.1 box which has kernel 2.2.6 on it.  I hd this EXACT problem until I recompiled the proper NIC module, and recompiled dhcpcd from source.  Then, it worked perfectly.
0
Wouter WolkersCommented:
hey guys, he doesn't need to upgrade to any newer version if he doesn't want to.
All I was saying is that he should upgrade his existing installation with the updated utils, which are needed for a 2.2.x kernel. the problem with his ifconfig ( the lot of errors) is caused by the fact that he is running an outdated version of ifconfig, which will show the numbers in the wrong place when using an 2.2.x kernel, because procfs got changed.
this is a start in getting the right data to come to the correct solution.
0
patowicCommented:
Cool, thanks wouterw!  I had no idea I had to upgrade ifconfig as well...
0
TYoungAuthor Commented:
TEST
0
TYoungAuthor Commented:
Thanx. I realize that was the problem, and I am not having any trouble now with RedHat 6.1
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.