Samba -- 95 Clients ok, NT clients can't logon.

I just installed MacMillan's 6.5 Linux on AMD K6 233 with 64m ram, and configured Samba.  My Win95 machines can get in just fine, but none of the NT 4.0 sp4 machines can.  Error is that no logins from this workstation allowed.  What must I change?
jisajf5Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

j2Commented:
You must set samba to accept encypted passwords. There is a "ecryption.txt" in the samba tarball, read it and follow it ;)
0
j2Commented:
the problem is that if a Win95 machine tries to connect to a share, it will fall back to sending the password in PLAIN TEXT if the server requires. This is a major security hole, and NT does not do this. You CAN tell NT to use plain text passwords, but do you really want your passwords sent to the world in plain text?
0
jisajf5Author Commented:
After doing a search on the drive, I can't find the file 'ecryption.txt.'  I tried enabling encrypted passwords in smb.conf anyway, and what happended is that now even the win 95 machines can't connect.  To be fair, I didn't tell you that I was trying to enable a public account for 'pcguest' with no password, but very limited share access.  This may be part of the problem...Could there be a case-sensitive problem in finding the file mentioned?
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

jisajf5Author Commented:
All I have is the 75 points...the link to 'More Points' is dead, so I couldn't do the survey and get more ; (

Joe
0
j2Commented:
you ALSO have to ADD users to the smbpasswd file. Is this redhat? The easiest way would be to just enable SWAT (on port 901) and do this via the web. Encryption.txt is only a part of the "real" samba distribution. Not the preinstalled bundles.

If this is a current distro, you prolly also have the "smbadduser" program, which you just execute like

"smbadduser unixid:ntid" and then it will prompt you to edit the smbpasswd, which must be the same as the login pass of the win95 user.

or you could to the old fashioned way by "smbpasswd -a userid"

but swat is a nice/ clean way to handle this. Or tell samba to auth against a NT server if you have one.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jisajf5Author Commented:
I DO wish there were a good beginner's section in one of the generic books, on Linux that dealt with configuration of Samba and dealt with simple things like this...

I feel dumb.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.