Horrid Problems with using DHCP

Hello, I have spent the last 48 hrs trying to get linux to work with my cable modem, and so far I am unsuccessful.

First, A little about my settings, ect.

1. im running mandrake 6.5(red hat 6.1)
2. I have an Asante 10NIC-PCI ethernet card (it was detected as a 'tulip' card)
3. I am trying to connect to a cable modem ISP that uses DHCP (mediaone/roadrunner, and no, I have never had to 'log in')
4. In Linuxconf I set up my default gateway and DNS info using info obtained from winipcfg
5. I then set up my host name as 'alex' (i just made it up, do I have to find 'what it really is' and put it in as my host name?)
6. I then set up my 1 and only ethernet card to use the tulip kernel module (it told me in installation it was a tulip card), set net device to eth0, and enabled DHCP

This is the error message I ended up getting at boot:

Determining IP info for eth0 via DHCP....
                                            [FAILED]

I then tried to open netscape to see if it was lying to me, but it wasnt and netscape immediately gave me an error about not being able to find such and such host

So then I tried this out...

I thought maybe it was an IRQ or I/O conflict so I went back into linuxconf and tried vaious IRQs like 11,12, and 13. along with various I/Os like 0x300, 0x240, 0x260. When I modified and IRQ and I/O fields then rebooted I got this error:

Delaying eth0 initialization               [FAILED]

I then opened up netscape with the same results.

Here are possible things that are causing my problem:

1. Host Name- I just typed 'alex' in the host name field, is there anywhere I can look to find out what I need to put in there, or does it matter?

2. IRQ or I/O conflicts- I tried various IRQs and I/Os, but I am new to Linux and don't know how to find out what IRQ and I/O devices are using, so I may have been using IRQs that are taken.

3. Driver Problems- Linux detected my Asante 10NIC-PCI as a 'tulip' card, could there be problems with this, is it really a tulip card? should i look on the net for drivers?

4. PUMP or DHCPD- I have heard people suggest to others with DHCP problems to obtain and install things called PUMP and DHCPD to stop DHCP problems. Should I try this? and if I should, where can I find these programs?

remember,I'm totally new to Linux so don't make your answers too technical

Thanx!
                                       
AlexNewtAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

j2Commented:
IO and IRQ should be BLANK in linuxconf for PCI cards. The "delaying.." is a pretty sure sign of haedware conflict.
Leave IO and IRQ blank and see what happens. Also check /etc/conf.modules to make sure it isnt passing IO or IRQ to the tulip driver. (ie: you should NOT have a line like options tulip io=0xXXXX irq=YY)

Pump is the standard RH dhcp client (and it is crap). I would recommend dhclient from ISC or dhcpcd. To install these you must also be willing and able to modify a few RH system scripts to suit the new DHCP clients.
0
AlexNewtAuthor Commented:
My installation of linux came with dhcpcd currently on it so I went to the ISC site and D/Led dhclient 2. The only problem is thta being new to linux I have no idea what to do with this .tar.gz file. I would also like to know if what I have down as my host name makes any difference.
0
AlexNewtAuthor Commented:
Please explain how to configure dhclient
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

j2Commented:
Hostname makes no difference. the quick guide to dhclient is to untar it (tar zxvf), ./configure, make, make install then edit /sbin/ifup and /sbin/ifdown, repkace the pump commands with dhclient.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hpkolasaCommented:
What if there are two NIC's on the same box and both of them have IO and IRQ's blank in Linuxconf?  Is that going to cause any hardware conflict.  

I have a similar problem. I have two cards eth0 on Lan side and eth1 connected to DSL modem.  I have defined DHCP on eth1 and it fails to get the dynamic IP from the DHCP server on the DSL modem/router. I get the same message :-
Determining IP info for eth0 via DHCP.... [FAILED]

But when I assign an internal IP to eth1 manually , it works fine. I have assigned 10.0.0.2 to eth1, since I know that eth0 on DSL modem has 10.0.0.1. It works fine.

Note that The DHCP server on the DSL router is enabled.



0
kodiakbearCommented:
Fixed the -1 problem on this question.
Escrow points corrected.

kb
Community Support Moderator
Experts Exchange
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.