Mouse detect problem

I've install Linux Red Hat 6.0,all works fine except that doesn't detect the mouse.
It's a "Genius" in the serial port
(COM 1)

Any ideas what I could do?

PD: I try to install a PS/2 Mouse and I have the same problem.
In the same machine I have Win 98 and NT and the mouse is correctly detected.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

You need to run Xf86Setup.  You can test each different type of mouse with it to see if it is working correctly before exiting.  
What do you have up and running so far?  I really find it odd that you got past the installation  without first configuring the mouse for X.  Usually near the end, the installer will ask you to configure the mouse and then you can configure video for X.

In Redhat, you can use mouseconfig at the shell prompt to configure your mouse.  For you it should be a generic serial mouse driver.
check if you got the file /dev/mouse
this file should be a link to /dev/ttys0 (that's if your
mouse is really installed on COM1)

also you could look at your bios settings(try change
the io addresses for com1 and com2)
this could help: do a
"cat /proc/ioports" see what you got there

usually rh6.0 detects the mouse port when installing.
if it didn't do that, it has to be some bios settings
(i guess)
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Make sure that you have serial device turned on in your kernel.
PampaAuthor Commented:
DeTavio, How can I check that is turned on?
(I'am new in Linux).

Crobert, when I install Linux the mouse wasn't detected so I installed it manually.
Now I'am using mouseconfig but any mouse I chosse it doesn't works.

I have the following message when I start X

"/dev/mouse unable to getstatus of fd (Input/Output error)"

What it means?
PD: /dev/mouse points to /dev/TTyS0

Have you ever compiled your kernel? If not, read "running linux" by matt welsh before you try to. You can hose up you system in the worst way if you configure your kernel incorrectly? If you have compiled your kernel before, then do the following as root:

cd /usr/src/linux

type make menuconfig

go down to Character devices and check

standard/generic serial support

That could be your problem if that is not selected. BTW, which kernel are you running?
PampaAuthor Commented:
Detavio,I don't understand your answer.
Why do I have to compile a new kernel If I have Just Install a new version of Linux (6.0)?
Why doing this could help me to detect the mouse?
Because if the standard/generic serial support is not in your kernel, the system will not try setup and use those ports.
PampaAuthor Commented:
I try what your said and doesn't works.

So I try use "setserial" command:
All ports works fine except the one from the mouse (TTyS0):

The message is:

/dev/ttyS0 UART:Unknown Port 0x3f8 IRQ:4

I want to know how can I correct this situation before try anything else.

PD: The other ports are fine...

Can you help me?

It sounds like your Serial port 1 is disabled in your system bios.  Also, if you have a modem, make sure it is not set to com 1 or com 3 as both use irq 4.  If it is on one of those, when your modem is active, youre mouse will fail.  But first check in bios to make sure serial port 1 (or A) is enabled and set to 3f8 irq4.
PampaAuthor Commented:
The BIOS is fine I can use the mouse in Win98 and NT in the same port.

The modem use com 3 IRQ 4

Should I disconnect the modem to try?
How can I change the IRQ that uses COM1?
You can't, but you can change the modem.  Put the modem on com 2 irq 3.  i.e. 2f8 irq3.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PampaAuthor Commented:
I have to change the MEm adress to correct this problem.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.