Linux Email Server

I setup a Linux box to be a POP & SMTP server.  It functions fine, but is a little slow.  It is a Pentium 233 w/64MB.  When I installed Linux I chose everything, and now all the processes or daemons are started upon boot.  I only want to start the ones I need.  This machine functions solely as an email server.  What processes can I get rid of and which file do I edit to do so?  
zzASLANzzAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

biardCommented:
Run linuxconf and select the Control Service Activity option.  There are many you can remove, but which ones depends on what options you need.  Should be able to leave off all of the following (at least):
 amd
 arpwatch
 bootparamd
 crond  (if no scheduled jobs are set up)
 dchpd (if dhcp is not set to control ip addressing on net)
 httpd (if no web server set up)
 lpd (if no printing is needed)
 mars-nwe
 mcserv
 nfs
 nscd
 pcmcia
 postgresql
 ruserd
 rwalld
 rwhod
 smb (if no ms windows access is needed)
 sound
 squid (if no proxy is needed)
 xfs
 xntpd
 ypbind
 yppasswdd
 ypserv

Good luck.
0
zzASLANzzAuthor Commented:
I tried that and now I cannot access a gui interface.  Sorry, I didn't mention that.  LINUX NEWBIE bigtime.  Anyway, the server is up & running with a command prompt.  What do I need to enable in Linux config to boot back to a gui.  I have REDHAT 6.0.  I just want to use xwindows, because I heard that KDE & Enlightenment are resource intensive.  Do I need to reconfigure the Xserver, or can I just go into Linuxconf again???
0
zzASLANzzAuthor Commented:
biard - Please follow-up and I will give you all the points.  This is for work & my boss wants a gui.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

biardCommented:
you will need gdm.  did you disable that?  that is the desktop manager, windows manager.  try typing startx at the shell prompt.  but, if you disabled gdm as one of the control services, then you need to reenable it and restart the machine.
0
zzASLANzzAuthor Commented:
I tried to reconfigure the Xserver via
../Xconfigurator.  It went through all the steps, and brought up the Xserver fine, but then with a reboot, It does the same thing. It keeps trying to start the Xserver.  Finally it says Idx respawning too fast...disabling for 5 minutes....Did I screw it up?? This is our email server for like 30 people.  Please help.
0
zzASLANzzAuthor Commented:
I did not disable gpm.  I did exactly what you told me.  Some of the processes you listed were already disabled.  I just disabled the other ones you suggested.  In addition to the error message I listed.  It tries unsuccessfully to restart the xserver every 5 minutes.  It then says that the gpm service has been started but seems to have been murdered mysteriously.  Please help.  Is there a way I can at least stop it from trying to restart the xserver every 5 minutes until I can get it up again.  I don't want the system to crash.  Help.
0
biardCommented:
OK.  This might sound a little strange, but I had the exact same issue once before.  The screen would be blank at the point where it should enter X, and then after a couple of minutes, it would kick out to that message. Try this from the command prompt for me.  Type df and let me know how full the root partition is (/).  If it is 100% full, go to /tmp and ls -l from there.  Remove any files not in directories.  They are all useless temp files, and take a lot of wasted space.  It seems that once the root partition gets full, Redhat 6 croaks.  That is the exact distro I am running.  I just eventually wrote a script to clean up each day as a cron job, and voila. No more X-death!


0
biardCommented:
OH ****.  Sorry.  Run Linuxconf again and reenable Xfs.  It is the X font server.  You need it.  My bad.  I'm checking over the list I gave you again to make sure that all the others are ok to turn off as well.
0
biardCommented:
Yep.  Looks like the rest should be ok.  Again, please accept my apologies.  I wasn't thinking straight for some reason.
0
zzASLANzzAuthor Commented:
I ran Linuxconf again and enable xfs.  There is not even any gdm.  It is gpm.  It is enabled anyway.  When I tried to reconfigure X.  I chose for it not to automatically start the xserver.  At least that is solved.  The server is up and running, just no x.  I tried typing startx....after I reenabled xfs, and it still crashes.  Did I corrupt the xserver or something..please reply.  Thanks for you fast response.  
0
biardCommented:
Still, go ahead and check the free disk space on / because, as I said, when I had that problem, it was full.  I deleted the temp files in /tmp and all was good.  
0
biardCommented:
Still, go ahead and check the free disk space on / because, as I said, when I had that problem, it was full.  I deleted the temp files in /tmp and all was good.  
0
biardCommented:
Sorry for the double submission.  I reloaded the ? and it submitted twice.  BTW, I will be leaving in approx 1/2 hour from work, so will try best I can to get you up and running b4 then.
0
zzASLANzzAuthor Commented:
No problem.  **** happens.  I am up and running fine.  The server is functioning.  I made sure xfs is enabled.  The disk usage is only 39%.  I tried to reconfigure x...it still test fine, but then crashes when I type startx after reboot.  If you could just follow up when you get time.  Any suggestions you have are appreciated.
0
biardCommented:
No problem.  I also read something about killing the gpm process as it is failing and then restarting it.  I'll look it up and respond again this evening at home.
0
tknayakCommented:
If you have kdeadmin package installed u can use ksysv command to invoke Sys V  init editor .. there u can specify which programs to be started at which run level ..
0
zzASLANzzAuthor Commented:
I am passed that now, but thanks for your response.  Biard gave me the right answer to disable my processes, I just can't get the xserver running now.
0
biardCommented:
Ok, I may now have the answer.  It seems that the reason my deletion of all the temp files worked is that some socket in there is corrupted.  Try this.

Try starting the system in single-user mode (or running the command 'telinit 3' to switch to the "normal" multi-user mode without any display manager (graphical login) running. Then remove the gdm.pid file from /var/run and any stray core files in the root, /root and similar directories.

You might also want to look for any UNIX domain sockets under the /tmp directory and /var. You can use the command
  command: 'find /tmp /var -type s -ls' to look for them.
 
You'll normally find a couple of them under /var for things like the printer (might also be under /dev) and gpmctl (console mouse and cut/paste support) as well as one or two sockets for your X server(s). Those would normally be in the /tmp/.X11-unix/ directory and be named X0, X1, etc. (If you've never run multiple concurrent X sessions then you'll only see X0 under there).
You probably don't have to do anything with those sockets. However, it might make sense to blow away the one's under /tmp. X will (re-)create those as necessary.

Then restart and change back to run level 5.  Hopefully things are corrected from there.
0
zzASLANzzAuthor Commented:
I don't know if I am confident enough to identify which files to delete.  If this was a home box, I'd be a little more adventurous, however I cannot crash this thing.  I don't mean to be a pain in the ass, but I don't want to mess this thing up.  I built, installed, configured it all myself.  I am, sad to say, the in house "linux expert".  It works great as a fully functioning email server.  I don't want to rock the boat.  If you could tell me what to look to remove.   Thanks.
0
zzASLANzzAuthor Commented:
biard...for example....I am not quite sure what you mean by stray core files.  
0
biardCommented:
First off, core files are the memory dump that is done when the system has a failure.  Have you ever had it just stop what its doing and make you log in again? or Netscape crash?  These things and many others create "core" files.  Loomk in "/root" and "/" as well remove any files called "core".  You really should remove these any time you see them.  Unless you intend to start debugging the Linux distribution code, then they probably will not be much help.  Otherwise they just take up space.

Sockets are files created by processes to the kernel for sccess to the processor for time sharing and record keeping (traffic cop).  Did your system crash or have to be shut down improperly at all whilst working on anything yesterday?  There is probably a socket there that is dead, which is owned by a running process (namely gdm.pid).  So, you need to go to /tmp/.X11-unix and list all of the files there.  Remove them (probably just X0).  Then go to /var/run and remove all gdm files as well as all gpm (yes it exists) files.  Usually gdm.pid, gpm.pid, and gdm.pi_.  
0
biardCommented:
Any luck?
0
zzASLANzzAuthor Commented:
work is nuts right now....i plan to get to it asap and ill let you know.
0
biardCommented:
No problem.  Just want to make sure I didn't leave you high and dry.  I'll check back later.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
zzASLANzzAuthor Commented:
thanks.
0
DVBCommented:
gdm is one way to get a X server up and running. (actually its xdm, for gnome its gdm and for kde its kdm). The other way is to use xinit (which is what startx does). gpm is a daemon that allows you to use the mouse in console mode (thats runlevel 3). Try init 5 to get into the gui mode directly. If you have to reboot and need a GUI Login, change your  initdefault to 5 in /etc/inittab . You can start the GUI from the command line by typing startx. You can put it in .bash_profile to get it run directly on login from the command prompt.
Hope this helps.
0
zzASLANzzAuthor Commented:
Thanks alot for all your help.  I am up and running again.  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.