Problem with JPEG files

I have a lot of pictures that I save under My Documents.  Some I receive via downloads, some I scan myself.  All of a sudden, I am not able to open them, and where as before they were .jpeg images, now they are .jpg images, and the icon for all of them has changed.  Whenever I try to open them I get an error message that says, "This file does not have a program associated with it for performing this action.  Create an association in My Computer by clicking view and then clicking folder options."  Now, I did not know what I was doing, but I went to folder options and started looking under "File Types".  I have two things under there that say JPEG image, and under those the file types listed are JPEG, JFIF, and JPE.  No mention of JPG anywhere.  When I attempted to make a new file and put in JPG, I got an error message that said "The extension .jpg is already in use by file type ViewerFrameClass".  I have no idea what any of this means, or what happened to make this change all of a sudden.  Can anybody help??????  Thank-you!!!!



KBRAustinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Patricia Siu-Lai HoCommented:
KBRAustin,  Try this in amending the registry.
Go to start-run, type [regedit    ]  in the open box and click OK.
At the registry editor, go to the key (folder) of: -
My Computer\HKEY_CLASSES_ROOT\.JPG

Above the key (folder) of ".jpg", there are ".jpe" and ".jpeg".

Make the key of ".jpg" and its string value, data and its sub-folders "ShellEx" exactly as the key of ".jpeg".

Finished. Next, go to the My Computer\HKEY_LOCAL_MACHINE\Software\CLASSES\.JPG.
Make the same amendment exactly as above.

Refresh the registry by View-Refresh.

Exit the registry.

Restart the computer.

Let me know if it worked or if you have further queries.     Pslh
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
KBRAustinAuthor Commented:
Thank-you so much, it worked!  After I figured out what you meant by  <<Make the key of ".jpg" and its string value, data and its sub-folders "ShellEx" exactly as the key of ".jpeg".>>  I had no problem.  You are the only one of the many people i asked who provided me with a valid solution.  Thank-you!
0
Patricia Siu-Lai HoCommented:
KBRAustin, You are welcome and thanks!  Pslh
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.