Mac Internet via Microsoft Proxy Server 2 On NT Server 4

Well my problem is how can i configure 3 mac's G3 to have access to the internet using microsoft proxy server 2.

The network also have a few PC's and they are using the proxy as well with no problems.

Is it needed to install Services for machintosh???

I'v tried to set the proxy settings in the mac's internet explorer by name and by IP Address and mac says "Cant Open Page"

Also i will like to grant the macs access to use outlook express to send/receive e-mail from the internet, what must i configure ??? once again the PC's allready are doing this with no problem.
LVL 2
PedroGAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rbrCommented:
Should be no problem. You don't need the SFM. Pls check that you use the correct port.
0
PedroGAuthor Commented:
well i've tried to configure the ip address 10.0.0.2 and port 80, these are the correct settings for the proxy server but nothing goes.

Should i assign an IP address to the mac?? We are using DHCP Server.
0
rbrCommented:
In general DHCP should work. But you can try a static IP.
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

ipierceCommented:
What are the IP addresses of the macs?  There's a bug in mac os 8.6 where DHCP clients become non-responsive for a few seconds every 5 minutes, so you may want to avoid DHCP for that reason.  You can tell the mac's IP address by looking in the TCP/IP control panel and hitting the "info" button.

Once you confirm the macs have ip addresses try pinging them from the proxy server by their IP address.   If this works, but the macs still can't get past proxy (or even see proxy) then you know the problem is on the mac.
0
PedroGAuthor Commented:
i'm not experinced with mac's.

How can i tell the mac os to use my DHCP server??
0
CyberGregCommented:
I use exactly the same configuration that you are trying to get working.

I would assign static IP's to the Mac's and make sure you enter the PROXY IP address in the entry labeled "Default Router". This will forward IP requests to that IP address.

As far as using Outlook Express you must make sure that the "mail" or "other" setting, depending on which version of OE you are using is set to use SOCKS and port 1080. You will also have to use the IP address for things like mail.company.com as the name resolution dosen't work through the Mac.

Post back if you'd like more detailed information.

CG
:)
0
PedroGAuthor Commented:
Well i've did exactly as CyberGreg told and voila, the mac's are now browsing the internet.

Conection to a external mail server is now the problem. I've configured OE to access my mail server (POP3 and SMTP) (i've tried to set the ip address and the server name) but i receive the following message wend i try to "Send/Recieve" mail messages

MAIL COULD NOT BE RECEIVED AT THIS TIME

PROXY ERROR
THE PROXY CANNOT FULFILL THE REQUEST

The pc's are sending and receiving mail with no problem

Wen i change the proxy type to SOCKS (it is in NORMAL) the OE doesn't gives the error, but it does connects to the proxy, a dialog saying "connecting to proxy server at 10.0.0.2" shows up and never goes.

And changing the proxy to SOCKS also mess up internet browsing since it isn't possible with these settings.

Please can anyone gives me some help.
0
CyberGregCommented:
Sorry, need to clarify. Looks like your using OE 4.5 and you need to keep the "ALL" setting to normal but in the next drop down list, change the "other" type to SOCKS and set the port to 1080.

just to clarify, you won't be able to use any domain names, only the IP address. e.g. for sending mail something like 172.12.1.10 and for receiving mail 172.12.1.11.

You'll have to determine these IP address yourself.

Good Luck!
0
PedroGAuthor Commented:
No i'm using OE 4.01, do you think is best for me to download IE 4.5 and OE 5 ?
0
CyberGregCommented:
Actually yes, Outlook Express 5.0 updates the PROXY settings in both Internet Explorer 4.5 and Outlook Express 5.0.

I think its easier to configure.

You should still be able to configure 4.01. I used it for awhile before 4.5 came out.

Post back if you're still unable to send and receive.

CG
:)
0
PedroGAuthor Commented:
i've updated to IE 4.5 and OE 4.5, i've setted the "other" to socks and port 1080, i've placed my pop3/smtp server ip in the acount (i got this ip by pinging the server from my nt box)

Wen i do send/receive from the mac, it says connecting to socks, in my NT in current sessions i see the mac Ip as an active connection.

After a bit of time the mac say's something like "Socks Proxy Error" and nothing more!!!

The IE now works good as i only changed the "other" proxy and left the "all" with normal
0
CyberGregCommented:
Do you have any restrictions set in MS Proxy server?

Make sure the user has full access to the SOCKS portion of the Proxy server.

Did you put a user name and password for the socks settings in Outlook Express?

Happy Holidays!
We'll keep at it!
CG
0
PedroGAuthor Commented:
sorry i know this is not a Mac question, but i've granted permission to the mac's Ip address, should it be all ??? what more most i do to give full access ??
0
CyberGregCommented:
If you're not concerned with security then add the "everyone" group to the users listed in PROXY server. You need to add the group to the "SOCKS" server permissions in the PROXY server.

If you are concerned with security then you need to create a MAC user in NT. Then add this user to the PROXY server permisions. Next configure Outlook Express to use the new username and password under the other category.

Good Luck
CG
0
PedroGAuthor Commented:
sory to bother you again, but something must still be wrong!!

If in the permissions tab of the socks proxy i add a permit to all everything is ok

Well but these doesn't seems very good for security.

My domain is DDDESIGN and i've created a user caled MACUSER in the NT. Also on the mac for Socks Proxy i placed the user and password.

I've tried to add a permit to
   MacUser
   DDDESIGN/MacUser
   DDDESIGN\MacUser

And nothing works, only with permit all

Please can you tell me what is wrong
0
CyberGregCommented:
If you are looking at the "SOCKS" properties of the PROXY server, the options for adding permissions are based on ports. These permissions effect the MAC clients and unless you want to add several different ports to the list I would go back and "Permit" ALL ports Greater Than (GT) zero.

To make sure we are both on the same page...

Access the SOCKS Proxy properties.
Click on the "Permissions" tab.
Click the "Add" button. Set the Action to "permit", set source to ALL, set Port "GT" and in the Port number or service name section enter a zero.

Click OK and now you should have 1 entry in the permissions list.

Now try Outlook Express on a MAC.

I have setup many MS PROXY servers in this manner and have not had any problems. I think your only other option is to enter the ports used by the MAC. A quick list would include the following ports:
21, 25, 80 & 110.

What permissions have you set in the other PROXY servers?

Keep at it...
:)
0
PedroGAuthor Commented:
i thing i haven't explained my self ok, i've did add the permissions to all in port grathe than 0, i was woundering if this isn't a major security leak???

The other setting are working ok, i've added the users, and what is the type off protocols allowed (Basicaly not allowed IRC and others like that )


By the way hapy new year!!!
0
CyberGregCommented:
Windows NT magazine (October 1999) did an EXCELLENT article on setting up PROXY server for maximum security.

To that extent I can't say that having the SOCKS server set to allow ALL ports is not something to be concerned about, I don't know how your NT server is configured.

At the very least if PROXY server is your FIREWALL too then you MUST have two NIC's and make sure you have disabled the NT Server service on the Internet NIC.

.... that's a topic for another post perhaps...

Bottom line... can the MAC's send and receive email?

HAPPY NEW YEAR!
CG
:)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple Networking

From novice to tech pro — start learning today.