No Access to Network

I have installed Linux 6.1 on a 133 Pentium clone computer. It is the only O/S on the computer.
There are only 2 cards in the PC, one ATI
Allwonder video card and one Kingston EtheRx VP 10/100 KNE110TX network card.
Linux sees the card at boot up and I can use the "dmesg |more" command and the card is in the list and seems to be active.
I can ifconfig or netstat and the card shows up.
I can ping the cards IP and loopback.
I know the card is good, I can install Windows 95 or Win Nt 4.0 on this same machine and networking works. So the card is working, the cable is good, the same port on the hub is good, but I can not ping any other PC on the network. On the hub, the light for the port doesn't change color showing a connection.
In the docs for Linux, the card is supported. I have also tried 2 other cards with the same results. ( Compaq NC3121 and NetGear FA310TX)

Any ideas?

Thanks for any help
Dick
LinuxDickAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

laeuchliCommented:
When you setup your linux machine make sure you chose real network intsead of loopback. The only other thing you could try it make sure that you have the network deamons are loaded like telnet ftp etc. not sure how this would help but you can try. Also make sure you have  given a subnet a ip and a domian. If you don't have a domain you can make one up.
0
LinuxDickAuthor Commented:
All TCP/IP modules are loaded.
There is a domain name, static IP, valid subnet mask.
As I said, if I use the same pc, same config for tcp/ip for another o/s, things work.
Thanks for your answer, but it really didn't help.
0
biardCommented:
What have you set the default gateway to?
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

biardCommented:
Please post the output of
ifconfig -a
route (with no agrs)
0
lewisgCommented:
I *think* you have a hardware problem.

"Modern" network cards will work in windoze since PNP may work for that card (or cards) on that day (or days).

One of the best items I have in my "toolbox" is a 3C509 that is set to 5/300 TP half duplex. If I put that card in and the network still does not work I KNOW the problem is not in the NIC. I think the 3C509 is the most supported card on the planet - and they are available used for under $10.

BTW - when you run ifconfig do you see RX and TX packets? Are the IO and IRQ values the same as the configuration software for the card reports?

Best of luck!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LinuxDickAuthor Commented:
I will leave out the first two numbers,
The gateway is right, as I have two other pc's on the same subnet and that is the only gateway.
gateway: xx.194.35.193

below is ifconfig -a

link encap:ethernet  hwadd c0:00:48:f0:1a:e1
inet addr:xx.194.35.195 bcast:xx.194.35.199 mask:255.255.255.248
up broadcast running multicast mtu:1500 metric:1
other fields at 0
collisions:0 txqueuelen:100
irq 9 (have tried others)
i/o 0x6000 (have tried others)

thanks for any help
0
LinuxDickAuthor Commented:
RX and TX packets in these fields are 0
the irq and i/o do match when I make a change with the supplied disk that comes with the card(s)
the plug&pray are disabled (also tried enabled)
the one thing that all 3 cards are: PCI
I need to dig in the workshop and grab a ISA card to test with...that is the only thing I can think of.

Has anyone ever had this problem?


thanks for any help folks
0
castleinfoCommented:
I kind of agree with the proposed answer, use a 3C509 and use the config disk supplied to make sure it is at the correct duplex,speed IRQ etc.
I often get problems with cards autosensing the wrong network speed and not working. Auto sensing hubs are an effective solution to this.
0
biskCommented:
Find out what chipset the card is.  If its a DEC 21143 linux is probably loading the tulip module for the card.

% lsmod
Module                  Size  Used by
tulip                   XXXX  1  (autoclean)
%

This module doesn't work with the 21143 chipset.
Fire up your favorite text editor and edit /etc/conf.modules
change the line:
alias eth0 tulip

to
alias eth0 de4x5

Then restart networking with /etc/rc.d/init.d/network restart

Now ping, etc to see if it works.


                                             
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.