Promise Ultra 66 & Slackware v7 (2.2.13)

This is a taxing question.

    I'm having a bit of bother with my promise Ultra66. i'm running Slackware v7(v2.2.13) WITH the patch for the controller.  One gigabyte 6BXE Mainboard (v3.4).

On the primary IDEe channel i've got a Quantum FireBall 2110A 2gb (primary)
2nd channel is only a primary IDE CD (24x AKO)

now i've got this Promise ultra66 with 2 x 9gb Quantum KA's (both as
primary's on different channels).
And when I recompile the kernel with support for this thing it boots up and
shows all
the IDE channels loaded but it seems to hang when trying to access the
/dev/hda (Quantum Fireball 2gb) for the 1st time. hdparm says it supports
dma. And i dunno what to do now?!!?!? Has anyone had any problems with the
compiled patch?

Any and all help appreciated..

Stephen



littleeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gilbert111199Commented:
I'm not sure about slackware, but I know Promise makes a driver for the Ultra66 card for Red Hat. I have the same card and had the same problem, until they finally released the Red Hat driver. Then it was ok.I heard for now they only have a driver for Red Hat since that is the most popular Linux distributor, so you might have to wait a while to get a working Slackware driver.
0
littleeAuthor Commented:
Well sry i guess i'm looking for an anwser not a reason.
0
jelaiwCommented:
I pulled this off the linux-raid mailing list archive, but basically you should make sure you have the unified ide patch (from /people/hedrick off any mirror) and it helps to have 2.2.14pre14 for some reason.  Call it magic.  :-)

let me know if this helps, or if you need links to mailing list archives, etc.

jw
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
littleeAuthor Commented:
Ahhhh I should off tried to Up the Kernel. DOH! (p.s. I haven;t tried it but i'm 99% certain that'll fix it - hell it fixes most driver issues.)
0
littleeAuthor Commented:
Oh BTW Jelaiw could u email the link for the linux-raid mail list. Ta littlee@bigpond.net.au

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.