can't start xfree86 3.3.5

Hi,

I'm having a really hard time trying to run xfree86 3.3.5 on my machine.  I've posted this question to both the Red Hat and Mandrake mailing lists, and also the xfree86.org tech support to no avail.  I hope someone here can help me.  I was running xfree86 3.3.3.1 just fine on my machine.  It's a dual Pentium II 350, Matrox Millennium G200 16 MB AGP video card.  I installed the xfree86 3.3.5 RPMs: SVGA, 75dpi-fonts, libs, devel, and XFree86.  The rpm -Uvh installation went fine.  Then I configured with xf86config.  No problems there, either.  The XF86_SVGA server was automatically selected by xf86config.  But then when I try to startx, I get the error:

/usr/X11R6/bin/Xwrapper: can't resolve symbol '__xstat'
_X11TransSocketUNIXConnet: Can't connect: errno: = 111
giving up.
xinit:  Connection refused (errno 111): unable to connect to X server
xinit:  No such process (errno 3): Server error.

I'm running mandrake 5.3 with smp kernel 2.2.9.  This machine can run xfree86 3.3.3.1 just fine.  What's my problem with 3.3.5?  Thanks,



Hidong
emeraldkim121799Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

patowicCommented:
Personally, I've never had any luck upgrading rpms for xfree86.  Have you considered downloading the source code from http://www.xfree86.org/, and compiling that from scratch?

Try starting X manually, with the       -verbose option.  That might shed a little more light on things.
0
emeraldkim121799Author Commented:
Hi, patowic,

I'll try compiling.  What do you mean by start X manually?  Thanks,



Hidong
0
patowicCommented:
Well, you could always just type X -verbose & from the command line, and then if it starts, use ctrl-alt-backspace to exit.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Brandon121799Commented:
This could be too plain simple, but try running /usr/sbin/xconfig or something like that.  Then at the end of it configuring itself again (like it did when it originally installed) tell it to start itself on startup.  Sometimes when you just reinstall it helps.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
emeraldkim121799Author Commented:
Hi, Brandon,

I don't have a /usr/sbin/xconfig.  What do you mean by start itself on startup?  Do you mean to set the run level to 5?  I'm really going bats trying to figure this out.  I've tried installing 3.3.5 by compiling the source.  In that case, X wouldn't start up saying that there was no file libXmu.so.6.  In fact there was a /usr/X11R6/lib/libXmu.so.6.  I added this directory to my PATH, but it still couldn't find it.  I tried installing 3.3.5 on another machine with a different video card.  Same problem.  I'm beginning to wonder if it's the distribution.  I'm running Mandrake 5.3 kernel 2.2.9.  Would this have anything to do with it?  Thanks,



Hidong
0
patowicCommented:
If you can't start X manually, don't set your runlevel to be 5!  
Have you had any luck compiling your own version of xfree?  The more I hear about Mandrake, the less impressed I am.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.