Win98 sound recorder won't work

I have an onboard Sound Pro sound card on my Pentium motherboard. Since installing Win98, the sound recorder is not accessible, and is grayed out. I have installed the drivers that came with the motherboard, and while they work fine for the sound playback, recording is not available.
zaf121799Asked:
Who is Participating?
 
Patricia Siu-Lai HoCommented:
zaf,  You may give this a trial.

Go to the control panel, multimedia, Audio, click the Playback icon, the Volume control.
Select the Menu-Options-Properties,
Mixer device [Sound System Mixer (534) ]
[x] Recording

     [x] Line in
     [x] Microphone

Click OK. A Recording Control panel pops up.
Checked the boxes for
     Line in         [x] Select
     Microphone  [x] Select
Close

Go back to the previous page

Mixer device [SB16 Mixer (220) ]
[x] Recording
     [x] Line in
     [x] Microphone

Click OK. A Recording Control panel pops up.
Checked the boxes for
     Line in         [x] Select
     Microphone  [x] Select
Close

Exit the multimedia.

Click the volume icon at the systray. Adjust Audio properties.
The recording icon will be found enabled.
0
 
zaf121799Author Commented:
Adjusted points to 50
0
 
MRVWCommented:
Are the new drivers for windows 98 or 95? If they are for win 95 they may not be fully compatable with 98.  Check you mainboards homepage to find out if they have drivers for win 98. Good Luck - Mike
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
Patricia Siu-Lai HoCommented:
zaf, Do you know the motherboard model, please advise?  pslh
0
 
bartsmitCommented:
The soundpro chipset on the TX Pro II motherboards is a CMI8330. Get the latest driver here:
http://www.cmedia.com.tw/8330/30w98v64.zip
0
 
zaf121799Author Commented:
A good idea, which I tried, but it does not solve the problem. The soundpro chipset is correctly a CMI8330, and the drivers that came with the motherboard are actually for WIN98.
0
 
bartsmitCommented:
How about your multimedia settings?

Start, settings, control panel, multimedia. Check that the CMI8330 is shown as the preferred device under recording. Also check the devices tab for the Microsoft PCM converter Audio Compressor Codec.

You did install all components didn't you? Add/remove programs, windows setup, multimedia. Check audio compression and sound recorder.
0
 
Patricia Siu-Lai HoCommented:
zaf, Use find to locate the file C:\windows\Sndrec32.exe and also the Sndrec32.exe on your soundpro driver directory either in CDrom or downloaded version.

Check the date:
Sndrec32.exe 05/11/98 (win98)    C:\windows\
Sndrec32.exe 07/11/95 (cdrom/soundpro driver)

Use window explorer to select the file   C:\windows\Sndrec32.exe  (dated  05/11/98) and rename it to Sndrec32.w98.
Then copy the Sndrec32.exe (dated 07/11/95) to the C:\windows\ directory.

Restart the computer.
Next go to the control panel, multimedia,
Playback  : preferred device: [Sound System Playback (534) ]
Recording: preferred device: [SB16 Record (220)                 ]

[x] Use only preferred devices.

Click apply and OK.

You may also need to go to the device manger of control panel, Sound, video and game controller,
Remove the SB16 Audio Device.

Restart the computer 3 times. Inspect if the recording. You may also double click the
C:\windows\Sndrec32.exe   (dated 07/11/95) and test recording result.

pslh
0
 
zaf121799Author Commented:
Have tried both suggestions, from bartsmit and pslh, unfortunately with no joy! Sound recorder is still grayed out and inaccessible
0
 
zaf121799Author Commented:
Adjusted points to 75
0
 
Patricia Siu-Lai HoCommented:
zaf, is the problem still there or not?     pslh
0
 
zaf121799Author Commented:
yes it is - haven't managed to solve it
0
 
zaf121799Author Commented:
Thanks pslh! Worked perfectly. Good to have my recording back after so many months!
0
 
Patricia Siu-Lai HoCommented:
zaf, You're welcome!     pslh
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.