ftp and telnet not working for users

I have installed "Complete Linux 6.5" using the "server" option. I have setup the network, giving the machine a static ip and qualified domain name. I have created 2 accounts, one using bash and the other csh as the shell. The only remote access I have to the machine is by anonymous ftp.  For a two week period my students need to be able to create user accounts and for the next 16 weeks be able to post web pages to their accounts. I was able to do this on a early dubian version but not with this new version. Please help.
bgelyk1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DVBCommented:
Are you using ipchains or some security software that prevents access to the ports? A firewall maybe?
0
TYoungCommented:
Does /etc/nologin exist? If so, delete it.

Does the shell that they are using exist in /etc/shells? If not, add them.

If you are using shadow passwords, make sure you compiled the ftp and telnet daemons for support with them.
0
a2h0miCommented:
first, are your sure that the remote-access is possible (ping)?

can you login (console) on your local system as on of the user-id?

Have you set rights to fallow files:
ftpasswd, host.allow, host.deny...

There was one file in /etc directory where telnet and ftp access you can set.
(forgett the name, but you can search with a grep "in.telnet")

reg., a2h0mi

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bgelyk1Author Commented:
It appears that the "server" install of Mandrake does not provide in.telnetd anywhere. I was able to get the ftpd to work by setting up the hosts.allow and hosts.deny file. To solve the account creation problem I used "linuxconf" to turn on the web version running on port 98. ie your.web.site:98. It appears that linuxconf has its own web server. I think I am set. Thanks to all who responded.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.