Serial Port Problem

I cannot connect to my ISP with Linux.

First I though it was a problem with my ppp software, then I though it might be the dialer, now I'm sure it's the configuration of the port itself.

I could say a lot about the symptoms of my problem, but the gist is this: my serial port (/dev/ttys0) configuration is set for the right irq (4), Linux never complains about any conflict, but every program I have used from minicom to gppp or kppp always says that the modem is busy.

Whether the modem is on or off, every dialer tells me the modem is in use. According to /proc/interrupts, the irq is used only by the serial port, but the lights on the modem never blink with Linux. Minicom doesn't report any errors when it's initialising the modem, but if I try to dial, it tells me that the modem is already in use and that I have to hang up. Again, whether the modem is actually on or off makes no difference. The modem works perfectly with windows, so the modem is not the problem. It's an external USRobotics 56K Faxmodem. Not a Winmodem.

Configuring the BIOS to "non Pnp OS" doesn't change anything. According to a command called "fuser" (I'm still new on Linux and I'm not sure what is exactly is) there are no programs using /dev/ttyS0 other than the dialers, whenever I use them. There is only one serial port on the computer, so there are no conflicts there.

Since I never found anyone who could provide a solution, this problem is probably more of a challenge than it seems. And if it is not, that's all for the better.

Thanks to anyone who has a solution.
LVL 1
eje211Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

eje211Author Commented:
Edited text of question.
0
eje211Author Commented:
Adjusted points to 100
0
bughead1Commented:
How do you attempt to dial?  For example, are you using the kde setup, kppp?  Or do you start and stop it at the command line with ppp-go and ppp-off? Using demand dial (part of ppp) or diald (a separate demand dialing program)?  Then, what Linux distribution and version number are you running: ie., Caldera 1.3, RedHat 6.0, Slackware 3.9?
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

DVBCommented:
Any files of type *.lock referencing the port? Or the modem? Or the dialler?
I had this problem with RH 6.0, upgrading to 6.1 solved it (but the question is still open because I would like to know why).

Again are you running mgetty?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
eje211Author Commented:
To bughead1:

I have tried dialing with kppp, gppp and minicom. I have Red Hat. All said the modem was already in use, which it was not. I don't remember if I installed 6.0 or 6.1. I have both CDs now, but I think I only had 6.0 the last time I installed Linux. I'm going to look into downloading an upgrade.

To DVB:

I'm still new at Linux, and I don't know all of the programs that have "tty" somewhere in their name. But I'm pretty sure I am not using mgetty. I was considering trying it, even though I have no idea what it is; the "tty" in the name makes it look relevant to my situation.

I tried looking for some lock files some time ago. But I don't think it's the problem. However, since I'm getting more familiar with Linux, I will try and look for them again, this time with a better understanding of what they are. (I've been reading modem and serial HOWTOs lately.)

Thanks for your help. When I find a solution to this problem, I won't have to go on Windows to try and solve my Linux problems anymore.
0
bughead1Commented:
As root, use whichever text editor (vi, vim, etc.,) that you are most familiar with and open /etc/ppp/options.  Clean it out, or comment out every line. (To comment out a line means to put a "#" symbol before the line--Linux will then ignore it).  In particular, leave no line that reads "lock"

After that, return to kde and run the kppp setup as root again.  If, after that, you can connect as root, post that fact as a comment and we can help you set permissions to run kppp as an ordinary user.

If not, we can then begin to troubleshoot your kppp setup.

0
DVBCommented:
mgetty is a program that lets you dial in from an external machine.
0
eje211Author Commented:
This is what happened: I did upgrade from Red Hat 6.0 to 6.1 and the serial port problem vanished. I still can't connect, but for reasons that have nothing to do with the serial port. Since it is DVB who suggested that I upgraded, I'll accept his comment as the answer.

Thanks to both of you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.