• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 224
  • Last Modified:

Linux won't load: "bsh#"?

I had Linux happily installed.  Then I upgraded GNOME.  That went smoothly.  But somehow some KDE files I had included got in there as well.  KDE didn't work.  So I rebooted.  I had set things up so it brought me the graphical login screen in RH 6.0.  After rebooting, nothing showed up.  Well, a grayish/black(speckles) background, but no windows, nothing.  I guess I could have tried Control-Alt-F7 but didn't know about that... I thought just reinstalling would fix things.
  So I reinstalled.  Only to find that now my linux partition was messed up.  ("hard disk error.  run fsck) but fsck didn't execute.  Now upon booting (thank goodness Lilo still works and I can get into windows!) it does the normal stuff then just has a bash# prompt.  Please help.  I think reinstallation might help but my RH cd is scratched so that GNOME doesn't install.  Last time I just used KDE, it worked fine and I could install GNOME after downloading it.

Gateway PIII 450
Quantum Fireball CX13.2
RH 6.0

brandond@lightspeed.net
ICQ 34417422
AIM Wpolo376

yes I am desperate for an answer!! Please help.  I am new enough to Linux that I've never compiled anything.
0
Brandon121799
Asked:
Brandon121799
  • 2
1 Solution
 
Brandon121799Author Commented:
Adjusted points to 80
0
 
freelonCommented:
Hi,

There are probably two ways for me to answer your question:

1.  When you log in to the "bash#" prompt, you may only need to run the command "startx".  This is the shell command to start the graphical user interface.

2. If you want the computer to boot into graphical mode, you may need to change the default runlevel.  The file /etc/inittab has a line which looks like this:

id:3:initdefault:

If you see a number 3 there, that usually means it will boot into the text console by default.  This may not be what you want.  If you want to always boot into KDE/GNOME/etc., you should edit this file (with an editor like vi, pico, emacs, joe, ...) and change that number to a 5.  Save that file, then reboot the system (i.e., type "shutdown -r now" at the bash# prompt).

Both of these steps assume that X is properly configured.  If it isn't, you need to run "xf86config", "XF86Setup", or possibly "Xconfigurator" to fix your video settings.

BE SURE that you can run "startx" (as mentioned in suggestion #1), before attempting to implement suggestion #2!

~f
0
 
Brandon121799Author Commented:
Well your comment had not bearing on my solution, but thanks anyways!  I've kept that in mind in case something like that happens to me in the future.  I just reinstalled everything.  Now I can't get GNOME to install again, but oh well.  One problem at a time!  Gracias :-)
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now