init level problem

i am working with UW2.0.1 . This is a network node . here i configured DNS, MAILSERVER, WEB
                       SERVER , almost everything.
                       Yesterday one of my officer shutdown the sever with init level 6.  after this i am not able to telnet
                       to any machine . locally also i am not able to telnet to my server itself.
                       while booting it is shopwing my default gateway is unreacheble.
                       How to boot my system with old status.
                       from man pages i checked abt init level 6. it is showing as follows
                       Stop the operating system and reboot to the  state
                                      defined by the initdefault entry in /etc/inittab.
                       now it is boooting with init level 3 ( default in /etc/ inittab)
                       how can i boot my machine with old status
Who is Participating?
jonkeConnect With a Mentor Commented:

# /etc/init.d/inetsvc start

from the command line. It might just be that the machine is not kicking this off at boot.
Have you tried telneting to the IP address or to localhost? Is telnet responding or are you receiving errors that indicate that telnet is not being executed?

All init 6 does is reboot the server. Generally this is not a good way to reboot if you have applications that need to be shutdown properly before restarting the system. However, OS services will shutdown properly with init 6. The init 6 should not have affected telnet services.

Suggest you check your name services and you inetd.conf and host.allow/deny files.
mon1Author Commented:
i tried to telnet localhost. it is working fine. but if you  try to telnet the server name or remote machine. i am getting the error messages as ..

UX:telnet:ERROR: Unable to connect to remote host. Cannot assign requested address.

if i give themachine name with telnet.
it is showing  machiemane: hostname lookup failure.
after shutting down the machine with init level 6 only , i faced the problem....
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Good. This says that telnet services are working but naming services are not. Try putting a machine name and IP in /etc/hosts. See if you can telnet to that machine. Chances are you will be able to telnet to that machine.

Have you verified that name services are running? How did you configure name services (manually or through the DNS Manager)? Are you familiar with DNS concepts?

mon1Author Commented:
i configured DNS , MAIl service, WEb server everything in this machine. It was the main server in our office. Evrything is workijg fine also earlier. We are giving internet serviuce to users..
One day i shutdown the machine with init level 6. aftyer this only the problem started....

If you give telnet ipaddress ( Server itself)
i am gertting the error messages.

UX:telnet:ERROR: Unable to connect to remote host. Cannot assign requested address
what does it mean..
Earlier everythig was working well.
Are you saying that all other services are working? Can you ping by name? How about FTP; does it connect OK? Have you looked at the syslog to see if it is posting any errors? If so, can you post them?
Maybe you had a manual configuration on your server before the reboot. So, whe the system rebooted it was lost. Check if a configuratio was done manually and not permanently on your server.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.