HD speed

I have two ultra ATA/66 HD's in my system. I have just read that a special cable (40 pin, 80 conductor) is required for the HD's to run at max capacity. I am wondering how I could verify that I have the right cable...other than buying one. Perhaps visually or a utility that will clock the data transfer rate.
LVL 12
jgvAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jhanceCommented:
ATA/66 and normal IDE cables are made from different cable materials.  Look at the cable.  If it's similar in appearance to the cable going to the FLOPPY except for it's width, then it's a standard 40 pin IDE cable.  If it is markedly different and has 80 conductors, it's an ATA/66 cable.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jgvAuthor Commented:
Looked the same so I bought the proper cable. Discovered that besides the ribbon looking different (finer wires, grey) the connectors are colour coded.

Blue-motherboard
Black-primary drive
Grey-slave drive

Out of curiosity, when I check the properties of either HD through the 'system' icon in control panel, the DMA check box is not selected. Is that normal or should it be checked?
0
jhanceCommented:
The installation selects DMA off by default for maximum compatibility.  Before enabling it, however, you need to be sure you have located and installed the latest UDMA/66 drivers for your specific motherboard.  Go to the website of your system or motherboard manufacturer and download the correct drivers.  The installation of these should turn on DMA by default.
0
jgvAuthor Commented:
Looked for an updated driver but already had it (system is a few months old). I turned on the DMA for both drives and did a quick test. It took 1:28 to copy 325 Meg of files from HD-HD. That's close to half the time it took to copy the same files before adding the cable. Looks like it's working the way it should now.
Thanks for the help
Jim
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.