Database Desktop

I have problem starting Database Desktop.  Everytime I execute that program it give me this error :-

Could not initialize BDE.:
Directory is controlled by other .Net file.

The only option I have over at the error message box is OK button.  When I press OK, the program terminates.

Does anyone have any clue as to what has happened and how to solve this problem?
kokhooAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kretzschmarCommented:
hi kokhoo,

examine your system and delete all .net from your system and try again

meikl
0
lleonardCommented:
Kokhoo,

>> Could not initialize BDE.:
>> Directory is controlled by other .Net file.

This message suggests that you've either:

-- Got another BDE application running (e.g. Delphi, Paradox, dBASE, or a custom app you wrote with Delphi) when you start the Database Desktop.

-- Crashed really hard recently, leaving a series of lock files from open tables, as well as the .NET file the Meikl mentioned.

Resolving this depends on what happened. If it's the latter,
then:

1.  Shut down all BDE apps, including Delphi.
2.  Find and delete *.NET and *.LCK.
3.  If you're using 16-bit, reboot.

If it's the former (that is, you've got two applications running), then you need to configure BDE--and probably your other app--to be more aware of each other.

The NET file controls the pessimistic locking that Paradox uses.

All applications that lock Paradox tables in a shared environment need to use the same NET file.  (You can get around this if you don't share the data.)

Use either the IDAPI/BDE Configuration utility (16-bit) or the BDE Administrator in Control Panel (32-bit) and select the
native Paradox driver.  You'll see a setting called NET file.

Set that to a directory shared between all users (and processes) that will be sharing the tables you're working with.  This needs to be a directory with WRC permissions for all users working with the tables.

Save the changes.  (They get writting to either a .CFG file or the Registry, again depending on your version.)

Now, you can set NET FILE, a tSession property, at runtime in your Delphi apps, though I usualy find it easier to simply configure the end-user's local .CFG file.

I mention this in case you have several different applications using the BDE and want to incoprate an easier way of changing the NET file.  (I sometimes use INI Files.)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kokhooAuthor Commented:
Thanks.  I am abled to run my Database Desktop now.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Delphi

From novice to tech pro — start learning today.