routing between different subnets/interfaces

Question:
What can I do to solve my routing problem stated below?  I don't care whether I have to configure the linux or the NT, so long as it works!

Details:
I have an NT 4.0 server using ethernet (10.2.0.7, gateway 10.2.0.1, mask 255.255.0.0) and token ring (10.1.0.50, no gateway, mask 255.255.0.0) with RIP service installed and active.

I have an Open Linux 2.3 2.2.10 box using eth0 (206.xxx.xxx.xxx, gateway 206.xxx.xxx.1)which is the 'public' side connected to ISP; eth1 (10.2.0.1, no gateway, mask 255.255.0.0) with masquerading installed.

All ethernet stations (10.2.x.x) can utilize the internet as expected and work perfectly; this includes the NT server itself.

All token ring stations (10.1.x.x) can ping ANY other ip on the ethernet side EXCEPT the linux (10.2.0.1); and so I believe that is why they CANNOT utilize the internet.  The linux box cannot see any token ring stations.

I have tried adding another default route on the linux pointing to 10.2.0.7 (NT) and that lets ALL stations ping ALL OTHER stations; great except it shuts down access to the internet!

I have tried adding a token ring card to the linux, but as soon as it comes online, it shuts down our WAN router!  Let me know if more info is needed

I hopefully gave this enough of a chunk of points for your trouble :)

Todd
ToddRodAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ToddRodAuthor Commented:
Edited text of question.
0
dcavanaughCommented:
Have you tried setting the default gateway on the Token Ring stations to 10.1.0.50?

Does the linux box have a static route to the 10.1.x.x network?

route add -net 10.1.0.0 netmask 255.255.0.0 gw 10.2.0.7 eth1

If this does not work, please include the results of the ifconfig and route -n commands from the Linux box.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dcavanaughCommented:
Things I should have mentioned in the first comment:

Alternative commands for adding the static 10.1.x.x route for the Linux box:

route add -net 10.1.0.0 netmask 255.255.0.0 gw 10.2.0.7

route add -net 10.1.0.0 netmask 255.255.0.0 eth1

I don't do this often enough to remember which one is precisely right for your situation, but I think the lack of a 10.1.x.x route for the Linux box would cause all of the behavior you mention.  
Assuming you get this to work, you'll have to update your network routing configuration using the appropriate tool for your distribution of Linux.  

Theory: When you experimented with 10.2.0.7 as an auxillary default route for Linux, you provided a viable path from Linux to the 10.1.0.0 network.  The problem was that Linux was fooled into thinking that packets could be delivered to <any> IP address via eth1, which is definitely not true.

Assuming you get this to work, you'll have to update your network routing configuration using the appropriate tool for your distribution of Linux.  

I may get flamed for this, but I favor putting this kind of stuff into a script that gets called from rc.local.   I usually do my upgrades via the fresh-install route,  so I depend on a backup copy of my script file to faithfully re-create my network environment.  I have upgraded many times, and everything worked as long as eth0 and eth1 were physically connected to the the right cables.   If nothing else, it makes me believe that I know how IP networks work.
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

dcavanaughCommented:
Did it work?
0
sinfulheathenCommented:
Have you enabled IP forwarding for the Token Ring card on the NT Server?  also,  Is your IP Masquerading setup aware that the 10.1.x.x hosts should be allowed to forward packets through the 10.2.0.7?  

Goodluck
0
ToddRodAuthor Commented:
yes, I already had to default gw set to 10.1.0.50 on the tr machines.

the command: route add -net 10.1.0.0 netmask 255.255.0.0 gw 10.2.0.7 eth1
did the trick!  I believe the key was to tell it which interface to use (eth1 in this case) I had actually tried this same command before (minus the interface option) and it killed access to the internet.

Thanks for the tip and lesson!



0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.