ADSL config under redhat 6.1

I'm pretty sure this is an easy question, but here it goes.
I just got an ADSL connection to the internet. The connection comes into the ADSL modem, then to a hub which is connected to a Win98 computer and my Linux box. I am running RedHat 6.1, and I am using a 3COM 3c509 ethernet card. Here's the problem. The ADSL modem has an ip in the 10.129.x.x range, the win98 computer has an ip in the 142.59.x.x range. with my current configuration, I can ping the win98 machine, but I can't ping the modem. if I leave out my nameserver info, then I am assigned an ip in the same range as the modem instead of the win98 machines range. I think that DHCP is working because I get back a few domain names in netcfg that weren't there before...why can't I get this to connect to the internet? The information I am given is scarce. I was told the DNS numbers, the domain, and the host. My configuration is comparable to the win98 box, but something's not clicking.

Thanks.
k0jackAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Bo0gi3manConnect With a Mentor Commented:
OK...now you can set it manually, all you have to do is save it to a script file.

cd /etc/rc.d/
pico rc.local

now your in editing the rc.local script file which runs every time you start your computer.  this is the same file I have to be in because I use multiple ip's for 1 network card.  here's example of what you should put here.

scroll all the way down to the bottom.

ifconfig eth0 192.168.100.1 netmask 255.255.255.0 broadcast 192.168.100.255

route add -net 192.168.100.0 netmask 255.255.255.0

----
there ya go, now everytime you start your computer you will have the network and hopefully the internet working, just replace 192.168.100.1 and .0 with your corresponding network address, also if you are using netmasking, put those in there also.

0
 
ihardingCommented:
In order to help out, please post the following for each card on your network;

ip, subnet mask, default gateway

Also see

http://www.linux.com/howto/mini/ADSL.html
0
 
k0jackAuthor Commented:
This is the problem...according to my ISP, I don't need to know any of that information. I am supposedly supposed to query the DHCP server and have it set up automatically.
The ip is supposed to be 142.64.59.210
the subnet mask 255.255.248.0
the default gateway 142.64.59.1

And the howto was utterly useless to me.

Thanks
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
sirwnstnCommented:
I was wondering.  Did you get ADSL service for only one computer or more than one?  I am intrigued that your ADSL modem has its own IP.
0
 
crouchetCommented:
As I understand it, that is the norm. The "modem"  connects and gets an IP dynamically. Turn off your computer, reboot and the same IP is still in place. So long as that modem is on that IP is retained.

There is a great deal of information out on http://www.cablemodeminfo.com and I recommend that site as a must for anyone thinking about cable modem, ADSL or other flavors of DSL.

You will probably find the Linux Cable Modem section very helpful.

J Crouchet
0
 
k0jackAuthor Commented:
I got ADSL for two computers. The ADSL modem, as I understand it, acts as a router.

Thanks crouchet...I will check out those resources.

k0jack
0
 
crouchetCommented:
Yeah, sorry no one had an answer handy for you. Many of us have a lot of experience with Linux, but most are new to DSL.

If you do get an answer, please let us know. I know I will be getting ADSL some time this year.

J Crouchet
0
 
k0jackAuthor Commented:
well, I checked out the resources on cablemodeminfo.com and none of them really helped me out...I also recompiled my kernel with all the right networking options enabled, but I still have to run netconfig to use the internet. I've noticed that linuxconf won't work for this.

....still looking for an answer...

k0jack
0
 
crouchetCommented:
Ok, I looked over your question again and it really sounds like a DNS problem or a routing problem. The cable modem stuff should not really affect it as it just treats that as a router (it's own IP & all).

I am no DNS guru, but I will see if I can help.

When you say you can ping the W98 machine, do you use the IP or a name? When you ping your ISP, do you use a name or the IP?

Oh, wait, I know what is wrong...

The IP for the modem is 10.129.x.x, the IP for your computer is 142.64.59.210. When you set up a netmask of 255.255.248.0 that screens off those bits that are covered with the 255 and 248, so it could find addresses in the 142.64.59.1 to 142.64.67.255 range.  As it is your computer thinks that 10.129.x.x is outside your subnet. It does not know how to route the packets to get them there.

I am making some leaps here that I really don't fully understand, but I think the combination of IPs and netmask is the problem.

Don't try to fix this by changing the netmask or it will try to find anything you unscreen on your local subnet.

I think you need something like IP masquerading. Check that out and see if the HOWTO tells you more. Also, you might want to check some of the previous answers on this forum.

My coworker who is the real DNS/IP guru around here will be back on the 3rd, so if you are still hung up then I will ask him for advice.
 
J Crouchet
0
 
crouchetCommented:
It also occurs to me that the address you originally gave for the modem is a private class A network IP. What that means is that it is unlikley to that 10.129.x.x is actually a working internet address.

So, part of the problem has to be that your modem is not getting a good address for the internet.

Do I understand that your Win98 box DOES use your ADSL modem ok? If so, can you bring that up and see what the modem's IP is when connected with the Win 98 box?

J Crouchet
0
 
crouchetCommented:
Ok, a buddy and I did some checking on the Alcatel "modems". The ADSL does not work as a router, it works as a bridge. That means it should provide a direct line to the internet without the need to have an IP address for the modem itself.

So what is your 10.129.x.x address for? Well, if you point your web browser at that address it should bring up a web page that will allow you to configure your modem (cool feature). And that *IS* an approprate use for a private address. However, the default for that address is 10.0.0.138.

Ok, next question is, what is the model number of your modem? It turns out that all Alcatell 100 modems are not created equal. I assume you do not have a ATML model, so you either have the bridge model (described above) or the PPP model.

Here comes that bad news. If you have the PPP model and your ISP is using PPP for it's ADSL, it requires the MICROSOFT version of VPN tunneling to establish a connection.

What you need to ask your ISP is if they are providing bridged service.

My buddy (who knows this stuff better than me) says your DHCP on your Linux box is screwed up. You should not be getting a 10.x.x.x address for your Linux box. Rather, you should get an address comparable to the IPs you get for your Win box.

I would suggest you use that 10.x.x.x address that you have (or the default I posted above) to check your modem's configuration. Then dig into the DHCP setup on your Linux box.

J Crouchet
0
 
Bo0gi3manCommented:
Also some versions of linux won't recieve dhcp data correctly from adsl routers.  Especcially cisco routers, and Alcatel (based on cisco).  You may have to enter your ip data manually on the linux box.  I my self have dsl and would be more than happy to help you out.  My email address is admin@web-docs.net.  Gimme an email and we'll see what we can do.  My icq number is 39784898.

Bo0gi3man
0
 
lewisgCommented:
You need a NAT/firewall box!

Go to www.sharethenet.com and look at their product. You can either pay the money or roll it yourself. Either way the download version allows a 30 minute connection before it has to be rebooted - long enough to troubleshoot.

Install the software on a old 486 box w/8megRAM,2 NIC's and a floppy and hook it between the ADSL box and your hub.

Enjoy and be safe! OR:

Hook both computers to the hub with the ADSL box. Check the cable! The one that came with ours was a "null" cable, the green and orange pairs swapped! Most ADSL boxes do not have an IP address. Your ISP should have given you an IP address for both compters (fixed IP's) or a IP for a DHCP server or told you to leave all the IP's and other settings blank on the windows machine and given you a blank stare when asked about linux. In any case it sounds like your BEST option is to get a NAT/firewall as described above!
0
 
k0jackAuthor Commented:
If the windows machine is able to recieve the correct dhcp information and connect immediately to the internet, then Linux should be able to do the same. I don't believe the answer lies in obtaining another computer to act as a firewall...if this was NEEDED, then windows would require it to. There has got to be an answer to this question that will work with my existing hardware/software package.
0
 
k0jackAuthor Commented:
I have increased the points to 150...I guess this question is a little harder than previously thought.
0
 
lewisgCommented:
You don't NEED to wear a seat belt in order to start or drive a car - but it is a good practice!
0
 
sirwnstnCommented:
How about trying this:
You say that your win-box works with DSL, so set up your linux-box with the network settings your ISP's DHCP assigned to the win-box.  Then fire up your win-box and see if they'll automatically assign it another IP addr.  This should work, but of course it doesn't address your linux-box's DHCP problem.
0
 
k0jackAuthor Commented:
Thanks for that last suggestion. I did what you said, and I got the same results as I did initially. I can actually setup networking manually when in linux now and have it work. But I have to do it each time I reboot, and it doesn't solve the problem anyway. I have a few other friends and associates that are working with the same problem. It seems to be a common problem with linux systems. I have experimented with the DHCP client setting on linux, but, again, to no avail.
0
 
Bo0gi3manCommented:
that should work for ya, I know how annoying it is to have to start services manually everytime you boot a computer.  solution don't reboot, or edit the scripts.

have phun,
bo0gi3man
0
 
Bo0gi3manCommented:
btw,

I think I commented this b4.  Linux does have serious problems recieving dhcp data from routers.  If you had another linux box set up as dhcp server or even if you set your linux box up as dhcp server you could get it working.  All you would have to do is remove dhcp capabilty from the modem, and add it to the linux box.  If you are interested in this, give me a ring.

Again, it would be simpler just to edit the script.  Thnx.  Bo0gi3man
0
 
crouchetCommented:
Is it possible that your Linux box has an active DHCP  server? If so, wouldn't that mess up it's ability to accept DHCP from other addresses?

I think we are missing something simple here, but I can't figure out exacly what. I'll see if I can get my buddy (the one who knows DHCP and DNS so well) to take a look.

J Crouchet
0
All Courses

From novice to tech pro — start learning today.