• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 226
  • Last Modified:

FTP problem, can connect but that's all

Here is my problem:
I'm using wu-ftpd

The server has 2 NIC, one for the internal network, and the other one for the world.
This server is used with "forwarding" rule from firewall options.

From the server, I can use ftp normally,
but from workstations (behind the firewall) i can use web, but if  try to use ftp, I can pass user identification, but after, it hangs during LIST command.  And nothing to do.
I tried this from the firewall itself, and it works, so I think it's an error with my firewall rules but ????

(Linux is RedHat 6.0)

1 Solution
Verify your firewall rules from ftp... I used AltaVista Firewall and I had to set it up to "transparent connection". If your firewall is correctly configured, try to see your router configuration (every pack to the outside network should pass throught your firewall) and verify your client configuration too (It must be configured to use firewall (IP and ports) and must be with correct option (OPEN Site or user@site or other...))

I hope it helps...
  Andre Langkjer.
aldricAuthor Commented:

I just forgot to add ftp in my firewall
rules    (oups :=)   )
You could have always used pasv mode in the ftp client programs behind the firewall.... That way you don't have to play with firewall settings and still have access to ftp.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now