nslookup returns core dump

I've got a fresh install of RH 6.0, and when I run the nslookup command, I get the following error:

Illegal instruction (core dumped)

and have a file called core in the current directory. nslookup worked fine in RH 5.2, but after I did an FTP upgrade to 6.0, it quit working. Due to some other problems, I got a RH 6.0 CD and did a clean install, and it still won't work!

Any ideas? The computer is a NexGen 586, and that is the only trouble I have. I've got LinuxPPC (which is RH 6.0 ported to the Mac/PowerPC platform) running on a different machine and nslookup works fine on that one, even though it's also RH 6.0.

I am pretty new to the wonderful world of Linux, so a walk-through solution would be greatly appreciated.

Thank you to everyone for the help!
LVL 2
andyringAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Anju111599Commented:
Have you tried running it as root?

First find out where the problem is.  Run "strace nslookup" to trace through nslookup's system calls.  This should give you a clue where it's dying.

Next, check your networking settings.  Is networking support compiled into the kernel?  What options?

Finally, check your zone files to make sure there's not a simple configuration problem.  One would hope that nslookup couldn't be crashed by a config error, but I've seen stranger things.  The install moves the pre-install files to backup files, so check to make sure the new files don't have something nslookup doesn't like.

Let me know if this helps.  If not, we'll continue looking.

Anju
0
andyringAuthor Commented:
well, I did the strace nsoookup command, and here are the last few lines:

fstat(3, {st_mode=S_IFDIR|SISUID|S_ISVTX|0316, st_size=0, ...}) =0

mmap(0, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40014000

read(3, "domain andyring.com/nsearch andy"..., 4096) = 92

---SIGILL (Illegal instruction) ---
+++ killed by SIGILL +++

Yes, this is being run as root. Networking support is compiled into the kernel, as this machine is being used as a small internet server (andyring.com) for web, mail, ftp, etc.

Zone files? That's not a term I'm familiar with, but you obviously know more about this than I do. Does the above output give you any hints?

Thanks and Merry Christmas!
0
Anju111599Commented:
So, it's doing an fstat to get statistics on an open file descriptor, and that returns zero which is okay.  Then the read returns 92 bytes, then gets an illegal instruction.  Sounds like buffer overrun.  This might happen if your DNS zone files are corrupt, although I'd hope nslookup is more robust than that.

Your networking is configured okay?  Can you use NetScape to browse a web site?  I'll assume you can.

Lets check the zone files next.  Zone files are your DNS configuration files.  Check the HOWTO at http://www.redhat.com/mirrors/LDP/HOWTO/DNS-HOWTO.html

Let me know what you find.  If this still doesn't fix it, we'll keep looking.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Anju111599Commented:
Oh, I almost forgot, Merry Christmas to you too!  I hope you have a happy New Year :)
0
andyringAuthor Commented:
Networking is configured ok as far as I can tell. Browsing the web works fine, as do all other tasks (web serving, mail, ftp, etc.). This machine (andyring.com) is a small Linux server I set up at home with my ADSL line.

Anyway, I'm thinking it has something to do with a misconfiguration on my end. When I try to run named, I get the same thing happening. Here's my named.conf file, does it look ok?

options {
      directory "/var/named";
};
zone "." {
      type hint;
      file "named.ca";
};
zone "andyring.com"{
      type master;
      file "andyring.com";
};
zone "0.0.127.in-addr.arpa"{
      type master;
      file "named.local";
};

The nameserver I use is dns.inetnebr.com (199.184.119.1). Here is my /var/named/andyring.com file if that helps at all.

@            IN      SOA      www.andyring.com.      root@andyring.com. (
                  1999122501 ; serial
                  3600 ; refresh
                  900 ; retry
                  1209600 ; expire
                  43200 ; default_ttl
                  )
@            IN      MX      5      www.andyring.com.
@            IN      NS      www.andyring.com.
@            IN      NS      199.184.119.1.
www            IN      A      206.222.216.42

Thanks so much for the help. Remember, though, I'm very much a novice here, so the more you are able to give me a walk-through approach, the better.
0
Anju111599Commented:
Looks like you're using named version 8.  I'm not familiar with that version (I have the older version), so we'll just have to stumble through as best we can.

Let's start with /etc/nsswitch.conf.  It should have a hosts entry something like the following:

hosts:      files nisplus nis dns

If you're not running NIS, yours will only be "files dns".  If you don't have a hosts entry, add one.

Next, /etc/resolv.conf.  It should look something like:

domain andyring.com
search andyring.com
nameserver 127.0.0.1
nameserver 199.184.119.1

Now on to /etc/hosts.conf:

order hosts,bind
multi on

Your /etc/hosts file should look something like this:

127.0.0.1 localhost loopback
206.222.216.42 andyring.com

This should take care of the basics.  Now on to named configuration.  Your named.conf should look like this:

options {
directory "/var/named";
};
zone "." {
type hint;
file "named.ca";
};
zone "0.0.127.in-addr.arpa"{
type master;
file "named.local";
};
zone "andyring.com"{
type master;
file "andyring.com";
};

The file named.local should look like this:

@ IN SOA www.andyring.com.   root.andyring.com. (
  1999122501 ; serial
  3600 ; refresh
  900 ; retry
  1209600 ; expire
  43200 ; default_ttl )
     NS andyring.com.
1    PTR localhost.

Please note the mail address "root@andyring.com" has the asterisk (@) replaced with a dot (.), and this is important!

The file andyring.com should look like this:

@ IN SOA andyring.com. root.andyring.com. (
  1999122501 ; serial
  3600 ; refresh
  900 ; retry
  1209600 ; expire
  43200 ; default_ttl )
          NS ns ; Your name server
          MX 5 mail
localhost A 127.0.0.1
ns        A 206.222.216.42
mail      A 206.222.216.42
www       A 206.222.216.42

At this point you can try the ndc reload command, then check the results with a "nslookup andyring.com" to see if we're on the right track.  If so, we're half way there.  We still have to do the reverse lookup files.  The reverse lookup files let you get a domain name from an address.

Add this to named.conf:

zone "216.222.206.in-addr.arpa" {
        notify no;
        type master;
        file "andyring.rev";
};

File andyring.rev should contain:

@ IN SOA andyring.com. root.andyring.com. (
  1999122501 ; serial
  3600 ; refresh
  900 ; retry
  1209600 ; expire
  43200 ; default_ttl )
42 PTR www.andyring.com.

Once more, do ndc restart, then nslookup 206.222.216.42 should return andyring.com.  If not, look for errors in syslog and let me know what they are.  We'll go from there.

Anju
0
andyringAuthor Commented:
OK, I got through the first part of that, and tried the ndc reload command, and got the following:

ndc: error: ctl_client: evConnect(fd 3): Connection refused
ndc: error: cannot connect to command channel (/var/run/ndc)

Any ideas? Once we get this figured out, I'll continue with the reverse stuff.

Thanks so much! I'll be more than happy to unload a bunch of points on you once we get this thing going.


Andy
0
Anju111599Commented:
The named service may not be running.  Issue a "ndc restart" command and check syslog.  If this *still* doesn't work, try going to a shell prompt and do the following as root:

cd /etc/rc.d/init.d
../named stop
../named start

And by the way:  You're quite welcome :)
0
andyringAuthor Commented:
OK, I think we need to take a step backwards here. I noticed upon booting the system that named fails to start. When I attempt to stop named or start it from the shell prompt (I rarely, if ever, use X), I get a [FAILED] message. When I issue 'ndc restart', I get an error also.

ndc: error: could not star new name server (/usr/sbin/named )

So for whatever reason named doesn't want to start.

This is getting frustrating!
0
Anju111599Commented:
I can understand your frustration.  I know quite well the helpless feeling one gets when nothing seems to work and one doesn't know where to begin looking to solve the problem.  Unfortunately, that's the way it often is with computers.  There are times when I have to walk away from it for a while.  However, I've found that patience and persistence eventually pay off.

Can you look at the syslog for me?  The messages file should be "/var/log/messages".  You can do a "grep named messages > named.msgs" (must be done as root) instead of having to wade through the entire messages file.  If there's not enough info to figure it out, you can start named with extra debugging output turned on:  "named -d <debuglevel>", where <debuglevel> is a number.  Try debug level 9.  That should give us lots of stuff to look at so we can try to figure out what is giving named indigestion.

Hang in there!  I'm going to stay with you until we solve it :)

Anju
0
andyringAuthor Commented:
That's what I get. Not too helpful. When I set the level to 9, I still get the core dump and no help. Heck, I'm about ready to give you an account on the machine with superuser access and see if you can make sense of any of it! Heck, if that sounds feasible, drop me a line at andyring@inetnebr.com.

Dec 27 22:43:23 www named: named startup failed
Dec 28 08:18:39 www named: named shutdown failed
Dec 28 08:18:48 www named: named shutdown failed
Dec 28 08:18:54 www named: named startup failed
Dec 28 18:44:16 www named: named shutdown failed
Dec 28 17:10:23 www named: named startup failed
Dec 28 17:12:23 www named: named shutdown failed
Dec 28 17:12:29 www named: named startup failed

0
Anju111599Commented:
Andy,

The following does the trick:

1.  Download the bind source, build new binaries, install.
2.  Re-Check zone files.
3.  Set system clock.

Anju
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
andyringAuthor Commented:
Excellent help, Anju. Thanks again.

-Andy
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.