Modem setup in RH 6.1

Well, I got everything installed but when I tried to connect, Linux didn't see my modem. I went into the setup and guessed at which device it was (took the default choice which was 0). Well, it didn't work and now I get errors when I try to delete or edit the improperly setup modem.

My modem is a USR Sportster Internal (not winmodem) which lives on com2, IRQ 3. Linux has it setup on com1, don't know which IRQ.

Is there a file I can manually edit that holds these settings? Where might it be?
capttomAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

j2Commented:
first of all, if you modem is ttyS1 that IS com2, since linux enumerates from 0. If this is a Plug And Play modem, you also need to set up isapnptools and setserial to get it to work.

You could look in /proc/interrupts and /proc/devices to see if it is listed.

Exactly what error do yuo get? It probably tells you that it cannot find the device.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
capttomAuthor Commented:
I suppose it is plug and pray so how to setup those things? i've forgotten the exact error msg and pc is at home. When I try to edit or delete the modem it errors. It's nothing so simple or intuitive as "device not found", some sort of segmenation error or similar... I'll check when I get home.

Why is it that Linux can find and setup most devices but refuses to do so on modems and sound cards? It's starting to come back to my mind why I ditched Linux previously....
0
j2Commented:
Cause modems and soundcards refuses to stick to a standard. ;)

Basically you do

pnpdump > /etc/isapnp.conf
this will create a file in containing your Pnp info. Then you edit that file to chose the right resources for the cards found (hopfully it finds the modem ;))

then you do a

isapnp /etc/isapnp.conf

to load the config data to your devices.
(has to be done on every reboot)

then you do a setserial /dev/ttyS1 autoconfig

(autoconfig works if the modem is on a "standard" IO / IRQ pair, if not use setserial /dev/ttyS1 irq X port 0xZZZ")

then do "rm /dev/modem ; ln -s /dev/ttyS1 /dev/modem"

and if this is a PCI modem, it isnt supported at all ;)
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

capttomAuthor Commented:
well, that didn't work. i ended up reinstalling Linux and choosing KDE desktop instead of Gnome. i went in and configured the modem using the right settings, that took care of the error messages but still get "Sorry, modem didn't respond" when I try to dial.
 
0
j2Commented:
exactly which model is this?

And did you try the isapnp route?
0
capttomAuthor Commented:
It's a USR Sportster 56k (updated to V90) internal. Its set on COM2, IRQ 3. yes, I tried the isapnp thing, it errored out. If it has to be done on every boot it's not the right answer anyway I think as I had a previous version of RH running fine on another machine with the same model modem.
0
j2Commented:
"If it has to be done on every boot it's not the right answer anyway"

Yes, but you just slap it in a rc.d file, and it is automatic.

Make sure the onboard com2 is disabled in BIOS (if you have one)
0
ahoffmannCommented:
please check with
  setserial -a /dev/ttyS0
  setserial -a /dev/ttyS1
if it matches what you see in /proc/{interrupts,devices}
In doubt, post the results.
Then make shure that your programs (rc.d scripts or whatever) use these devices (ttyS[1-4]) and not some symbolic ones like /dec/modem (which simply has to be a soft link to the right ttyS? )

You also did not tell us which program refuses to work with the modem, did you try minicom?
Keep in mind that some programs rely on /dev/cua? instead of /dev/ttyS?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.