apmd date wrong

why is the date wrong after wakeup from a long suspend?
I've tried all the latest apmd versions. The hardware clock is fine but the system time is wrong. The minutes are
correct but the timezone is off by 5 hours (I'm on EST).
Who is Participating?
biardConnect With a Mentor Commented:
It sounds to me as though you selected GMT time during the install.  If you did, you need to set your bios clock to 5 hours ahead of EST.  See below.

There are some ramifications to selecting GMT (same as UTC) for your
system clock during the install (or later)

1) your CMOS clock needs to be set to GMT (5 hours ahead of EST).

2) if you set the time in Linux using date, be sure to use EST.

3) if you set the hardware clock using clock, be sure to use the -u
switch to indicate that the hardware clock is in GMT.

4) make sure your timezone is set properly; you can use
/usr/sbin/timeconfig to reset the timezone.

Setting your system clock to GMT allows for Linux to correctly set the
time from various daylight savings zones.
aprusso10Author Commented:
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.