• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 325
  • Last Modified:

Real Player G2 vs. CD Player

I installed RealPlayer G2 (version 6.06.99) from the web and now my Windows CD Player is acting strange. It no longer auto-launches when I put in a music CD. I have to start it up manually. And if I change the music CD, the CD Player won't recognize the new CD unless I shut it down and relaunch it. This is only happening since I installed Real Player. Software CDs work fine (auto-launch okay). The problem is only with music CDs.

I'm running Windows NT 4.0 Build 1381 SP5 on a Dell PentiumII-350
0
suzyQ
Asked:
suzyQ
1 Solution
 
zeiszlerCommented:
Hi,

I have RealPlayer 7 Basic V6.0.7.362 on NT4.0 SP4 and it works fine for CD auto launching.  I do notice that the CD image in NT explorer looks like the real player.  
Check for updates for your Real products.
Do you have the Real Jukebox loaded?
Have you contacted support at www.real.com? 
Sorry this isn't much help.
0
 
suzyQAuthor Commented:
I don't want to update it because I don't like it.  I may even uninstall it.  Nope, I'm not running RealJukebox.  Also, I reclaimed all of the filetypes for which it had made itself the default application.  I reassociated them with their original apps.  I HATE it when a proggy does that!

I didn't contact their customer support because I figured they'll just tell me to download the latest, greatest version.  Blechhh!  My co-worker suggested that maybe one of the experts here would know the quick fix.  Registry hack, anybody???
0
 
maharustyCommented:
There are two options in the registry for autorunning cd's.  One is for software cd's and the other is for audio cd's.  TweakUI, one of the Microsoft powertoys has the ability to set this.  You can get it from the Microsoft web site.  I have also enclosed a couple of registry hacks that I found that should do the trick also.  I would be most likely to try Option 1.  That is the way it is set on mine for shutoff.


Option 1

1.Change the Autorun value in the following registry key:
             HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom

          2.To disable the Autorun feature, change the Autorun value to 0. To enable the Autorun feature,
             change the Autorun value to 1.

          3.Restart the computer.



Option 2

Run the Registry Editor (REGEDIT.EXE).
            Open HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer.
            Change the Value of NoDriveTypeAutoRun from 95 00 00 00 to BD 00 00 00.
            You might have to restart Windows for this change to take effect.
0
 
suzyQAuthor Commented:
Thanks maharusty! I tried your registry hacks but they didn't solve the problem. (I didn't bother with TweakUI since I don't mind fiddling around with regedit) I went back to zeiszler's comment and downloaded the update for RealPlayer. That didn't help either. I was all set to contact RealPlayer Support when I realized the simplest solution was to let Windows NT restore the CD Player functionality for me. So I zapped my cdplayer.exe and used the Windows disc to re-install it. Problem solved!

You didn't fix my problem, but I'll give you points for the e-mail!  :-*
0
 
kodiakbearCommented:
Fixed the -1 problem on this question.
Escrow points corrected.

kb
Community Support Moderator
Experts Exchange
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now