• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 262
  • Last Modified:

New DELL OPTIPLEX GX1 with 13.8 Gb HD and Linux

Does anybody have the right CCC/HHH/SSS info for this drive? The DELL BIOS is totally screwed up and Linux only uses the drive as a 8 Gb unit. I used a similar drive on an ASUS P2BF motherboard and that worked flawlessly.

DELL also partitions their machine in some weird way which makes CFDISK (debian) barf and so does PartitionMagic :-(


Bye, Arno.
1 Solution
If you have a WD disk, you might find it convenient to download the typed util from wdc's web site:


It properly reports C/H/S of WD drives.

The (booting from a floppy) kill the start of the disk using dd (NOTE - hda IS THE NEW DISK):

dd if=/dev/zero of=/dev/hda bs=64k \ count=2

(128kb is actually MAJOR overkill, but I believe in massive overkill)...

Then try again.
griffioenaAuthor Commented:
Thanx.. Turned out that if I used a 2.2.x kernel as installation kernel that it will handle the drive OK. Seems like 2.0.38 and the like don't grok these drives in combination with the tings the DELL BIOS tells them.

Under 2.2.x the partition table can be understood (after some grumbling) by simple 'fdisk'. Making some trivial changes and then letting 'fdisk' write it back again makes the rest of the tools happy too.

Thanx for the pointer anyway! Machine is now happily buzzing along.

Bye, Arno.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now